Abs light and traction conrrol light on - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-09-2014, 06:20 PM   #1
Jeeper
 
Join Date: Nov 2011
Posts: 34
Abs light and traction conrrol light on

My abs light and traction control light came on today anybody have any ideas of what I can check or fixes. Why???? Thanks Dave

krumby is offline   Quote Quick Reply
Old 03-09-2014, 06:24 PM   #2
Jeeper
 
dwtgolden's Avatar
 
Join Date: Sep 2012
Posts: 308
This is just a guess, but I would say a faulty wheel speed sensor. These sensors are used by the ABS system to determine if a wheel is skidding and by the traction control to determine if a wheel is slipping. If a sensor is bad, it would cause a fault in both systems.

dwtgolden is offline   Quote Quick Reply
Old 03-09-2014, 08:19 PM   #3
Jeeper
 
armyretiree's Avatar
 
Join Date: Jul 2011
Posts: 66
Just had my left rear sensor replaced Friday exact symptoms!
armyretiree is offline   Quote Quick Reply
Old 03-09-2014, 08:19 PM   #4
Jeeper
 
Join Date: Nov 2011
Posts: 34
Yeah the jeep reacted funny for a short bit like the brakes were stuck and it made some noise too
krumby is offline   Quote Quick Reply
Old 03-09-2014, 08:24 PM   #5
Jeeper
 
armyretiree's Avatar
 
Join Date: Jul 2011
Posts: 66
My cruise would not engage, and no hill assist... I had a code of U1417!
armyretiree is offline   Quote Quick Reply
Old 03-10-2014, 07:44 PM   #6
Jeeper
 
Join Date: Nov 2011
Posts: 34
Yup I have the same thing no hill assist or cruise control
krumby is offline   Quote Quick Reply
Old 03-10-2014, 08:32 PM   #7
Jeeper
 
Chaz1294's Avatar
 
Join Date: Jan 2014
Posts: 63
I was driving at about 75mph In TX panhandle. Strong
Chaz1294 is offline   Quote Quick Reply
Old 03-10-2014, 08:36 PM   #8
Jeeper
 
Chaz1294's Avatar
 
Join Date: Jan 2014
Posts: 63
I was driving in TX Panhandle last week with strong cross wind, and cruise on. All of sudden ESC light came on and cruise went off. Stopped and turned off Jeep but ESC stayed on. Went to next exit and let sit for a few mins shut off. Turned back on and ESC went off. Drove without cruise after that. All good. May just need to cycle on and off a few times. If that doesn't work could be bad sensor.
Chaz1294 is offline   Quote Quick Reply
Old 03-10-2014, 09:12 PM   #9
Jeeper
 
armyretiree's Avatar
 
Join Date: Jul 2011
Posts: 66
Quote:
Originally Posted by Chaz1294 View Post
I was driving in TX Panhandle last week with strong cross wind, and cruise on. All of sudden ESC light came on and cruise went off. Stopped and turned off Jeep but ESC stayed on. Went to next exit and let sit for a few mins shut off. Turned back on and ESC went off. Drove without cruise after that. All good. May just need to cycle on and off a few times. If that doesn't work could be bad sensor.
If your light went off I would disconnect your battery and then reconnect...may clear any codes and restore cruise!

armyretiree is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:36 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC