brakes make squeak sound only at a slow stop - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-07-2013, 07:16 AM   #1
Newb
 
Join Date: Jul 2013
Posts: 1
brakes make squeak sound only at a slow stop

I have a 2013 4 door Sahara. It has only 1,200 miles on it and recently I noticed that when I apply pressure at a normal brake (stopping at faster speeds) all is good and normal. However, when I'm creeping up to a stop sign, for example, and apply pressure to the brakes there is a odd squeaky/clunky noise that only occurs, not as I'm braking but as I apply pressure at the time of my final stop. Does anyone know what may be causing this?

And, a second question, I was attempting to pull a friend's vehicle out from being stuck, and during this attempt my engine light came on. It's not blinking but it's not going away either. It has been like this for 2 days now. Wasn't because of a loose gas cap. I'm going to get it to the dealer in the next couple of days but hoping it's not because of anything from attempting to tow my friend out of muddy terrain.

tg14226 is offline   Quote Quick Reply
Old 07-07-2013, 09:18 AM   #2
Jeeper
 
Wingsnut72's Avatar
 
Join Date: Aug 2012
Posts: 392
Quote:
Originally Posted by tg14226 View Post
I have a 2013 4 door Sahara. It has only 1,200 miles on it and recently I noticed that when I apply pressure at a normal brake (stopping at faster speeds) all is good and normal. However, when I'm creeping up to a stop sign, for example, and apply pressure to the brakes there is a odd squeaky/clunky noise that only occurs, not as I'm braking but as I apply pressure at the time of my final stop. Does anyone know what may be causing this?

And, a second question, I was attempting to pull a friend's vehicle out from being stuck, and during this attempt my engine light came on. It's not blinking but it's not going away either. It has been like this for 2 days now. Wasn't because of a loose gas cap. I'm going to get it to the dealer in the next couple of days but hoping it's not because of anything from attempting to tow my friend out of muddy terrain.
My 2013 unlimited rubi has the same issue with the brakes. I've got use to the noise (almost 8,000 miles). I think it's because of crappy OE brake pads. All I know is that they shed brake dust worse that a long haired dog shedding hair on a hot day. My wheels look like crap!

Wingsnut72 is offline   Quote Quick Reply
Old 07-07-2013, 10:10 AM   #3
Jeeper
 
iNizo's Avatar
 
Join Date: Oct 2011
Posts: 187
Re brake noise its normal. Many here have this issue.. Re engine light its not normal and you need to take it to the dealer...
iNizo is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 12:09 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC