Bug shield problem - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-18-2012, 10:24 AM   #1
Newb
 
Join Date: Nov 2012
Posts: 1
Bug shield problem

Hello all. I have a Wade bug guard. I installed one previously and had it crack and fly off the truck on the highway. It was cracked right down the middle so I figured, just a rock hit it and split it so that's why it came off. Well, I have my second one on now and noticed while I had the hood up that 3 out of 4 of the tabs that hold the shield on are broken. It's hanging on by one screw! Has anyone else had this problem? Is there a solution? Does the weathertech shield attach differently? and does it come in clear?

Tianne is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 02:32 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC