Burning smell after a little mudding - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-10-2012, 09:52 PM   #1
Newb
 
Join Date: Apr 2012
Posts: 3
Burning smell after a little mudding

So me and my brother went mudding yesterday, got stuck and had to be winched out by another jeep, and now all I can smell when I drive is sort of a burning clutch smell. I washed underneath 3 times and got all the mud off the undercarriage and wheels. Its a 2012 with only 4000 km on. It also feels a little shaky while starting off in first gear since then. What could this be? I know I was a bit hard on my clutch trying to get unstuck.

Cheers!

colton.higgins is offline   Quote Quick Reply
Old 04-10-2012, 10:08 PM   #2
Jeeper
 
Casotakar1229's Avatar
 
Join Date: Mar 2012
Posts: 2,217
welcome to wf.

when I run the clutch really hard and even when I go wot for that matter, I get a "burning smell" and some nice exhaust fumes. sounds normal to me...but surprised you never smelled it before. fairly new engine you got there too...

Casotakar1229 is offline   Quote Quick Reply
Old 04-10-2012, 10:47 PM   #3
ESP
Needs stuff..
 
ESP's Avatar
 
Join Date: Jun 2010
Location: NC
Posts: 11,116
A little mud doesn't get you stuck. I don't think we are getting the full story here. You need to really clean every inch of your jeep. If you had both axles submerged under water/mud then check your breathers to make sure they are still connected and no liquid entered.

Did you use your clutch while in the mud? If so, you've let in a lot of garbage into your tranny.
__________________
Behold...THE LEGENDARY ESP

98 XJ 02 TJ 10 JK 13 JK

ESP is offline   Quote Quick Reply
Old 04-11-2012, 10:28 PM   #4
Newb
 
Join Date: Apr 2012
Posts: 3
I wasn't at all submerged in water or mud. My drivers side wheels weren't even stuck it was just my passenger side. It was just really heavy mud, no water at all. I did ride the clutch really hard trying to get untuck. Underneath wasn't even that muddy, mostly just stuck to the skid plates. I couldn't spin my wheels to get mud everywhere. All the mud was mostly on the wheels. So I'm confused on why it still stinks. I'm new to four wheeling, don't know a lot about it and what to do in some situations.
colton.higgins is offline   Quote Quick Reply
Old 04-12-2012, 12:06 AM   #5
Jeeper
 
MarineHawk's Avatar
 
Join Date: Dec 2011
Location: Virginia
Posts: 700
Quote:
Originally Posted by ESP View Post
...Did you use your clutch while in the mud? If so, you've let in a lot of garbage into your tranny.
I'm starting to like the fact that I have an auto trans with raised breathers.
MarineHawk is offline   Quote Quick Reply
Old 04-12-2012, 12:18 AM   #6
Jeeper
 
WatchThis!'s Avatar
 
Join Date: Jul 2010
Location: East Texas
Posts: 3,800
Images: 3
Did you remember to turn your traction control off if you were in high range? That could be why you had to be hard on your clutch.
__________________
I'm here to participate. I didnt come all this way just to watch.

My jeep's thread http://www.wranglerforum.com/f33/che...st-111461.html
WatchThis! is offline   Quote Quick Reply
Old 04-12-2012, 02:48 AM   #7
Ex Navy man
 
rics1997's Avatar
 
Join Date: Oct 2010
Location: Bristol, Tn
Posts: 4,767
If you change gears in high mud, you can get mud between the clutch causing issues. Never use the clutch in high water or mud
__________________
2010 Dark Charcoal Pearl Jeep Wrangler Sport S Automatic
4.88 Yukon w/Trac-Lok rear and Eaton ELocker Front - Synergy Gussets - B&M 70264 Trans Cooler
BDS 3" lift - BDS Fox 2.0 Racing Shocks
XHD front Bumper - Trektop NX - Goodyear MT/R w/Kevlar 35X12.5X15 on MB Chaos 5 Wheels - Thrush Turbo Muffler

Become a WranglerForum Supporting Member!
rics1997 is offline   Quote Quick Reply
Old 04-12-2012, 05:26 AM   #8
Jeeper
 
joe buell's Avatar
 
Join Date: Jan 2012
Location: Florida
Posts: 517
for what its worth the first time i had my 12 jk in the mud got a real bad clutch burning smell and mine is a auto i was realy giving it hell buried it to the frame only 3k on it assumed smell was from exhaust/ maybe cat converter smell went away after a couple miles on the way home was realy worried but norm i guess
joe buell is offline   Quote Quick Reply
Old 04-12-2012, 07:09 AM   #9
Jeeper
 
OH9JK's Avatar
 
Join Date: Oct 2011
Location: Graham, NC
Posts: 738
Ahhh the smell of burning clutch and mud....in all seriousness make sure you hose off real good. Mud likes to get into everything and causes all sorts of crazy issues. Most likely you have some leftover mud sitting on top of your cats or muffler.
__________________
Crowded elevators smell different to midgets.
OH9JK is offline   Quote Quick Reply
Old 04-12-2012, 08:05 AM   #10
Newb
 
Join Date: Apr 2012
Posts: 3
Yeah I never changed gears at all. And I was in 4hi and forgot about traction control, whoops. After reading up about it, turns out 4lo is a pretty useful tool eh, wish I woulda know that at the time. I even had it checked out in the shop yesterday and they said everythings fine so ill just hope the smell goes away I guess. I'm probably just worrying to much lol.
colton.higgins is offline   Quote Quick Reply
Old 07-17-2012, 10:07 AM   #11
Newb
 
Billabong73's Avatar
 
Join Date: Jul 2012
Posts: 11
I have the same clutch smell and stutter at 1st gear take off. But mine was after some sand action. I also forgot to turn of the traction control. I hate that button! I did give the under carriage a good "hows ya father" when I got home.

Only 2K on my '12 JKU, going to bring it to dealer, hopefully they will replace clutch (it is warrantied to 12K miles).
Billabong73 is offline   Quote Quick Reply
Old 04-03-2013, 05:27 PM   #12
Jeeper
 
JEEP425's Avatar
 
Join Date: Apr 2013
Posts: 17
Same thing happened to me when driving my '12 JKU Manual... I think it was just mud on the exhaust because it went away with in a mile or 2 down the road.

JEEP425 is offline   Quote Quick Reply
Reply

Tags
clutch , problem , smell

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:06 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC