Cam Phasers gone bad, less than 5k miles! - Page 2 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-18-2013, 12:25 PM   #31
Jeeper
 
scipio337's Avatar
 
Join Date: Jul 2012
Posts: 1,285
Quote:
Originally Posted by nitroz680 View Post
Dude...that sucks. But with your engine being that new, I'm guessing that HAS to be electronic. Any difference in ride characteristics?

A little at idle. You feel the cylinder misfire (I think). I'm sure the dealer will take care of it, but it's pretty annoying. Glad I found the thread, I will have to follow your progress.

scipio337 is online now   Quote Quick Reply
Old 06-18-2013, 12:33 PM   #32
Jeeper
 
Join Date: Feb 2013
Posts: 285
Hmm...yea Jceo noticed a bit different ride quality I think. I'm sure the dealer will be able to diagnose but make sure you ask them if they inspected for wear on the cam lobes.

Hope its not in the shop too long :/

__________________
2013 JKU Sahara
nitroz680 is offline   Quote Quick Reply
Old 01-27-2014, 07:22 PM   #33
Sponsoring Vendor
 
DynoMax Exhaust's Avatar
 
Join Date: Sep 2012
Posts: 178
So.. this just happened to my 2013 JKU with 3700 miles, getting replaced right now. Weird thing no code was thrown that I was able to see by doing the key trick. ECO didn't work and ran rough for a short time.
__________________

www.dynomax.com
DynoMax Exhaust is offline   Quote Quick Reply
Old 01-27-2014, 11:31 PM   #34
Jeeper
 
cheap4tw's Avatar
 
Join Date: Feb 2012
Location: Toronto, Ontario, Canada
Posts: 428
I had the cam phasers done on my 2012 at around 45000km on the odometer. Not sure if I'm nuts or not but after they did them my mileage seemed to become more consistent.

cheap4tw is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:55 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC