Check engine light / Code P2096 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-09-2013, 08:16 AM   #1
Jeeper

WF Supporting Member
 
kev324's Avatar
 
Join Date: Mar 2011
Location: Massachusetts
Posts: 242
Check engine light / Code P2096

My 2012 JK (Auto, 33k miles, cylinder head replaced) CEL came on this morning. The code is P2096. I have only heard of TJs with this code, not JKs.

Here's what I was doing: I was driving at about 50mph for 30 miles with about 4" of snow on the road. I had the gas pedal pushed way down just to maintain my speed. Under normal conditions, my Jeep would have been doing 90+mph with accelerator pushed so far down.

If anything, I would have expected the "Hot oil" light to come on.

Should I worry about this code? Or, should I just clear it and keep driving?

__________________
2012 JK Sport S, 3.6L, Auto, TF 2.5" coil lift & 1" Spacers, Rancho RS9000XL, RC control arm drop kit, TF monster track bar, 35" Pro Comp Radial Xtreme ATs on 16x8 AR172 Baja, ACE rear bumper & tire carrier, ACE Rock Sliders, Bushwacker Flat Fenders
kev324 is offline   Quote Quick Reply
Old 02-09-2013, 01:33 PM   #2
Jeeper
 
Raziel's Avatar
 
Join Date: Aug 2011
Posts: 747
Unable to check the code at this time but I think it's for one of the O2 sensors. Fuel trim will be in a fail safe mode. You may notice gas usage change. Not major problem really!

__________________
2011 Jeep Wrangler Unlimited, M/T


Home, Home Is Where The Heart Is. That Is What They Say. It's Sorrow Is As Sweet To Me As Red Wine...
Raziel is offline   Quote Quick Reply
Old 02-09-2013, 01:43 PM   #3
Jeeper
 
onetraveller's Avatar
 
Join Date: Sep 2012
Location: Alaska
Posts: 724
It's a fuel system code. Could be a variety of things including bad gas.

Error code - P2096 - Jeep Garage - Jeep Forum

Mike
__________________
2013 JKU Sahara, Commando Green - 2.5" Franken Lift - Rancho 9000xl shocks - 275/70r18 Cooper ST Maxx in summer - 265/70r18 Bizzaks in winter

http://www.wranglerforum.com/f202/re...ho-627602.html
onetraveller is offline   Quote Quick Reply
Old 02-09-2013, 02:32 PM   #4
Jeeper

WF Supporting Member
 
kev324's Avatar
 
Join Date: Mar 2011
Location: Massachusetts
Posts: 242
Thanks guys. I think I'll just see if it goes away with some more normal driving. If not, I'll clear it with my scanner.
__________________
2012 JK Sport S, 3.6L, Auto, TF 2.5" coil lift & 1" Spacers, Rancho RS9000XL, RC control arm drop kit, TF monster track bar, 35" Pro Comp Radial Xtreme ATs on 16x8 AR172 Baja, ACE rear bumper & tire carrier, ACE Rock Sliders, Bushwacker Flat Fenders
kev324 is offline   Quote Quick Reply
Old 02-09-2013, 04:39 PM   #5
Mech. Engr. & Mechanic

WF Supporting Member
 
jmb6420's Avatar
 
Join Date: Apr 2011
Location: Tulsa, OK
Posts: 485
Images: 3
Found this ...

P2096-DOWNSTREAM FUEL TRIM SYSTEM 1 LEAN

Set Condition:
If the PCM multiplies short term compensation by long term adaptive as well as a purge fuel multiplier and the result is below a certain value for a calibrated amount of time over two trips, a freeze frame is stored, the MIL illuminates and a trouble code is stored. Two Trip Fault. Three good trips to turn off the MIL.


Possible Causes

EXHAUST LEAK

ENGINE MECHANICAL

1/2 O2 SENSOR

(K141) O2 SENSOR 1/2 SIGNAL CIRCUIT

(K299) O2 1/2 HEATER CONTROL CIRCUIT

(K904) O2 RETURN DOWNSTREAM CIRCUIT

FUEL CONTAMINATION
__________________
**********
Mike
08 Flame Red Rubicon
Cibie H4 headlamps
You can't fix stupid!
jmb6420 is offline   Quote Quick Reply
Old 06-04-2013, 08:27 AM   #6
Jeeper
 
Rabuck's Avatar
 
Join Date: Jan 2012
Location: Baltimore, md
Posts: 356
Threw this code p 2096 yesterday with 20500 miles I had my head replaced about 2000 miles ago any relations? Is this common code? Oh and btw it sat over night and now no code
Rabuck is offline   Quote Quick Reply
Old 08-29-2013, 11:55 PM   #7
Jeeper
 
relyt's Avatar
 
Join Date: Mar 2011
Location: Sidney, OH
Posts: 674
I just got this code as well. I have a '13 with the AB head. The head has not yet been replaced, and I've not had any problems that lead me to believe that is the issue. I did get fresh gas in the morning, so I'm hoping its just a bad tank.

If it is contaminated fuel, is there a reason I'd only see the code on bank 1? Is there anything I should add to the fuel, ie octane booster/sta-bil or similar? Any other ideas I may be missing? I've cleared the code with my scan tool, and if it comes back, I'll be scheduling a service appointment.
relyt is offline   Quote Quick Reply
Old 08-30-2013, 07:08 AM   #8
Jeeper
 
Raziel's Avatar
 
Join Date: Aug 2011
Posts: 747
Could be a software issue. Vehicle is under warranty so take it in.
if it's a lean mixture. It's getting more air. Vacuum leak some where.could possible be the head issue.
__________________
2011 Jeep Wrangler Unlimited, M/T


Home, Home Is Where The Heart Is. That Is What They Say. It's Sorrow Is As Sweet To Me As Red Wine...
Raziel is offline   Quote Quick Reply
Old 09-04-2013, 12:01 AM   #9
Jeeper
 
relyt's Avatar
 
Join Date: Mar 2011
Location: Sidney, OH
Posts: 674
Quote:
Originally Posted by relyt View Post
I just got this code as well. I have a '13 with the AB head. The head has not yet been replaced, and I've not had any problems that lead me to believe that is the issue. I did get fresh gas in the morning, so I'm hoping its just a bad tank.

If it is contaminated fuel, is there a reason I'd only see the code on bank 1? Is there anything I should add to the fuel, ie octane booster/sta-bil or similar? Any other ideas I may be missing? I've cleared the code with my scan tool, and if it comes back, I'll be scheduling a service appointment.
After clearing the code I put in a bottle of fuel system treatment/water remover and I've put on a few hundred miles. So far the light has stayed off. I'm hoping it was just bad gas.
relyt is offline   Quote Quick Reply
Old 09-09-2013, 01:05 AM   #10
Jeeper
 
relyt's Avatar
 
Join Date: Mar 2011
Location: Sidney, OH
Posts: 674
I haven't checked the code, but the engine light is back on. Guess I'll be calling the dealer in the morning.
relyt is offline   Quote Quick Reply
Old 09-09-2013, 04:22 PM   #11
Jeeper

WF Supporting Member
 
kev324's Avatar
 
Join Date: Mar 2011
Location: Massachusetts
Posts: 242
Quote:
Originally Posted by relyt View Post
I haven't checked the code, but the engine light is back on. Guess I'll be calling the dealer in the morning.
Trust me, you need the head replaced. There are lots of bad "AB" heads out there. Don't drop your Jeep off until they have the new part in stock. If they say that you aren't elligible for a loaner, call Jeep customer service from the dealership. Good luck!
__________________
2012 JK Sport S, 3.6L, Auto, TF 2.5" coil lift & 1" Spacers, Rancho RS9000XL, RC control arm drop kit, TF monster track bar, 35" Pro Comp Radial Xtreme ATs on 16x8 AR172 Baja, ACE rear bumper & tire carrier, ACE Rock Sliders, Bushwacker Flat Fenders
kev324 is offline   Quote Quick Reply
Old 09-09-2013, 05:21 PM   #12
Jeeper
 
relyt's Avatar
 
Join Date: Mar 2011
Location: Sidney, OH
Posts: 674
Quote:
Originally Posted by kev324 View Post

Trust me, you need the head replaced. There are lots of bad "AB" heads out there. Don't drop your Jeep off until they have the new part in stock. If they say that you aren't elligible for a loaner, call Jeep customer service from the dealership. Good luck!
Did you get the new head? Is that what finally fixed your problem? I'm dropping it off in the morning and have a loaner car already in the works. I'm also having them look at my chirping throw out bearing while they have it.
relyt is offline   Quote Quick Reply
Old 09-09-2013, 07:19 PM   #13
Jeeper

WF Supporting Member
 
kev324's Avatar
 
Join Date: Mar 2011
Location: Massachusetts
Posts: 242
The dealer kept finding other things to try instead of replacing the head, seemingly just running up the bill on Chrysler. They eventually removed the head and installed an "AC" head, which only took a few hours. The CEL never came back on, the ticking is gone, and gas mpg is improved!
__________________
2012 JK Sport S, 3.6L, Auto, TF 2.5" coil lift & 1" Spacers, Rancho RS9000XL, RC control arm drop kit, TF monster track bar, 35" Pro Comp Radial Xtreme ATs on 16x8 AR172 Baja, ACE rear bumper & tire carrier, ACE Rock Sliders, Bushwacker Flat Fenders
kev324 is offline   Quote Quick Reply
Old 09-10-2013, 07:06 AM   #14
Jeeper
 
relyt's Avatar
 
Join Date: Mar 2011
Location: Sidney, OH
Posts: 674
I'm at the dealership now. The light turned off on my way in and they said if the code didn't store there probably isn't much they can do about it today. They are at least going to look at my noisy throw out bearing. There isn't any way it should make as much noise as it does for only having 5800 miles.
relyt is offline   Quote Quick Reply
Old 09-10-2013, 08:34 AM   #15
Jeeper
 
relyt's Avatar
 
Join Date: Mar 2011
Location: Sidney, OH
Posts: 674
Apparently I had a slight oil leak from the valve cover right on the O2 sensor. Hopefully that'll fix it, and hopefully the dealership won't flag me for warranty. They were giving me a hard time about aftermarket parts. I can't see how an intake or exhaust would affect a valve cover. We'll see how it goes. In the mean time, they gave me a 2010 Sebring to drive. Horrible car. I can't recommend them to anybody.

relyt is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 11:47 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC