Check engine light during smog?? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-17-2013, 09:12 AM   #1
Jeeper
 
AngelJK's Avatar
 
Join Date: Jun 2013
Location: Reno, NV
Posts: 67
Check engine light during smog??

Got a smog test done yesterday and while the gentleman was doing his thing on the computer, I noticed that the CE light came on. I didn't say anything out of fear of failing but what the heck?!

It turned off later that day, and came back On when I pumped gas.

Then it turned off and came back on the next day when I had to used 4low.

What do you guys/girls think?

AngelJK is offline   Quote
Old 06-17-2013, 01:32 PM   #2
Jeeper
 
AngelJK's Avatar
 
Join Date: Jun 2013
Location: Reno, NV
Posts: 67
Bump?

AngelJK is offline   Quote
Old 06-17-2013, 01:56 PM   #3
Jeeper
 
2five22's Avatar
 
Join Date: Jul 2012
Posts: 1,902
It could be and is likely something simple like the gas cap not sealing correctly. Around here, they love to jiggle the cap to see if they can induce a fail.

Find someone with an OBD2 scanner and find out what the fault code is. Anything else is a guess.
2five22 is offline   Quote
Old 06-18-2013, 11:55 PM   #4
Jeeper
 
AngelJK's Avatar
 
Join Date: Jun 2013
Location: Reno, NV
Posts: 67
Quote:
Originally Posted by 2five22 View Post
It could be and is likely something simple like the gas cap not sealing correctly. Around here, they love to jiggle the cap to see if they can induce a fail.

Find someone with an OBD2 scanner and find out what the fault code is. Anything else is a guess.

Who is they?
AngelJK is offline   Quote
Old 06-18-2013, 11:58 PM   #5
Jeeper
 
AngelJK's Avatar
 
Join Date: Jun 2013
Location: Reno, NV
Posts: 67
Here are the codes. The lady said to be interested about the "possibilities" and didn't pay too much attention to the "definition." Done at auto zone though.. Is that the OBD 2?
AngelJK is offline   Quote
Old 06-19-2013, 12:09 AM   #6
Jeeper
 
AngelJK's Avatar
 
Join Date: Jun 2013
Location: Reno, NV
Posts: 67
The codes
Attached Thumbnails
Click image for larger version

Name:	securedownload.jpg
Views:	31
Size:	219.9 KB
ID:	263301  
AngelJK is offline   Quote
Old 06-19-2013, 12:34 AM   #7
Jeeper
 
AngelJK's Avatar
 
Join Date: Jun 2013
Location: Reno, NV
Posts: 67
Anything would help guys, kind of lost as a first time jeep owner. Thank you.
AngelJK is offline   Quote
Old 06-19-2013, 12:48 AM   #8
Newb
 
Rallyman's Avatar
 
Join Date: Jun 2013
Location: Highlands Ranch
Posts: 6
I would start by replacing the o2 sensor first. After that clear the codes and then drive about 50 miles on the highways to let ECM run another test and see if your dummy light comes back on. You just need to pinpoint which o2 it is.
Rallyman is offline   Quote
Old 06-19-2013, 02:30 AM   #9
Jeeper
 
Lusus_Naturae's Avatar
 
Join Date: Oct 2012
Location: OKC, missing WI
Posts: 2,692
Give us some Jeep info - year?

Have you replaced the gas cap with a locking one?

Has there been any recent work done on the Jeep - like a tune up before the test?

Have you switched gas - different brand, E10?
__________________
2013 JKU Sport, billet, auto, 3.73, LSD, 315/75/16 Duratracs on MB 72, 10A springs, Bushwacker flatties

Sold - 2005 TJ, red, auto, 3.73, 33" Duratracs, 4" lift
Ice storm casualty in 2007 - 2003 TJ, green, auto, 3.73, 33" Duratracs, 4" lift
Lusus_Naturae is offline   Quote
Old 06-19-2013, 10:46 AM   #10
Jeeper
 
AngelJK's Avatar
 
Join Date: Jun 2013
Location: Reno, NV
Posts: 67
Quote:
Originally Posted by Rallyman View Post
I would start by replacing the o2 sensor first. After that clear the codes and then drive about 50 miles on the highways to let ECM run another test and see if your dummy light comes back on. You just need to pinpoint which o2 it is.
Thanks man, i will assess in that matter for starters!
AngelJK is offline   Quote
Old 06-19-2013, 10:48 AM   #11
Jeeper
 
AngelJK's Avatar
 
Join Date: Jun 2013
Location: Reno, NV
Posts: 67
Quote:
Originally Posted by Lusus_Naturae View Post
Give us some Jeep info - year?

Have you replaced the gas cap with a locking one?

Has there been any recent work done on the Jeep - like a tune up before the test?

Have you switched gas - different brand, E10?

You're right, my apologies.

2011 Jeep Wrangler 2 door (40xxx miles)
Never replaced anything
No tune-ups (just purchased it a week ago)
I have not switched gas. That would actually play a factor?
AngelJK is offline   Quote
Old 06-19-2013, 01:12 PM   #12
Jeeper
 
insylem's Avatar
 
Join Date: Apr 2013
Location: Enterprise, Alabama.
Posts: 1,066
Images: 3
Quote:
Originally Posted by AngelJK View Post
You're right, my apologies.

2011 Jeep Wrangler 2 door (40xxx miles)
Never replaced anything
No tune-ups (just purchased it a week ago)
I have not switched gas. That would actually play a factor?

I purchased a used vehical once and had the engine light come on a few days later. The vehica;s previous owner had modified the engine for more performance, and had the engine computer reprogramed. However, when the dealership got the vehcial they reflashed the engine calibraton back to factory, causeing the engine to not run correctly. In my case it threw P0172 System Too Rich. So it may not be from something YOU did, but possibly something the previous owner did. In my case there was a sticker on the engine computer that told me what company had originally reporogramed it, and was able to contact them for reprograming. Alls good now.
__________________
2013 Wrangler Unlimited Rubicon 10th Anniversary
insylem is offline   Quote
Old 06-19-2013, 01:52 PM   #13
Jeeper
 
SoCal's Avatar
 
Join Date: Oct 2012
Location: SoCal
Posts: 55
What were the readings from your smog inspection. It can show if there is an exhaust leak or if its running rich or lean

SoCal is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:28 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC