clocksprings - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today

Thread Tools

Please support our sponsors and let them know you heard about them on
Old 11-25-2011, 08:52 PM   #1
Join Date: Nov 2011
Location: Westminster Md
Posts: 4

I have a problem with no dash lights and once the jeep is started the wipers start with not control. Someone mentioned the clocksprings. My eyes are going crossed from so much reading. So what I am asking when the engine starts would bad clockspring cause the wipers to turn on (No speed control) no dash lights or gauges, no turn signals. cannot get the automatic shift to move from P to N,D, etc No horn except locking the doors with remote. head lights are on (normal manual on/off) no hazard light. when the hazard light button is pressed the stock radio outer buttons light not the clock am/fm cd etc light up. It seems to me that only the functions on the steering wheel would be affected by a bad clockspring. Ideas/thought/comments ?

Notes: I have disconnected battery term. checked fuses. Done a good inspection looking for water or wet connections. Found nothing so far

vanhagar is offline   Quote
Old 11-26-2011, 07:55 AM   #2
MARGARET, 10-14-51\6-1-12

WF Supporting Member
Join Date: Aug 2010
Posts: 10,295
more info is needed, what year jeep and what options do you have,,, clock spring can affect many things, but dash lights, never heard of this, you might have something else going on.


life is too short to be taken seriously all the time,,,, go buy a MR.potato head and have some fun.
GREEN-MACHINE is offline   Quote
Old 11-26-2011, 08:27 AM   #3
Join Date: May 2011
Posts: 2,709
I had a Ford clock spring give me an air bag light, no horn, and no cruise control, but that was about it.
demarpaint is offline   Quote
Old 11-26-2011, 10:21 AM   #4
Join Date: Nov 2011
Location: Westminster Md
Posts: 4
It is 08 wrangler X. We only had it almost a year. Soft top. no mods yet. It is pretty standard. As i said i didnt think that the clockspring would cause this problem.But i wanted to ask around
vanhagar is offline   Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:59 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC. is not in any way associated with the Chrysler Motors LLC