Drag link doesn't move, occasionally hard to steer moving slowly - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-08-2013, 06:24 PM   #1
Supporting Member

WF Supporting Member
 
cmaggi2's Avatar
 
Join Date: Oct 2012
Location: Prairieville, LA
Posts: 1,510
Drag link doesn't move, occasionally hard to steer moving slowly

It seems like my power steering is giving out intermittently in parking lots when I'm moving slowly. I don't hear any weird noises and my fluid seems fine.
When I checked underneath, my tie rod rotates from the front to rear when I manually turn it, but my drag link does not. Should the drag link rotate like the tie rod does? here are some pics of the bushings. as you can see, they aren't centered.
Attached Thumbnails
Click image for larger version

Name:	20130808_181605.jpg
Views:	26
Size:	141.6 KB
ID:	283444   Click image for larger version

Name:	20130808_181630.jpg
Views:	24
Size:	149.4 KB
ID:	283445  


cmaggi2 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:17 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC