Electric Throttle Control and power down - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-31-2011, 08:45 AM   #1
Newb
 
Join Date: Feb 2011
Location: Columbus, OH
Posts: 10
Electric Throttle Control and power down

I was driving on the highway and was going to make a pass. I put the petal to the metal and then whaa, whaa, whaaaaaaaa. The electronic throttle control(ETC) light came on and I went idle and had to pull over. I pulled the key out and restarted it and it was fine. This has happened twice(both while accelerating) since I bought it(2011 2-door) back in Sept. I haven't had it looked at because both times after a restart I'm fine. Anyone else have a similar issue? If so anyone know exactly what may be happening?

owuboy is offline   Quote Quick Reply
Old 07-31-2011, 09:19 AM   #2
Jeeper
 
tuff2010's Avatar
 
Join Date: Dec 2010
Location: Weatherford TX
Posts: 355
Sounds like it needs to go to the dealer..never heard of that happening..

tuff2010 is offline   Quote Quick Reply
Old 07-31-2011, 11:46 AM   #3
Jeeper
 
Join Date: Jul 2011
Location: Broken Arrow, OK
Posts: 2,305
Does the check engine light come on? TBW systems default to idle, or just slightly over it, anytime a fault is detected. A fault should be accompanied by a code and engine light. Sometimes a code set in a pending status and doesn't turn the light on unless the fault happens again within a certain time period. Take it somewhere and see if they can get a code out of it. It sounds like there is probably something going on in the pedal position sensor when you move the pedal quickly. This is what warranties are for, I suggest using yours. This stuff can get pricey and even if the dealer can't find something wrong now you will have it on record as a problem in case it causes you problems down the road.
__________________
2012 Silver Sport S, Silver, 6 speed, soft top, 3.73s, LSD, PCG, Infiniti, deep tint windows, Pro Comp 1028 wheels, 33" Duratracs, Smittybilt bumpers and steps, KC fog lights, Mopar slush mats and fuel door.

Happiness is a belt fed weapon.
oilwell1415 is offline   Quote Quick Reply
Old 08-15-2011, 07:49 AM   #4
Jeeper
 
uvjeep's Avatar
 
Join Date: Jul 2011
Location: Upper Valley, NH
Posts: 20
Quote:
Originally Posted by owuboy View Post
I was driving on the highway and was going to make a pass. I put the petal to the metal and then whaa, whaa, whaaaaaaaa. The electronic throttle control(ETC) light came on and I went idle and had to pull over. I pulled the key out and restarted it and it was fine. This has happened twice(both while accelerating) since I bought it(2011 2-door) back in Sept. I haven't had it looked at because both times after a restart I'm fine. Anyone else have a similar issue? If so anyone know exactly what may be happening?
Happened to me this weekend an hour and a half from home (2011 JKU). Flashing ETC light, rough idle, and no response when I stepped on the gas. We tried disconnecting the battery to reset, but it didn't work. Luckily, 24 roadside assistance got us on a flatbed to the nearest dealer who is (hopefully) looking at it today. Mine happened after I stalled the motor I could restart it, but nothing when I stepped on the gas.
uvjeep is offline   Quote Quick Reply
Old 08-15-2011, 10:25 AM   #5
Jeeper
 
nvkid's Avatar
 
Join Date: Jan 2011
Location: n.nevada
Posts: 736
Has happened a couple times here when i coast downhill. Do the key dance to read your code. Mine reads P2173 (high air flow/vaccum leak).
nvkid is offline   Quote Quick Reply
Old 08-15-2011, 11:00 AM   #6
Jeeper
 
uvjeep's Avatar
 
Join Date: Jul 2011
Location: Upper Valley, NH
Posts: 20
Quote:
Originally Posted by uvjeep View Post
Happened to me this weekend an hour and a half from home (2011 JKU). Flashing ETC light, rough idle, and no response when I stepped on the gas. We tried disconnecting the battery to reset, but it didn't work. Luckily, 24 roadside assistance got us on a flatbed to the nearest dealer who is (hopefully) looking at it today. Mine happened after I stalled the motor I could restart it, but nothing when I stepped on the gas.
Quote:
Originally Posted by nvkid View Post
Has happened a couple times here when i coast downhill. Do the key dance to read your code. Mine reads P2173 (high air flow/vaccum leak).
Just heard from the dealer and he said it's a bad power train control module and will be replaced under warranty. Now I need to go learn how to do the key dance.
uvjeep is offline   Quote Quick Reply
Old 08-15-2011, 11:19 AM   #7
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 34,259
It tells you in the manual if the light flashes and shuts off- u should be good.
If the light stays on- get service. I've seen this problem and do believe there is a TSB
out --- not sure

__________________
2007 Rubicon/Rock Krawler TR 2.5 coils/rear TB/Rancho 9000 31/32XL shocks/Teraflex monster TB/Synergy highsteer,tie rod, ball joints/Hankook MT 315-75-16 on Level 8 ZX's/MC front SB links/Rancho geo brackets & shocks/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings=Frankinjeep from hell.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Acronyms etc... stevens243 General Jeep Discussion 69 03-30-2014 06:25 PM
check engine light came on and speedo stopped working @ the same time. eric TJ General Discussion Forum 14 10-14-2013 12:05 PM
Prolly! A rant by ccain. ccain Off-Topic 58 04-10-2010 01:57 PM
throttle body change & Power Control Module jryan TJ Tech Forum 8 03-16-2010 04:41 AM
TJ Error codes khenderson TJ Tech Forum 3 08-19-2005 12:36 AM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:35 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC