Engine light... Help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-26-2013, 07:48 PM   #1
Jeeper
 
Ajax333333's Avatar
 
Join Date: Dec 2010
Location: Gilbert, AZ
Posts: 517
Engine light... Help

Engine light came on way home today. I checked all fluids, including oil, and all at proper levels. Any thoughts on what could cause this?

If it helps, it's an 07' JKU with 88,000 miles on it.

Thanks!

Ajax333333 is offline   Quote
Old 08-26-2013, 07:54 PM   #2
..shall not be infringed!

WF Supporting Member
 
Up Hill Bill's Avatar
 
Join Date: Jun 2011
Location: Up the hill, CA Northcoast
Posts: 4,666

__________________
2012 JKU Rubicon
Sahara Tan
Auto
3.73


Up Hill Bill
Up Hill Bill is offline   Quote
Old 08-26-2013, 08:14 PM   #3
Jeeper
 
Ajax333333's Avatar
 
Join Date: Dec 2010
Location: Gilbert, AZ
Posts: 517
Thanks. It came up P0481.
Ajax333333 is offline   Quote
Old 08-26-2013, 08:29 PM   #4
..shall not be infringed!

WF Supporting Member
 
Up Hill Bill's Avatar
 
Join Date: Jun 2011
Location: Up the hill, CA Northcoast
Posts: 4,666
P0481 is "Cooling Fan 2 Control Circuit Malfunction"

Maybe someone will know exactly what that means and what you need to do to fix it. Good luck!
__________________
2012 JKU Rubicon
Sahara Tan
Auto
3.73


Up Hill Bill
Up Hill Bill is offline   Quote
Old 08-26-2013, 10:06 PM   #5
Jeeper
 
Ajax333333's Avatar
 
Join Date: Dec 2010
Location: Gilbert, AZ
Posts: 517
Took it to auto zone to see of they could help me out. They confirmed what the code was and suggested that I take it to the dealer to get fixed. He feels its a wiring problem with the secondary speed on my fan.

I wonder how much I will get screwed by the dealer.....
Ajax333333 is offline   Quote
Old 08-26-2013, 10:16 PM   #6
Newb
 
Join Date: Aug 2013
Posts: 11
new guy here.. i feel your pain..hope you can get your problem solved without being put thru the ringer by the dealer. i just bought a 2013 wrangler with 2998 miles on it on saturday..last night the check engine light came on!! total bumber..im goin back to the deaker on wednesday morning to find out what is up.
may2nd is offline   Quote
Old 08-26-2013, 10:37 PM   #7
Jeeper
 
Sueby's Avatar
 
Join Date: Sep 2011
Location: CT
Posts: 1,810
I had a P0480 - cooling fan 1 the other day. It was a black wire near the battery that was not connected (our own fault after a compressor install).

Probably doesn't help you much, but take a look & see if you have any loose wires. It would be nice if was an easy fix like mine. But its nothing i'd ignore - cooling fans are important!
Sueby is offline   Quote
Old 08-27-2013, 12:23 PM   #8
Jeeper
 
Ajax333333's Avatar
 
Join Date: Dec 2010
Location: Gilbert, AZ
Posts: 517
Started jeep this morning and engine light was off. I guess i will just wait and see if it comes back on again

Ajax333333 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 10:22 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC