Engine Noise - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-10-2009, 07:03 PM   #1
Newb
 
Join Date: Jun 2009
Posts: 5
Engine Noise

2008 wrangler x no mods. 5000 miles. When i start the engine cold it sounds like rods knocking. Anyone else have this problem. Changed oil at jeep dealer at 2600 miles. This started shortly after. Thanks K.C.

muleman is offline   Quote
Old 08-11-2009, 08:57 PM   #2
Jeeper
 
Hitchhiker's Avatar
 
Join Date: Aug 2008
Posts: 172
I'd take it back and have them check it or change it again. Maybe the grease jockey put the wrong oil in it.

__________________
2008 Wrangler Unlimited Sahara 4dr 'JK' -- Steel Blue Metallic -- Hard Top
Hitchhiker is offline   Quote
Old 08-12-2009, 04:31 PM   #3
Jeeper
 
Codeman911's Avatar
 
Join Date: Aug 2009
Location: Kansas City
Posts: 182
I would use Royal Purple fluids. Best stuff I've seen.
Codeman911 is offline   Quote
Old 08-14-2009, 09:31 AM   #4
Jeeper
 
UnionOffRoad's Avatar
 
Join Date: Aug 2009
Location: Nowhere, NC
Posts: 33
Quote:
Originally Posted by Hitchhiker View Post
I'd take it back and have them check it or change it again. Maybe the grease jockey put the wrong oil in it.
Grease Jockey. LOL thats mint
Possible bad oil filter. Seeing alot of those at my dealer, we're Cadillac, Chevy and Buick but... Possible
__________________
"Up N Over"
UnionOffRoad is offline   Quote
Old 08-18-2009, 09:08 PM   #5
Newb
 
Join Date: Jun 2009
Posts: 5
Done some checking. They put a perform-X filter on it. This does not have the anti bleed back. Filter was the problem.
muleman is offline   Quote
Old 08-26-2009, 01:29 PM   #6
Newb
 
Join Date: Feb 2009
Location: Montgomery, Texas
Posts: 10
Switch the filter to a Motorcraft FL-400S.
It's a larger capacity filter and has an anti-bleedback valve.
If you're slow, like me, it will take about three minutes to swap the filter.
TXRLK is offline   Quote
Old 01-24-2012, 06:48 PM   #7
Jeeper
 
pkmcd99's Avatar
 
Join Date: Jan 2012
Posts: 2,117
Quote:
Originally Posted by muleman
2008 wrangler x no mods. 5000 miles. When i start the engine cold it sounds like rods knocking. Anyone else have this problem. Changed oil at jeep dealer at 2600 miles. This started shortly after. Thanks K.C.
Its common cold start up noises. Lucas oil sunstitute 1 qt and use an oil filter with anti drain back valve like fram tough gaurd or equivilant. Pullies also ocasionally make start up noises but youll have to live with them. Get a block heater also and plug her in during the winter.

pkmcd99 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rebuilding your engine?? Get Stroked!!! jeeper95yj YJ General Discussion Forum 6 01-01-2014 04:47 PM
Engine noise slackerrp YJ Tech Forum 11 07-29-2009 01:29 AM
Chirping noise from engine when warmed up chadvickers YJ General Discussion Forum 14 07-04-2009 01:59 PM
Engine Noise 04SilverTj TJ Tech Forum 3 05-19-2009 04:51 PM
Engine whistle noise t2kcfd TJ Tech Forum 3 02-11-2007 07:34 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:44 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC