ESID and evap codes - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-15-2013, 07:58 AM   #1
_3m
Supporting Member

WF Supporting Member
 
_3m's Avatar
 
Join Date: Oct 2007
Location: pittsburgh, Pa
Posts: 2,765
ESID and evap codes

I was told that many of the small evap leak code are due to the ESID being dirty and stuck in one position or another, Has anyone had any experience with this? where is it located?

__________________
Life isn't about how you survive the storm, but how you dance in the rain
_3m is offline   Quote Quick Reply
Old 05-15-2013, 08:01 AM   #2
rabbits eat lettuce

WF Supporting Member
::WF Moderator::
 
tabber02's Avatar
 
Join Date: Nov 2010
Location: left coast, florida
Posts: 10,798
the EVAP is about two thirds of the way back... closer to the drivers side and next to your exhaust. it's a black box... about 10"x10" if i had to guess..

__________________
-bob

2010 JK - Mountain Edition
i spend way too much money on it... that's all



tabber02 is offline   Quote Quick Reply
Old 05-15-2013, 08:35 AM   #3
_3m
Supporting Member

WF Supporting Member
 
_3m's Avatar
 
Join Date: Oct 2007
Location: pittsburgh, Pa
Posts: 2,765
ESID is the white box on the trailing side of the evap canister. And mine was sliding side to side just fine. Back to square one
__________________
Life isn't about how you survive the storm, but how you dance in the rain
_3m is offline   Quote Quick Reply
Old 05-15-2013, 08:41 AM   #4
rabbits eat lettuce

WF Supporting Member
::WF Moderator::
 
tabber02's Avatar
 
Join Date: Nov 2010
Location: left coast, florida
Posts: 10,798
hmm.. you nail the EVAP on something? maybe the connector is junked up with dirt?
__________________
-bob

2010 JK - Mountain Edition
i spend way too much money on it... that's all



tabber02 is offline   Quote Quick Reply
Old 05-15-2013, 11:49 AM   #5
Jeeper
 
JeepHerz's Avatar
 
Join Date: Apr 2012
Location: California
Posts: 2,691
Images: 21
Have you done anything to the evap. prior? We had the same code- messed with the canister when we did our gears. Lost a gasket somehow. $3 from the dealer and the code went away.
It threw both codes at the time- someone mentioned the gas cap can throw the evap. code. (even though there is a gas cap code). Easy enough to try and un-do and re-do your gas cap.
JeepHerz is offline   Quote Quick Reply
Old 05-15-2013, 12:02 PM   #6
Sponsoring Vendor
 
JPi4.0's Avatar
 
Join Date: Feb 2012
Posts: 850
Quote:
Originally Posted by JeepHerz View Post
Have you done anything to the evap. prior? We had the same code- messed with the canister when we did our gears. Lost a gasket somehow. $3 from the dealer and the code went away.
It threw both codes at the time- someone mentioned the gas cap can throw the evap. code. (even though there is a gas cap code). Easy enough to try and un-do and re-do your gas cap.

i chased and chased this leak on mine. i never had a seal. Jeremy's had the same problem. no seal. we have seen quite a few come in without a seal. the seal is cheap but it just became available from the dealer. a year ago you couldn't get the seal.

so no worries you didn't loose it.
__________________
Jeeperformance, Inc
Yucaipa CA.
877-795-JEEP
https://www.facebook.com/Jeeperformanceinc http://www.jeeperformanceinc.com/
JPi4.0 is offline   Quote Quick Reply
Old 05-15-2013, 03:00 PM   #7
_3m
Supporting Member

WF Supporting Member
 
_3m's Avatar
 
Join Date: Oct 2007
Location: pittsburgh, Pa
Posts: 2,765
Well after checking everything I could on the rear side and replacing the gas cap I traced the lines to the front and found the leaking hose. It's the hose that comes from the back and bends around the battery. Mine was leaning up against the battery and had the battery has rubbed a hole in the hose. See photo

Click image for larger version

Name:	image-3501175323.jpg
Views:	47
Size:	70.4 KB
ID:	249450





Click image for larger version

Name:	image-2119282389.jpg
Views:	40
Size:	176.5 KB
ID:	249451

I put some heat shrink on it and taped it up. I'm hoping that does the trick. But I would encourage everyone to have a look at theirs. I also looked at my girlfriends jeep as she's having the same issue & sure as heck same hole in the same spot.
__________________
Life isn't about how you survive the storm, but how you dance in the rain
_3m is offline   Quote Quick Reply
Old 05-15-2013, 03:06 PM   #8
_3m
Supporting Member

WF Supporting Member
 
_3m's Avatar
 
Join Date: Oct 2007
Location: pittsburgh, Pa
Posts: 2,765
next question: will the computer reset itself from this code or do I need to reset it myself and then drive a bit? i have a state inspection in the AM and i know the 0456 is an automatic fail.
__________________
Life isn't about how you survive the storm, but how you dance in the rain
_3m is offline   Quote Quick Reply
Old 05-15-2013, 03:09 PM   #9
Sponsoring Vendor
 
JPi4.0's Avatar
 
Join Date: Feb 2012
Posts: 850
Quote:
Originally Posted by _3m View Post
next question: will the computer reset itself from this code or do I need to reset it myself and then drive a bit? i have a state inspection in the AM and i know the 0456 is an automatic fail.
Yes. I think after five cycles. Mine reset about ten minutes after I fixed it.
__________________
Jeeperformance, Inc
Yucaipa CA.
877-795-JEEP
https://www.facebook.com/Jeeperformanceinc http://www.jeeperformanceinc.com/
JPi4.0 is offline   Quote Quick Reply
Old 05-15-2013, 03:32 PM   #10
_3m
Supporting Member

WF Supporting Member
 
_3m's Avatar
 
Join Date: Oct 2007
Location: pittsburgh, Pa
Posts: 2,765
shesh maybe i didn't Fix it. well I did in a sense. i drove nearly 50 miles today with it fixed on the highway and the engine light is still on. the code is gone but the light remains on. i did shut it off a number of times but cant say for sure if it was more than 5.
__________________
Life isn't about how you survive the storm, but how you dance in the rain
_3m is offline   Quote Quick Reply
Old 05-15-2013, 04:36 PM   #11
Sponsoring Vendor
 
JPi4.0's Avatar
 
Join Date: Feb 2012
Posts: 850
Quote:
Originally Posted by _3m View Post
shesh maybe i didn't Fix it. well I did in a sense. i drove nearly 50 miles today with it fixed on the highway and the engine light is still on. the code is gone but the light remains on. i did shut it off a number of times but cant say for sure if it was more than 5.
Two of our shop jeeps reset themselves. Maybe you have another code?
__________________
Jeeperformance, Inc
Yucaipa CA.
877-795-JEEP
https://www.facebook.com/Jeeperformanceinc http://www.jeeperformanceinc.com/
JPi4.0 is offline   Quote Quick Reply
Old 05-15-2013, 08:27 PM   #12
_3m
Supporting Member

WF Supporting Member
 
_3m's Avatar
 
Join Date: Oct 2007
Location: pittsburgh, Pa
Posts: 2,765
I disconnected the battery, reset it and drove 130 miles, no code no engine light. Fingers crossed

__________________
Life isn't about how you survive the storm, but how you dance in the rain
_3m is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 05:44 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC