ESP/BAS Light - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-28-2010, 01:00 PM   #1
Jeeper
 
bigjerm646's Avatar
 
Join Date: Dec 2010
Location: Ashburn, Virginia
Posts: 82
Exclamation ESP/BAS Light

Hey to all,

So this past Sunday, my ESP/BAS Light and my Traction Control Light came one and stayed on. Took it to the dealership and apparently it was my allignment. My JK is only 14K miles old and I dont recall that I hit anything that would cause my allignment to go off (But dont hold me to that). So I was wondering if you any of you all had this same experience and if it was actually your allignment as well. The dealership said this was probably the main cause and it wasnt the spring in the steering column or any other problems. The weirdest thing is that it came on after I started her up at a Target parking lot.

Jeremy

bigjerm646 is offline   Quote Quick Reply
Old 12-28-2010, 01:12 PM   #2
Jeeper
 
Join Date: Dec 2010
Posts: 42
I just had the same thing happen along with the low trac light. There is an update for the low trac light and the ESP/BAS was from a bad clock spring.

Rgarcia501 is offline   Quote Quick Reply
Old 12-28-2010, 01:13 PM   #3
Jeeper
 
JIMBOX's Avatar
 
Join Date: Nov 2009
Posts: 9,916
Thats why I never go in TARGET parking lots !!

Just kidding, I've modified mine quite a bit and NO ESP lights/icons, untill I push the ESP sw.

JIMBO
__________________
"ya gotta have class"
JIMBOX is offline   Quote Quick Reply
Old 12-28-2010, 02:41 PM   #4
Jeeper
 
RubiJK12's Avatar
 
Join Date: Jul 2009
Location: Arizona
Posts: 226
I had the same experience just after reaching 14K on my 09.
Can't remember if it was a Target parking lot.
But, it just came on. After a couple of starts, it went off and I thought all was well. It finally came on and stayed on.

It was not the clockspring or the alignment on mine. Actually had a bad sensor that was back ordered several weeks. This sensor fits under the center console and is the one that apparently feels when the vehicle is not going straight, level, etc. After it was replaced, and since, everything it fine!!
__________________
"Take nothing but memories,
leave nothing but 'light tread marks'."

12 Rubi
RubiJK12 is offline   Quote Quick Reply
Old 12-28-2010, 03:10 PM   #5
Jeeper
 
bigjerm646's Avatar
 
Join Date: Dec 2010
Location: Ashburn, Virginia
Posts: 82
Yeah had to pay for an alignment..i guess thats alright if my JK needed it
__________________
Jeremy

"Do what you can, with what you have, where you are."
- Theodore Roosevelt
bigjerm646 is offline   Quote Quick Reply
Old 12-28-2010, 10:43 PM   #6
Jeeper
 
07XMan2Door's Avatar
 
Join Date: Nov 2010
Location: colorado
Posts: 1,651
Did you notice if your steering wheel was not centered?

Mine came on after I removed my entire front axle assemmbly to weld in EVO sleeves & C gussets. When I bolted it all together, the esp bas light came on & stayed on.

My steering wheel was no longer centered. I crawled under it & adjusted
it & the light went out 20 miles later.

Glad you got it fixed.
07XMan2Door is offline   Quote Quick Reply
Old 12-29-2010, 08:17 AM   #7
Jeeper
 
Join Date: Jun 2010
Location: Ithaca, NY
Posts: 32
Mine came on around 5k miles while I was driving on the highway at the end of a very long drive (15 hours). It went out the next time I started the Jeep. It hasn't returned...
Testut is offline   Quote Quick Reply
Old 12-29-2010, 01:22 PM   #8
Jeeper
 
bigjerm646's Avatar
 
Join Date: Dec 2010
Location: Ashburn, Virginia
Posts: 82
Yeah I had take a trip back in November (34 Hours Roundtrip) and I never noticed my steeringwheel out of alignment. Driving to the dealership the light did go out. I'm hoping it was just the front alignment.
__________________
Jeremy

"Do what you can, with what you have, where you are."
- Theodore Roosevelt
bigjerm646 is offline   Quote Quick Reply
Old 05-08-2013, 10:30 PM   #9
Jeeper
 
JeepDiaz's Avatar
 
Join Date: May 2013
Posts: 25
Hi there

Quote:
Originally Posted by RubiJK12 View Post
I had the same experience just after reaching 14K on my 09.
Can't remember if it was a Target parking lot.
But, it just came on. After a couple of starts, it went off and I thought all was well. It finally came on and stayed on.

It was not the clockspring or the alignment on mine. Actually had a bad sensor that was back ordered several weeks. This sensor fits under the center console and is the one that apparently feels when the vehicle is not going straight, level, etc. After it was replaced, and since, everything it fine!!
Just was wondering if you wouldn't mind telling me where and how to do this I did my clock spring on my own and got wheel alignment done for my new tires maybe this would help to take off the lights email me the info on dandiaz1521@gmail.com thanks
JeepDiaz is offline   Quote Quick Reply
Old 06-30-2013, 05:55 PM   #10
Jeeper
 
Join Date: Sep 2011
Location: Near Denver, Co
Posts: 19
Electronic stability control (ESC) came on while driving straight. After turning ignition off, light in dash turned off. This happened 4 times in a week, once's just braking. Each time ignition off, light off and of course light off being at dealer. Dealer put in clock spring. ( wrangler sport, 2011, 26000 miles).

Houkie is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ohio Light laws gus54 Ohio Jeep Forum 8 03-17-2011 07:38 PM
How many forum members does it take to.... Nick Off-Topic 46 03-16-2011 01:47 AM
HID kit jksahara JK General Discussion Forum 13 08-22-2010 12:42 PM
Rear Cargo Light installed on a 2008 Jeep Wrangler X 2 Door 1EYEDJACK JK Pics Forum 1 08-17-2008 08:56 PM
A Sign of the Impending Apocalypse Dare2BSquare Off-Topic 18 06-19-2008 01:44 AM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:38 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC