factory radio problems! - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-24-2013, 03:40 PM   #1
Jeeper
 
Wyo-JK's Avatar
 
Join Date: May 2011
Location: Casper, Wyoming
Posts: 68
factory radio problems!

Hey guys i have a 2010 Rubicon unlimited and my radio is jacked.....i came out after work and i can't change from sirius to normal radio and the only buttons that work are the knobs for changing stations and volume....also can't shut off radio just adjust volume

Wyo-JK is offline   Quote Quick Reply
Old 08-24-2013, 05:24 PM   #2
Jeeper
 
Brankz's Avatar
 
Join Date: Jun 2013
Posts: 348
Quote:
Originally Posted by Wyo-JK View Post
Hey guys i have a 2010 Rubicon unlimited and my radio is jacked.....i came out after work and i can't change from sirius to normal radio and the only buttons that work are the knobs for changing stations and volume....also can't shut off radio just adjust volume
eBay jeep jk radio the go for really cheap

Brankz is offline   Quote Quick Reply
Old 08-24-2013, 05:36 PM   #3
Jeeper
 
flharleycop's Avatar
 
Join Date: Nov 2010
Location: South Florida
Posts: 305
First try to reset it, take the fuse out for the radio or undo your battery for about 10 mins and reset it and honk the horn. Mine did that once and the battery thing has worked ever since. I did buy a new one from one of the guys here jic but have not needed to use it yet. You can find them cheap from those upgrading if you have the RES radio.
__________________


JKUS 11
flharleycop is offline   Quote Quick Reply
Old 08-24-2013, 06:08 PM   #4
Jeeper
 
Wyo-JK's Avatar
 
Join Date: May 2011
Location: Casper, Wyoming
Posts: 68
Quote:
Originally Posted by flharleycop View Post
First try to reset it, take the fuse out for the radio or undo your battery for about 10 mins and reset it and honk the horn. Mine did that once and the battery thing has worked ever since. I did buy a new one from one of the guys here jic but have not needed to use it yet. You can find them cheap from those upgrading if you have the RES radio.
I pulled the battery for like a minute and it didn't work
Wyo-JK is offline   Quote Quick Reply
Old 08-24-2013, 07:36 PM   #5
Jeeper
 
MSpiegel00's Avatar
 
Join Date: Jun 2013
Location: New Jersey
Posts: 369
Quote:
Originally Posted by Wyo-JK View Post
I pulled the battery for like a minute and it didn't work
Pull the battery for longer.
MSpiegel00 is offline   Quote Quick Reply
Old 08-24-2013, 08:28 PM   #6
..shall not be infringed!

WF Supporting Member
 
Up Hill Bill's Avatar
 
Join Date: Jun 2011
Location: Up the hill, CA Northcoast
Posts: 4,284
Quote:
Originally Posted by Wyo-JK View Post
I pulled the battery for like a minute and it didn't work
Here's the right way to do that...

Jeep Parts, Jeep Accessories & Jeep Soft Tops From The Jeep Parts Experts - Quadratec
__________________
2012 JKU Rubicon
Sahara Tan
Auto
3.73


Up Hill Bill
Up Hill Bill is online now   Quote Quick Reply
Old 09-01-2013, 10:35 AM   #7
Jeeper
 
Wyo-JK's Avatar
 
Join Date: May 2011
Location: Casper, Wyoming
Posts: 68
It randomly started working now! I'm about to get rid of it for an aftermarket radio
Wyo-JK is offline   Quote Quick Reply
Old 09-01-2013, 12:38 PM   #8
Jeeper
 
flharleycop's Avatar
 
Join Date: Nov 2010
Location: South Florida
Posts: 305
Quote:
Originally Posted by Wyo-JK View Post
I pulled the battery for like a minute and it didn't work
I don’t know I can only go with what I was told to do, the guy told me to leave the power off for about 10 mins because the radio has an internal battery store that will reset after that. The minute may have not been enough. Like I said tho check here and ebay I pieced up a new res radio for around 40 bucks.
__________________


JKUS 11
flharleycop is offline   Quote Quick Reply
Old 09-01-2013, 12:40 PM   #9
Jeeper
 
flharleycop's Avatar
 
Join Date: Nov 2010
Location: South Florida
Posts: 305
Quote:
Originally Posted by Up Hill Bill View Post
Thats great information, I wonder if its something you should do when the ghost star showing up. I have had some stuff not work and then they fix themselves for no reason.

__________________


JKUS 11
flharleycop is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:44 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC