Front LCA Mount Question - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-03-2013, 09:47 PM   #1
Jeeper
 
Join Date: Jan 2013
Location: Houston, TX
Posts: 74
Was making some adjustments today on my lift that was installed w/g8 bolt kit. On my front LCA axle mount my bolt holes are square. I suspect that this isn't correct and am not sure what to do. Did the factory hardware have bolts that fit into that mount have a squared shoulder? It's a 2013. I wish I would have just installed the lift myself now. Been unscrewing everything all night and I'm stuck on the rear control arms with bolt issues (cant get them out they are so tight once the nut is off). 3 of my 4 rear arms were installed backwards and both my front lower arms were as well, hence,,, when I noticed the square holes.

Please help.

TexasRubi is offline   Quote Quick Reply
Old 07-03-2013, 11:53 PM   #2
Jeeper
 
jrussblues's Avatar
 
Join Date: Apr 2011
Location: se la
Posts: 3,066
The holes are square on my 10

__________________
06 LJ
78? CJ-7
jrussblues is offline   Quote Quick Reply
Old 07-04-2013, 12:00 AM   #3
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 37,369
Always wondered why they were square myself

Try jacking the pinion up to take pressure of the bolts.
kjeeper10 is offline   Quote Quick Reply
Old 07-04-2013, 12:28 AM   #4
Jeeper
 
PHILDABEAST's Avatar
 
Join Date: Nov 2012
Location: Farmington N.M.
Posts: 883
The lower brackets on the front axle are square because they have a removable tab to elongate the hole for use with cam bolts/washers for adjusting caster.
PHILDABEAST is online now   Quote Quick Reply
Old 07-04-2013, 07:52 AM   #5
Jeeper
 
Join Date: Jan 2013
Location: Houston, TX
Posts: 74
Thanks guys... I think my issue with the rear UCA bolt is its stuck in the CA joint. There is some play at the frame. Of course you can't tap it out because the rear brakes/tire are in the way. Tried prying ect. I need some sort of bolt puller I guess.
TexasRubi is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:22 AM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC