Gas cap causes ruff running? - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-29-2013, 06:07 PM   #1
Jeeper
 
Johnny HotFoot's Avatar
 
Join Date: Sep 2010
Posts: 175
Gas cap causes ruff running?

Last night me dear wife put gas in my rubi, this morning me check engine light came on and she ran ruff. Nursed her home from work - light still on but no codes. Got home checked gas cap. It was loose. Removed and replaced. Started her up and light was off. Seemed to run well after 10-20 seconds.

My question. Does the cap being jank cause the light to come on? Others have said it does.

Bigger question. Does the ill replaced gas cap cause a disturbance in engine performance???

__________________
Black 1986 Jeep CJ-7 Laredo, Hard Top Only: Long Gone
Black 1995 Jeep Wrangler YJ, Both Tops: Long Gone
Black 2007 Jeep Wrangler JK Unlimited Sahara, Soft Top Only: Lease Turned In
Black 2010 Jeep Wrangler JK Unlimited Rubicon, Both Tops: Daily Driver
Johnny HotFoot is offline   Quote
Old 10-29-2013, 09:51 PM   #2
Jeeper
 
MikeK46's Avatar
 
Join Date: Mar 2012
Location: Long Island, NY
Posts: 1,722
I've forgotten to replace my gas cap on numerous occasions and sometimes didn't notice till the next day. No change in performance and never had a check engine light.

__________________
12JK
MikeK46 is offline   Quote
Old 10-30-2013, 04:33 PM   #3
Jeeper
 
Johnny HotFoot's Avatar
 
Join Date: Sep 2010
Posts: 175
Light is back on. Ran well all the way to work. 15 miles of freeway. On way how light came back on. Only problems I can see are slight loss in power at times, not able to climb past 60mph easily. And sometimes the revs stay high when coasting or slowing.

Any ideas??? Loose plug wire?
__________________
Black 1986 Jeep CJ-7 Laredo, Hard Top Only: Long Gone
Black 1995 Jeep Wrangler YJ, Both Tops: Long Gone
Black 2007 Jeep Wrangler JK Unlimited Sahara, Soft Top Only: Lease Turned In
Black 2010 Jeep Wrangler JK Unlimited Rubicon, Both Tops: Daily Driver
Johnny HotFoot is offline   Quote
Old 10-30-2013, 04:34 PM   #4
Jeeper
 
Johnny HotFoot's Avatar
 
Join Date: Sep 2010
Posts: 175
Quote:
Originally Posted by Johnny HotFoot View Post
Light is back on. Ran well all the way to work. 15 miles of freeway. On way how light came back on. Only problems I can see are slight loss in power at times, not able to climb past 60mph easily. And sometimes the revs stay high when coasting or slowing.

Any ideas??? Loose plug wire?
Also she still not throwing any codes???
__________________
Black 1986 Jeep CJ-7 Laredo, Hard Top Only: Long Gone
Black 1995 Jeep Wrangler YJ, Both Tops: Long Gone
Black 2007 Jeep Wrangler JK Unlimited Sahara, Soft Top Only: Lease Turned In
Black 2010 Jeep Wrangler JK Unlimited Rubicon, Both Tops: Daily Driver
Johnny HotFoot is offline   Quote
Old 10-30-2013, 04:36 PM   #5
Jeeper
 
jquinn83's Avatar
 
Join Date: Aug 2012
Location: Maryland
Posts: 484
Where did she get the gas? Quality of gas can cause the light to go on.
jquinn83 is offline   Quote
Old 10-30-2013, 04:39 PM   #6
Jeeper
 
JKjingle's Avatar
 
Join Date: Dec 2012
Location: Canada
Posts: 208
Did she put diesel in it :P do you have a man or auto trans?
JKjingle is offline   Quote
Old 10-30-2013, 07:53 PM   #7
Jeeper
 
Johnny HotFoot's Avatar
 
Join Date: Sep 2010
Posts: 175
Gas was from BP, it's at half a tank. Should I too it off with super?
__________________
Black 1986 Jeep CJ-7 Laredo, Hard Top Only: Long Gone
Black 1995 Jeep Wrangler YJ, Both Tops: Long Gone
Black 2007 Jeep Wrangler JK Unlimited Sahara, Soft Top Only: Lease Turned In
Black 2010 Jeep Wrangler JK Unlimited Rubicon, Both Tops: Daily Driver
Johnny HotFoot is offline   Quote
Old 10-30-2013, 08:08 PM   #8
Jeeper
 
MikeK46's Avatar
 
Join Date: Mar 2012
Location: Long Island, NY
Posts: 1,722
If it's the gas, maybe you're better off running it down some more before refilling at another gas station.

What did you originally mean by loose gas cap? It's less than half a turn before it clicks, if I recall correctly. So as I understand, it's either on properly or totally off and hanging on the wire.
__________________
12JK
MikeK46 is offline   Quote
Old 10-30-2013, 08:13 PM   #9
Jeeper
 
Lusus_Naturae's Avatar
 
Join Date: Oct 2012
Location: OKC, missing WI
Posts: 2,983
Since you have a half tank you can try some gas treatment. Use about half a dose of treatment which usually calls for a full tank.
__________________
2013 JKU Sport, billet, auto, 3.73, LSD, 315/75/16 Duratracs on MB 72, 10A springs, Bushwacker flatties

Sold - 2005 TJ, red, auto, 3.73, 33" Duratracs, 4" lift
Ice storm casualty in 2007 - 2003 TJ, green, auto, 3.73, 33" Duratracs, 4" lift
Lusus_Naturae is offline   Quote
Old 10-31-2013, 12:42 AM   #10
Jeeper
 
Join Date: Apr 2012
Posts: 17
My user manual says that the light will come on if you don't close the gas cap properly.
rodharrison is offline   Quote
Old 10-31-2013, 08:07 AM   #11
Jeeper
 
milani's Avatar
 
Join Date: Jul 2013
Location: Orland Park
Posts: 364
If you have a loose gas cap, or a bad seal on it, you can/will eventually throw a code: PO455 (LARGE EVAP LEAK) is what I think it is...
__________________
2013 Jeep Wrangler Unlimited Sahara - Black
2014 Jeep Grand Cherokee Overland - Brilliant Black Crystal Pearl
Previously - 2011 Jeep Grand Cherokee Overland - Brilliant Black
milani is offline   Quote
Old 10-31-2013, 09:27 AM   #12
Supporting Member

WF Supporting Member
 
NFRs2000NYC's Avatar
 
Join Date: Nov 2011
Location: NYC
Posts: 7,068
An evap leak isn't going to cause your motor to run rough. Something else is the problem. Fill up at another station, and also check your oil. If your Jeep throws a code pull it and report back.
NFRs2000NYC is offline   Quote
Old 10-31-2013, 09:41 AM   #13
Jeeper
 
milani's Avatar
 
Join Date: Jul 2013
Location: Orland Park
Posts: 364
Quote:
Originally Posted by NFRs2000NYC View Post
An evap leak isn't going to cause your motor to run rough. Something else is the problem. Fill up at another station, and also check your oil. If your Jeep throws a code pull it and report back.
Actually, it can. Had it happen on my wife's 14 GC
__________________
2013 Jeep Wrangler Unlimited Sahara - Black
2014 Jeep Grand Cherokee Overland - Brilliant Black Crystal Pearl
Previously - 2011 Jeep Grand Cherokee Overland - Brilliant Black
milani is offline   Quote
Old 10-31-2013, 02:10 PM   #14
Jeeper
 
Dogzilla's Avatar
 
Join Date: Oct 2010
Location: Coastal NC
Posts: 936
Quote:
Originally Posted by Lusus_Naturae View Post
Since you have a half tank you can try some gas treatment. Use about half a dose of treatment which usually calls for a full tank.

This. I've had it happen. A little water will screw things up pretty badly.

Dogzilla is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 12:02 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC