Help Dead 2012 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-11-2013, 10:28 PM   #1
Jeeper
 
joe buell's Avatar
 
Join Date: Jan 2012
Location: Florida
Posts: 599
Help Dead 2012

Well took my mother out to eat for moms day on sat to beat the Sun rush anyway we started to leave turned the key on my 2012 2dr sport and the dash lights looked like the 4TH of July right down to the sizzle flicker/flash get bright go dim well my brother was there . we opened the hood and you could hear clicking from the fuse panel without the key in ignition. it turned out clicking is coming from the ignition relay took relay out and it continued disconnected bat for 10min to try to reset no use even with the key out and the lights turned off. the parking lights and headlights would flicker very dimly called roadside assist and they sent a tow well could not get it in neutral with key all the way on when the tow guy hooked jump box to it it was enough to get it in neutral but then key would not come out well got it to local dealer of course not open till Monday if anyone has any ideas I would love to hear them thanks Joe. until then

joe buell is offline   Quote Quick Reply
Old 05-12-2013, 12:43 AM   #2
Jeeper
 
BillyPete's Avatar
 
Join Date: Dec 2011
Location: Washington state
Posts: 315
Sounds like a fried Power Distribution box to me.

__________________
.


2012 Orange Crush Sahara 2dr.
BillyPete is offline   Quote Quick Reply
Old 05-12-2013, 05:50 AM   #3
Jeeper
 
joe buell's Avatar
 
Join Date: Jan 2012
Location: Florida
Posts: 599
Thanks BillyPete the way all the lights were flickering even with key out and every thing in the off mode that's kind of what I was thinking Brain type issue you would like to at least see more than 14k on odometer before something like this happens?Thank God for warantee.I wonder how many have had this issue? thanks again Joe.
joe buell is offline   Quote Quick Reply
Old 05-12-2013, 06:21 AM   #4
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 34,756
Oooh Joe. Hope it's something stupid
__________________
2007 Rubicon/Rock Krawler triple rate 2.5" coils/RK rear TB w/ a teraflex raised bracket/Rancho 9000 31/32XL shocks/Synergy flipped draglink,ball joints,tie rod /Hankook MT 315-75-16 on Level 8 ZX's/Rancho geo brackets/Ruff stuff uppers/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings/Rancho cat back exhaust.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is offline   Quote Quick Reply
Old 05-12-2013, 06:31 AM   #5
Jeeper
 
joe buell's Avatar
 
Join Date: Jan 2012
Location: Florida
Posts: 599
Praying for bad batt but after jumping for 10min had enough juice to run all lights including KC lights then right back to stupid mode this is my company vehicle I need for work so hoping for QUICK FIX???? I'll see what happens Monday will repost results may help someone in the future. Joe.
joe buell is offline   Quote Quick Reply
Old 05-12-2013, 06:37 AM   #6
Jeeper
 
ilikeguns's Avatar
 
Join Date: Apr 2012
Location: Long Island, NY
Posts: 732
good luck man.. keep us posted
ilikeguns is offline   Quote Quick Reply
Old 05-12-2013, 09:58 AM   #7
Jeeper
 
SafetyThird's Avatar
 
Join Date: Aug 2012
Posts: 84
Quote:
Originally Posted by joe buell
Praying for bad batt but after jumping for 10min had enough juice to run all lights including KC lights then right back to stupid mode this is my company vehicle I need for work so hoping for QUICK FIX???? I'll see what happens Monday will repost results may help someone in the future. Joe.
My first thought on any electrical weirdness is bad ground. Power wants ground and when it can't get there the right way it goes through other circuits the wrong way.

Good luck.
SafetyThird is offline   Quote Quick Reply
Old 05-15-2013, 03:16 PM   #8
Jeeper
 
joe buell's Avatar
 
Join Date: Jan 2012
Location: Florida
Posts: 599
Well I went to the dealer Mon morning and talked to service rep he said 90percent sure it was the batt so I left it and went home 2hrs later he called and said it was ready it was the batt but I have never seen any vehicle do such and to not start even after a jump????Happy Happy Happy . and BTW FYI your Chrysler roadside service towing only covers the 1st $100 of any tow so if you are aways away you might want to use your insurance instead just thought that was kinda weak only $100 for a tow but alls good thanks to the ones that took the time to try to help Joe.
joe buell is offline   Quote Quick Reply
Old 05-15-2013, 04:40 PM   #9
Jeeper
 
Join Date: Apr 2013
Posts: 24
My old Lancer had one of the cells go bad in the batt. Still had enough power to make everything go crazy like you said plus it sounded like their was a pissed off squirrel with a machine gun under the hood.
cbell77 is offline   Quote Quick Reply
Old 05-15-2013, 04:44 PM   #10
Jeeper
 
ilikeguns's Avatar
 
Join Date: Apr 2012
Location: Long Island, NY
Posts: 732
glad it worked out for you man..
ilikeguns is offline   Quote Quick Reply
Old 05-15-2013, 04:51 PM   #11
Jeeper
 
lesgoff's Avatar
 
Join Date: Jun 2012
Location: Charlotte
Posts: 93
Similar problem with my BMW. I went into a restaurant for lunch, came out and it wouldn't do anything (not even a click). I called BMW (still under the 3 year maintenance free service) and they couldn't even jump the car. They towed the car to the dealership and it was a bad battery. Replace free of charge and sent me on my way.

__________________
Teraflex 2.5 coil lift, JKS Disconnects, Trektop NX
Rubicon Rock Rails, ACE Rock Sliders, MyGig Lockpick
Rugged Ridge Satin Black Wheels, Goodyear Duratrac 315/70/17
lesgoff is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:40 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC