help? my radio/navigation/HD won't turn on - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-06-2012, 08:22 PM   #1
Jeeper
 
Shauna's Avatar
 
Join Date: Jun 2011
Location: Beaverton, OR
Posts: 357
help? my radio/navigation/HD won't turn on

I have one of those factory installed navigation/HD/dvd/cd/radio touch-screen systems in my 2008 jku and today it stopped turning on....black screen only....sometimes it looked like it would try to turn on and flash the "UConnect" screen for a few seconds, then turn off again. The fuse is not blown. Anyone ever had this issue? Or know what I can try to fix it?
Attached Thumbnails
Click image for larger version

Name:	40797.jpg
Views:	73
Size:	33.5 KB
ID:	166785  

__________________
2008 JKU Rubicon - 3.8L V6 automatic, 4" lift, 35" Km2 Mud Terrains, 5.13 Yukon Gears, Dana 44 front & rear, XRC bumpers / body armor / fender flares
Shauna is offline   Quote
Old 10-06-2012, 08:47 PM   #2
Krew Member

WF Supporting Member
 
Turbostixxx's Avatar
 
Join Date: Sep 2012
Location: Richmond, Virginia
Posts: 20,478
#1 throw it out the window

#2 use an iPod with headphones

#3 pay someone to fix it like everything else on the jku...

#4 try running a new ground, molar is famous for grounding their radios through the antenna, which screws up after a little while.

__________________
_______
/l
,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)

1997 Wrangler SE:4" Lift; 33x11x16; Q9000 Winch
Turbostixxx is offline   Quote
Old 10-06-2012, 08:54 PM   #3
Jeeper
 
Shauna's Avatar
 
Join Date: Jun 2011
Location: Beaverton, OR
Posts: 357
thanks for suggestion #4
__________________
2008 JKU Rubicon - 3.8L V6 automatic, 4" lift, 35" Km2 Mud Terrains, 5.13 Yukon Gears, Dana 44 front & rear, XRC bumpers / body armor / fender flares
Shauna is offline   Quote
Old 04-14-2013, 09:59 AM   #4
Newb
 
Join Date: Apr 2013
Posts: 1
Radio and Navigation won't turn on

I was wondering if you ever found out what was wrong with your radio? Mine is doing the same thing. If I push the on button it will show me JEEP and then turn back off.
Captmorgan is offline   Quote
Old 07-20-2013, 11:59 AM   #5
Jeeper
 
Shauna's Avatar
 
Join Date: Jun 2011
Location: Beaverton, OR
Posts: 357
Sorry for late response...this has happened a couple times to me now.... I completely disconnect the battery and then reconnect...it resets everything and the radio starts working again
__________________
2008 JKU Rubicon - 3.8L V6 automatic, 4" lift, 35" Km2 Mud Terrains, 5.13 Yukon Gears, Dana 44 front & rear, XRC bumpers / body armor / fender flares
Shauna is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:49 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC