Help Warning lights..... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-12-2013, 01:47 PM   #1
Supporting Member

WF Supporting Member
 
fastmover's Avatar
 
Join Date: Sep 2013
Location: Smoky Mountains East Tenn
Posts: 13
Help Warning lights.....

Hey Guys I need your help.
I have had my "New to me" JK X one month and up until today
all systems were great. I was riding down a nice smooth paved road
and all of a sudden the following warning lights come on
ESP/BAS, ABS, and ESP/TCS and stay on. I can detect NO
problem and the JK seems to drive normally. I cycled the engine
( started and shut down) many times with no change.
I am not sure if its related but I noticed the cruise control
is not working, I don't use it often but last time I Did use it worked fine.
I checked fuses, ok got under and looked at the cables going to the wheels (ABS) all LOOKS ok.
The prior owner lifted 3 1/4" with a rustys off road kit added MT baja tires 33x12.5/17 and some other minor mods
BUT I am almost 100% sure this Jeep was never off road and all the mods
were VERY recent. There is NO sign of any accident damage or repaint.
So before I take it to the dealer any ideas what the problem could.
The worst part is I was going to Win Rock today oh well maybe next weekend
Tnx Jim

PICS

fastmover is offline   Quote Quick Reply
Old 10-12-2013, 02:01 PM   #2
Jeeper
 
The General's Avatar
 
Join Date: Jun 2012
Posts: 411
You could try disconnecting the battery for a while, other than that I have no ideas. Good luck.

The General is offline   Quote Quick Reply
Old 10-12-2013, 02:05 PM   #3
Race Car Dave

WF Supporting Member
 
NFRs2000NYC's Avatar
 
Join Date: Nov 2011
Location: NYC
Posts: 6,948
Your clockspring has most likely gone bad. A member on another forum just brought in his 09 to the dealer for it, and they covered it under the 100K warranty. Chrysler knows that clocksprings have issues.
NFRs2000NYC is offline   Quote Quick Reply
Old 10-12-2013, 02:23 PM   #4
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 35,238
Def a sensor. Read the code and replace the bad one.
I broke a wire and all my dash lights came on.

The clock spring will illuminate the airbag light I believe.
__________________
2007 Rubicon/Rock Krawler triple rate 2.5" coils/RK rear TB w/ a teraflex raised bracket/Rancho 9000 31/32XL shocks/Synergy flipped draglink,ball joints,tie rod /Hankook MT 315-75-16 on Level 8 ZX's/Rancho geo brackets/Ruff stuff uppers/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings/Rancho cat back exhaust.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is offline   Quote Quick Reply
Old 10-12-2013, 02:45 PM   #5
Supporting Member

WF Supporting Member
 
fastmover's Avatar
 
Join Date: Sep 2013
Location: Smoky Mountains East Tenn
Posts: 13
clockspring malfuction

Quote:
Originally Posted by NFRs2000NYC View Post
Your clockspring has most likely gone bad. A member on another forum just brought in his 09 to the dealer for it, and they covered it under the 100K warranty. Chrysler knows that clocksprings have issues.
Holy Moly
Why didn't I think of that.... I'll wait until it gets dark to check, I have been told they
glow when they brake
fastmover is offline   Quote Quick Reply
Old 10-12-2013, 03:13 PM   #6
Race Car Dave

WF Supporting Member
 
NFRs2000NYC's Avatar
 
Join Date: Nov 2011
Location: NYC
Posts: 6,948
Quote:
Originally Posted by kjeeper10 View Post
Def a sensor. Read the code and replace the bad one. I broke a wire and all my dash lights came on. The clock spring will illuminate the airbag light I believe.
From what I have read you are correct. It may be a bad sensor/torn wire since all those systems are tied into the brakes. OP, I take back my clockspring comment, check all the sensors and wires going to the wheels.
NFRs2000NYC is offline   Quote Quick Reply
Old 10-12-2013, 03:21 PM   #7
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 35,238
Fwiw ... If for any reason your clock spring does go. Jeep extended the warranty till 100k
__________________
2007 Rubicon/Rock Krawler triple rate 2.5" coils/RK rear TB w/ a teraflex raised bracket/Rancho 9000 31/32XL shocks/Synergy flipped draglink,ball joints,tie rod /Hankook MT 315-75-16 on Level 8 ZX's/Rancho geo brackets/Ruff stuff uppers/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings/Rancho cat back exhaust.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is offline   Quote Quick Reply
Old 10-12-2013, 09:43 PM   #8
Supporting Member

WF Supporting Member
 
fastmover's Avatar
 
Join Date: Sep 2013
Location: Smoky Mountains East Tenn
Posts: 13
Quote:
Originally Posted by kjeeper10 View Post
Fwiw ... If for any reason your clock spring does go. Jeep extended the warranty till 100k


Does the clock spring have a warning light?????
fastmover is offline   Quote Quick Reply
Old 10-12-2013, 09:48 PM   #9
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 35,238
Quote:
Originally Posted by fastmover View Post
Does the clock spring have a warning light?????
No ... Your air bag light will show and I don't think the horn works.
__________________
2007 Rubicon/Rock Krawler triple rate 2.5" coils/RK rear TB w/ a teraflex raised bracket/Rancho 9000 31/32XL shocks/Synergy flipped draglink,ball joints,tie rod /Hankook MT 315-75-16 on Level 8 ZX's/Rancho geo brackets/Ruff stuff uppers/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings/Rancho cat back exhaust.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is offline   Quote Quick Reply
Old 10-12-2013, 09:53 PM   #10
Jeeper
 
00Sebby's Avatar
 
Join Date: Sep 2012
Location: The mountains of East Tennessee
Posts: 191
On my '09 MINI Cooper S, I hit a major pothole and the dash lit up like a Christmas tree... ABS, DSC, DTC, etc. It drove fine. One of the sensor connectors that attach to the back of the wheel hub area snapped. I would guess the wiring going to one of the ABS sensors on your Jeep is faulty. As for the clock spring, when my Suburban clock spring went bad it triggered the Airbag light.
__________________
'12 JKUR, 3.6, AT, Crush, all options except leather, added Smitty Rock Armor steps.
Before this one... '00 XJ Cherokee Sport, '99 XJ Cherokee Classic, '98 TJ Wrangler, '97 TJ Wrangler, '91 FSJ Grand Wagoneer, '89 XJ Cherokee Laredo
00Sebby is offline   Quote Quick Reply
Old 10-12-2013, 10:13 PM   #11
Supporting Member

WF Supporting Member
 
fastmover's Avatar
 
Join Date: Sep 2013
Location: Smoky Mountains East Tenn
Posts: 13
Quote:
Originally Posted by 00Sebby View Post
On my '09 MINI Cooper S, I hit a major pothole and the dash lit up like a Christmas tree... ABS, DSC, DTC, etc. It drove fine. One of the sensor connectors that attach to the back of the wheel hub area snapped. I would guess the wiring going to one of the ABS sensors on your Jeep is faulty. As for the clock spring, when my Suburban clock spring went bad it triggered the Airbag light.
I was thinking the same thing and I checked as best I could but without a lift its hard to tell......
And BTW I think its time for a clock spring recall before someone gets hurt
fastmover is offline   Quote Quick Reply
Old 10-13-2013, 11:06 AM   #12
Supporting Member

WF Supporting Member
 
fastmover's Avatar
 
Join Date: Sep 2013
Location: Smoky Mountains East Tenn
Posts: 13
update

Well first I disconnected the Batt over night and the tbl is still there,
so I took it for a short drive and when I got home I pulled the code, it was
U1417 -( Implausible Left Wheel Distance Signal Received) since it didn't say front or rear I checked both for the second time, still look ok to me.
I assume this lets the clock spring off the hook, I watched the youtube video
on how to replace the clockspring, NOT fun. So unless anyone has another idea it will be off to the shop Monday.

fastmover is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 11:21 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC