Ipod Song Gaps on UConnect - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-07-2012, 05:15 PM   #1
Jeeper
 
bluehen's Avatar
 
Join Date: Feb 2012
Location: Milford, DE
Posts: 76
Ipod Song Gaps on UConnect

I play my iPod frequently through the USB connection in the center console. One thing I find really annoying is the song gaps that UConnect inserts between songs. I have my iPod set to play albums continuously without artificial gaps. The Uconnect system not only puts a gap between songs, but even more annoyingly, it will play about a quarter second of the next song just before the gap. GRRRRRR.

Is there a way to get rid of that nonsense? I can't seem to find any option to go gapless.

__________________
2012 JKU Sahara, Bright Silver
Head replaced at 15K; traded for '12 Passat diesel at 28K - still a Jeep fan
Semper Fidelis
bluehen is offline   Quote Quick Reply
Old 04-07-2012, 05:24 PM   #2
Jeeper
 
TASARCTIC12's Avatar
 
Join Date: Mar 2012
Location: Swan Point, Maryland
Posts: 182
Images: 3
Same issue in my 2012..

__________________
2014 AMP'd JKU
Rugged Ridge Black Accessories
3" BDS with 35" Duratracs
Adams Jeep Build
0|||||||0
TASARCTIC12 is offline   Quote Quick Reply
Old 04-09-2012, 10:10 AM   #3
Jeeper
 
bluehen's Avatar
 
Join Date: Feb 2012
Location: Milford, DE
Posts: 76
Weekday bump: Anyone figure out how to get rid of the song gaps?
__________________
2012 JKU Sahara, Bright Silver
Head replaced at 15K; traded for '12 Passat diesel at 28K - still a Jeep fan
Semper Fidelis
bluehen is offline   Quote Quick Reply
Old 04-09-2012, 11:07 AM   #4
Jeeper
 
termite's Avatar
 
Join Date: Feb 2012
Location: Central Ohio
Posts: 623
Odd, I do not have that issue with a 2012 JKU w/ 430N. I do not have the gaps turned off on the Ipod. The gaps that are in between the songs are extremely short, maybe a third of a second.
 
The Ipod I am using is an old 2nd Gen Nano.
termite is offline   Quote Quick Reply
Old 04-09-2012, 12:08 PM   #5
Jeeper
 
bluehen's Avatar
 
Join Date: Feb 2012
Location: Milford, DE
Posts: 76
Quote:
Originally Posted by termite View Post
Odd, I do not have that issue with a 2012 JKU w/ 430N. I do not have the gaps turned off on the Ipod. The gaps that are in between the songs are extremely short, maybe a third of a second.
 
The Ipod I am using is an old 2nd Gen Nano.
Maybe that's the problem. I'll try turning gaps "on" on my iPod. Can't hurt to try. Hell, I don't mind the gaps as much as I do the 1/4 second of the next song playing just before the gap.
__________________
2012 JKU Sahara, Bright Silver
Head replaced at 15K; traded for '12 Passat diesel at 28K - still a Jeep fan
Semper Fidelis
bluehen is offline   Quote Quick Reply
Old 04-09-2012, 12:16 PM   #6
Commercial Member

WF Supporting Member
 
Join Date: Apr 2011
Posts: 2,006
your vehicle must have been built after mid October 2011 and has the newest SW in it. Uconnect went to "direct play" for Ipods then.



Quote:
Originally Posted by termite View Post
Odd, I do not have that issue with a 2012 JKU w/ 430N. I do not have the gaps turned off on the Ipod. The gaps that are in between the songs are extremely short, maybe a third of a second.
 
The Ipod I am using is an old 2nd Gen Nano.
xsdbs is offline   Quote Quick Reply
Old 04-09-2012, 12:23 PM   #7
Commercial Member

WF Supporting Member
 
Join Date: Apr 2011
Posts: 2,006
Apple has changed the way that it plays the music on newer Apple SW versions.
They used to have a moment at the ending of the current song where it would compare the next song with the Meta Data to make sure that the data matched the next song. So Uconnect would also have a buffer time for this. Now with their change, Uconnect is in a buffer time and Apple is trying to force start play. Apple changed this after the Uconnect SW was wrote for the 2011 vehicles. Uconnect made a change to perform "direct play" for V2 2012 Uconnect modules.
Had Apple been working with others they would have found out that their change would cause problems with what people already have and use.

Quote:
Originally Posted by bluehen View Post
I play my iPod frequently through the USB connection in the center console. One thing I find really annoying is the song gaps that UConnect inserts between songs. I have my iPod set to play albums continuously without artificial gaps. The Uconnect system not only puts a gap between songs, but even more annoyingly, it will play about a quarter second of the next song just before the gap. GRRRRRR.

Is there a way to get rid of that nonsense? I can't seem to find any option to go gapless.
xsdbs is offline   Quote Quick Reply
Old 04-09-2012, 12:39 PM   #8
Jeeper
 
termite's Avatar
 
Join Date: Feb 2012
Location: Central Ohio
Posts: 623
Quote:
Originally Posted by xsdbs View Post
your vehicle must have been built after mid October 2011 and has the newest SW in it. Uconnect went to "direct play" for Ipods then.
Yeah it does, my build date is 020612 (picked it up on 20 feb). There is a new update that my fix the issue for the ones that have this issue. I do not have the bluetooth streaming issues some have either.

I'll set my ipod to no gaps and see if it shows up on the new firmware as well.

termite is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turbo on my 2.4l!!!!!!!! yellowbeast TJ General Discussion Forum 104 09-05-2012 06:03 PM
Jk rock doors on tj? burgundytj TJ General Discussion Forum 8 04-08-2012 12:32 AM
Help finding the ignition power on a 2012 TheNuge Communications and Electronics 1 04-07-2012 02:59 PM
Tires on 97 Sahara 1974 Farmall TJ General Discussion Forum 0 04-07-2012 10:59 AM
First Post Question on Price ivel_86 JK General Discussion Forum 2 04-07-2012 07:50 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 04:48 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC