Is my Feedom Top missing a part? (W/pics) - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-08-2013, 09:36 AM   #1
Jeeper
 
Join Date: Nov 2011
Posts: 176
Is my Feedom Top missing a part? (W/pics)

Had my Freedom Top panels off all last week (vacation!), and noticed something weird. When you take the panels off there are what looks like should be TWO rubber bumpers between the front of the rear hard top section and the roll bar. Looks like I have one missing. Can someone check theirs to see if its just me, or that I'm actually missing one. Thanks!
Attached Thumbnails
Click image for larger version

Name:	image-1154011888.jpg
Views:	88
Size:	122.9 KB
ID:	246648   Click image for larger version

Name:	image-2333618909.jpg
Views:	75
Size:	126.0 KB
ID:	246649  


Dakovich is offline   Quote
Old 05-08-2013, 10:01 AM   #2
Jeeper
 
Join Date: Mar 2012
Location: Central Mass
Posts: 287
Don't believe so. I think that bumper exists so the panels sit level together.

Seginus is offline   Quote
Old 05-08-2013, 10:51 AM   #3
Jeeper
 
Join Date: Nov 2011
Posts: 176
But I only have one over the driver side, the hole is there in the passenger side, but no bumper.
Dakovich is offline   Quote
Old 05-08-2013, 12:51 PM   #4
Jeeper
 
COLOUJK's Avatar
 
Join Date: Oct 2012
Posts: 230
Quote:
Originally Posted by Dakovich View Post
But I only have one over the driver side, the hole is there in the passenger side, but no bumper.
There should be 2 bumpers, your missing one.
COLOUJK is offline   Quote
Old 05-08-2013, 05:16 PM   #5
Jeeper
 
ohioviper's Avatar
 
Join Date: Sep 2012
Location: Chillicothe, Ohio
Posts: 2,330
Yep missing bumper.
__________________

2015 JKU
2013 JK
2000 TJ
ohioviper is offline   Quote
Old 05-09-2013, 10:32 AM   #6
Jeeper
 
MangoTango34's Avatar
 
Join Date: Jun 2012
Location: Middle of Kansas
Posts: 362
Yep, i had the same problem! Same side also. All i did was find some rubber bumpers that are that long at lowes. Found some and super glued them on. All better now

__________________
Sometimes I have to make my own type of wheeling.
It's a Jeep thing - live with it.

/l ,[_],
l---L -OlllllllO-
()_) ()_)----)_)
MangoTango34 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 08:15 AM.



Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC