Jeep Hesitates when accelerating - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-18-2012, 01:09 PM   #1
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
Jeep Hesitates when accelerating

I have a 2009 Jeep Wrangler Sahara, 3.8L 6-Speed, and something weird started happening. When I accelerate and hit about 3,000 RPMs in any gear my jeep starts hesiatting bad and losing power. I have to let off the gas for it to stop and let the rpms get lower. Any ideas what this could be???

jibber is offline   Quote Quick Reply
Old 03-18-2012, 01:11 PM   #2
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 35,852
Quote:
Originally Posted by jibber
I have a 2009 Jeep Wrangler Sahara, 3.8L 6-Speed, and something weird started happening. When I accelerate and hit about 3,000 RPMs in any gear my jeep starts hesiatting bad and losing power. I have to let off the gas for it to stop and let the rpms get lower. Any ideas what this could be???
How many miles?

Any lights show on the dash?

kjeeper10 is online now   Quote Quick Reply
Old 03-18-2012, 01:15 PM   #3
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
Quote:
Originally Posted by kjeeper10 View Post
How many miles?

Any lights show on the dash?

It has 36000 miles. I see no lights on dash on.
jibber is offline   Quote Quick Reply
Old 03-18-2012, 01:17 PM   #4
Jeeper
 
JIMBOX's Avatar
 
Join Date: Nov 2009
Posts: 9,914
Does the Elex Throtle Control (ETC) RED LIGHTNING icon lightup ??

It's item #30 in your owners manual Dashboard icon chapter and tells about various sensors to control your throttle !

JIMBO
__________________
"ya gotta have class"
JIMBOX is offline   Quote Quick Reply
Old 03-18-2012, 01:20 PM   #5
cf1
Jeeper
 
cf1's Avatar
 
Join Date: Feb 2012
Posts: 26
Quote:
Originally Posted by JIMBOX View Post
Does the Elex Throtle Control (ETC) RED LIGHTNING icon lightup ??

It's item #30 in your owners manual Dashboard icon chapter and tells about various sensors to control your throttle !

JIMBO
try a diffrent brand of gas , mine did the same thing untill i changed brands of gas.
cf1 is offline   Quote Quick Reply
Old 03-18-2012, 01:25 PM   #6
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 35,852
Quote:
Originally Posted by JIMBOX
Does the Elex Throtle Control (ETC) RED LIGHTNING icon lightup ??

It's item #30 in your owners manual Dashboard icon chapter and tells about various sensors to control your throttle !

JIMBO
That's what I was thinking.

No "flashes" the ETC light will not stay on I don't think. Just flash.

I dont think bad gas will be RPM specific??

Sounds like a sensor problem or possibly a misfire/engine knock causing the knock sensor to cut throttle
kjeeper10 is online now   Quote Quick Reply
Old 03-18-2012, 01:33 PM   #7
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
UPDATE!! I just drove my jeep again and am completely losing power. It will idle fine, but if I am sitting still and give it gas, the RPMs will go up and then hhesitate and go back down. Even if I am still holding the gas pedal down. Can hear an occasional backfire too. This is frustrating. I can't even drive it to the dealer to have them look at it. I just bought this thing 2 weeks ago!
jibber is offline   Quote Quick Reply
Old 03-18-2012, 01:34 PM   #8
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 35,852
Quote:
Originally Posted by jibber
UPDATE!! I just drove my jeep again and am completely losing power. It will idle fine, but if I am sitting still and give it gas, the RPMs will go up and then hhesitate and go back down. Even if I am still holding the gas pedal down. Can hear an occasional backfire too. This is frustrating. I can't even drive it to the dealer to have them look at it. I just bought this thing 2 weeks ago!
Check your wires/plugs
kjeeper10 is online now   Quote Quick Reply
Old 03-18-2012, 01:43 PM   #9
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
And the ETC light is NOT on and is NOT flashing.
jibber is offline   Quote Quick Reply
Old 03-18-2012, 01:51 PM   #10
Jeeper
 
JIMBOX's Avatar
 
Join Date: Nov 2009
Posts: 9,914
If it's an auto--there's a little gold engine profile icon just under thr "P", when it lights up it shows OBD11 engine trouble and should exibit a failure code--

Otherwise it could also be gas filter contamination and there's nothing you can do aboutit--dealer time-

Good luck

--JIMBO
__________________
"ya gotta have class"
JIMBOX is offline   Quote Quick Reply
Old 03-18-2012, 01:55 PM   #11
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
It is a 3.8L, 6-speed MANUAL transmission. And there are NO dash lights on. NONE.
jibber is offline   Quote Quick Reply
Old 03-18-2012, 02:20 PM   #12
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
The engine seemed really hot when I opened the hood initially but the temperature guage was in the middle between Hot and Cold. I just let it set for about 20 minutes and it ran ok for a few seconds and then went back to the same thing.
jibber is offline   Quote Quick Reply
Old 03-18-2012, 02:20 PM   #13
Jeeper
 
pkmcd99's Avatar
 
Join Date: Jan 2012
Posts: 2,117
Quote:
Originally Posted by jibber
UPDATE!! I just drove my jeep again and am completely losing power. It will idle fine, but if I am sitting still and give it gas, the RPMs will go up and then hhesitate and go back down. Even if I am still holding the gas pedal down. Can hear an occasional backfire too. This is frustrating. I can't even drive it to the dealer to have them look at it. I just bought this thing 2 weeks ago!
MAP SENSOR, test the resistance with a meter. They can fail and not trip a code.
pkmcd99 is offline   Quote Quick Reply
Old 03-18-2012, 02:27 PM   #14
Jeeper
 
JIMBOX's Avatar
 
Join Date: Nov 2009
Posts: 9,914
Here's a simple free check--

Open your airfilter box and remove the filter---HOW DOIT LOOK ??

Vacuum the box all around and without putting the filter back in--startit and see how the engine ops--DON'T DRIVE LIKE THAT, BUT it may tell you something !

JIMBO
__________________
"ya gotta have class"
JIMBOX is offline   Quote Quick Reply
Old 03-18-2012, 02:32 PM   #15
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
Quote:
Originally Posted by JIMBOX View Post
Here's a simple free check--

Open your airfilter box and remove the filter---HOW DOIT LOOK ??

Vacuum the box all around and without putting the filter back in--startit and see how the engine ops--DON'T DRIVE LIKE THAT, BUT it may tell you something !

JIMBO

It has a K&N filter on it
jibber is offline   Quote Quick Reply
Old 03-18-2012, 02:34 PM   #16
Jeeper
 
Celtic's Avatar
 
Join Date: Nov 2010
Location: Shenandoah Valley
Posts: 707
Been in the water lately?
__________________
Best Always 🍀,
Celtic

___________

"Peej" - 2011 Wrangler Sport S Two Door, Quad Black, Six Speed
Celtic is offline   Quote Quick Reply
Old 03-18-2012, 02:36 PM   #17
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 35,852
Quote:
Originally Posted by pkmcd99

MAP SENSOR, test the resistance with a meter. They can fail and not trip a code.
Yep check the map

Probably loaded with oil from the K&N
kjeeper10 is online now   Quote Quick Reply
Old 03-18-2012, 02:36 PM   #18
Jeeper
 
JIMBOX's Avatar
 
Join Date: Nov 2009
Posts: 9,914
Thats too bad--there could be the problem, with contaminated MAP SENSOR, from using the K&N filter--like pkmc mentioned !


Quote:
Originally Posted by jibber View Post
It has a K&N filter on it
-JIMBO
__________________
"ya gotta have class"
JIMBOX is offline   Quote Quick Reply
Old 03-18-2012, 02:39 PM   #19
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
Where is that located?
jibber is offline   Quote Quick Reply
Old 03-18-2012, 02:44 PM   #20
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 35,852
Bingo
kjeeper10 is online now   Quote Quick Reply
Old 03-18-2012, 02:46 PM   #21
Jeeper
 
JIMBOX's Avatar
 
Join Date: Nov 2009
Posts: 9,914
google "Jeep JK MAP Sensor" and then what are you going to do ??

Get some onsite help--

--JIMBO
__________________
"ya gotta have class"
JIMBOX is offline   Quote Quick Reply
Old 03-18-2012, 03:20 PM   #22
Supporting Member

WF Supporting Member
 
SilverSport's Avatar
 
Join Date: May 2011
Posts: 21,555
Send a message via Yahoo to SilverSport
Similar symptoms to plugged cat.
__________________
"Own a Jeep and own a piece of history."

"The Hunter is not concerned with the opinion of the Wolf."
SilverSport is offline   Quote Quick Reply
Old 03-18-2012, 03:26 PM   #23
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
I found my MAP sensor, took it off and did not look like there was oil in it. I blew it out with my air compressor, installed it and same symptoms. I gave up, had my wife follow me to the dealership and dropped it off. I had the jeep for two weeks and put less than 200 miles on it. It is THEIR problem now. It is under warranty.
jibber is offline   Quote Quick Reply
Old 03-18-2012, 03:31 PM   #24
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 35,852
Quote:
Originally Posted by jibber
I found my MAP sensor, took it off and did not look like there was oil in it. I blew it out with my air compressor, installed it and same symptoms. I gave up, had my wife follow me to the dealership and dropped it off. I had the jeep for two weeks and put less than 200 miles on it. It is THEIR problem now. It is under warranty.
Well that's good. Hopefully they figure it out.
kjeeper10 is online now   Quote Quick Reply
Old 03-18-2012, 03:32 PM   #25
Jeeper
 
JIMBOX's Avatar
 
Join Date: Nov 2009
Posts: 9,914
Sounds good--they'll fixit--please post the findings , so we'll all know what it was--

Good luck-

JIMBO
__________________
"ya gotta have class"
JIMBOX is offline   Quote Quick Reply
Old 03-18-2012, 03:33 PM   #26
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
Quote:
Originally Posted by JIMBOX View Post
Sounds good--they'll fixit--please post the findings , so we'll all know what it was--

Good luck-

JIMBO

I definitely will. Thanks for everyone's help!
jibber is offline   Quote Quick Reply
Old 03-18-2012, 04:31 PM   #27
ESP
Jeeper
 
ESP's Avatar
 
Join Date: Jun 2010
Location: NC
Posts: 11,503
Subscribed.
__________________
98 XJ 02 TJ 10 JK 13 JK

2013 JK - Lifted w/ 35s - Bilstein 5100s - Monster TB - Chopped Flares - Can't Keep It Clean
ESP is offline   Quote Quick Reply
Old 03-18-2012, 05:54 PM   #28
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
Quote:
Originally Posted by Celtic View Post
Been in the water lately?

And no, NO water.
jibber is offline   Quote Quick Reply
Old 03-19-2012, 01:46 PM   #29
Jeeper
 
jibber's Avatar
 
Join Date: Oct 2011
Location: State College, PA
Posts: 198
UPDATE!! Well, I got a call from the Master Technician and they ran some tests and determined that there is a problem with the fuel pressure and they believe it is the fuel pump. They ordered a fuel pump (will be there tomorrow) and will have to drop the tank to install it. They said they will inspect the tank and everything else while the tank is dropped to eliminate any other possible problems. SO, I should know by the end of the day tomorrow if the fuel pump was the problem. Either way, I am getting a new fuel pump at their expense.
jibber is offline   Quote Quick Reply
Old 03-19-2012, 01:50 PM   #30
Jeeper
 
Celtic's Avatar
 
Join Date: Nov 2010
Location: Shenandoah Valley
Posts: 707
Good luck, keep us posted.

__________________
Best Always 🍀,
Celtic

___________

"Peej" - 2011 Wrangler Sport S Two Door, Quad Black, Six Speed
Celtic is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
You know you drive a Jeep when... Reaperonin General Jeep Discussion 5943 09-29-2014 07:58 PM
MD: 2012 Jeep Wrangler Sahara Silver Bumper trim Kelsey73 Classifieds Archive 10 05-09-2012 06:12 PM
Newbie - New Jeep Almost Here adamrs3 WF New Member Check In 12 03-20-2012 04:42 AM
GoPro Hero 2 with Jeep question ESP Off-Topic 0 03-18-2012 01:07 PM
jeep:1 dodge intrepid: 0 tracie JK General Discussion Forum 8 03-18-2012 11:46 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:41 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC