Lights causing Radio interference - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-11-2012, 07:53 PM   #1
Jeeper
 
Join Date: Jul 2012
Posts: 34
Lights causing Radio interference

So I'm having a problem that has been happening intermittently and has recently gotten worse.

I have window pillar mounted Rigid Industries D2 LED lights. On occasion, in the past, specifically when its raining or otherwise damp out (heavy fog etc), when i turn them on, my radio (FM) gets a fuzz/ static. It doesn't go COMPLETELY static, just intermittent signal.

the stock antenna was being held to the side of the light with a bracket. Last week i ordered an Antennax shorty, hoping that removing a physical connection from the antenna to the light would eliminate the static. Well now its worse.

I get no other symptoms of bad ground on any other aspect of the jeep. CD, HDD all fine, no flickering lights or anything.

I'm totally stumped. any thoughts?

itgbudeev is offline   Quote Quick Reply
Old 01-20-2013, 09:50 PM   #2
Newb
 
Jkus's Avatar
 
Join Date: Dec 2011
Location: Pomona, CA
Posts: 12
same problem, ever find the problem?

Jkus is offline   Quote Quick Reply
Old 04-29-2013, 11:30 PM   #3
Jeeper
 
Matty87's Avatar
 
Join Date: Jun 2012
Location: Ontario,Canada
Posts: 60
I have this problem, I had the rigid d2s mounted on the windshield pillars and it messed with the radio when I turned them on, recently I got HiD lights installed now my radio is even worse, all the time now
Matty87 is offline   Quote Quick Reply
Old 04-30-2013, 01:29 AM   #4
Jeeper
 
relyt's Avatar
 
Join Date: Mar 2011
Location: Sidney, OH
Posts: 668
Mine do the same. I assumed it was because the lights aren't shielded very well and they're right beside the antenna. Not a big deal as far as I'm concerned.
relyt is offline   Quote Quick Reply
Old 04-30-2013, 03:56 AM   #5
Jeeper
 
Lusus_Naturae's Avatar
 
Join Date: Oct 2012
Location: OKC, missing WI
Posts: 2,081
I wouldn't say this is normal. The TJ has the antenna in the same area, and I ran windshield lights with no issue. Could it be related back to the CANbus system again?

How are the windshield lights run, directly to battery or sPod or hacked into the factory wiring?

I'm curious if this also happens to non-LED lights too in the same mounting area.

Could also be the ground to the antenna is not good, or for that matter, the wire itself is low quality. I'd try tapping a ground to the antenna, wrapping the stock antenna wire, and just messing around in that area first.
__________________
2013 JKU Sport, billet, auto, 3.73, LSD, 315/75/16 Duratracs on MB 72, 10A springs, Bushwacker flatties

Sold - 2005 TJ, red, auto, 3.73, 33" Duratracs, 4" lift
Ice storm casualty in 2007 - 2003 TJ, green, auto, 3.73, 33" Duratracs, 4" lift
Lusus_Naturae is offline   Quote Quick Reply
Old 04-30-2013, 08:12 AM   #6
Jeeper
 
Off Pavement's Avatar
 
Join Date: Sep 2012
Location: The Silver State
Posts: 620
If you REALLY want to find a workaround for interference from LEDs, read this... RFI Problems
__________________
The Road To Paradise Is NOT Paved
Off Pavement is offline   Quote Quick Reply
Old 04-30-2013, 11:18 AM   #7
Jeeper
 
Join Date: Feb 2013
Location: Windsor Ont
Posts: 244

2footin is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:56 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC