Mygig radio freezing.. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-27-2010, 07:13 AM   #1
Jeeper
 
Join Date: Mar 2010
Location: MD
Posts: 261
Mygig radio freezing..

today is the third day in a row that the mygig radio froze up. first time it happened i was on my way home from work listening to the HHD, second time it happened as soon as i started the jeepup and it said it was trying to activate the navigation but yet wouldnt activate at all or even alow me to play music, third time this morning i was listening to the HHD again and it frove. all 3 times it wouldnt let me do anything besides switch back and fourth thru the menus. but yet would notletme play music or anything.

anybody else have this problem? is this typical of a jeep product?

guygettnby is offline   Quote Quick Reply
Old 04-28-2010, 08:46 AM   #2
Jeeper
 
Join Date: Mar 2010
Location: MD
Posts: 261
ok, i finally am at the dealer as the problem continued to happen and get worse. it got to the point the mygig would completely freeze and even stayed on when i turned the jeep off. when i got home last night i turned the jeep off when i got home and about 2 hours later went to go get the mail, i then noticed that the radio was infact still on and still froze in the same spot it was when i drove home. i had to actually unhook the battery to shut it off.

after doing alot of research about this i find this is not an uncommon problem. i have found alot of people having the same problem.

guygettnby is offline   Quote Quick Reply
Old 04-28-2010, 05:32 PM   #3
Jeeper
 
Join Date: Mar 2007
Posts: 16
Quote:
Originally Posted by guygettnby View Post
ok, i finally am at the dealer as the problem continued to happen and get worse. it got to the point the mygig would completely freeze and even stayed on when i turned the jeep off. when i got home last night i turned the jeep off when i got home and about 2 hours later went to go get the mail, i then noticed that the radio was infact still on and still froze in the same spot it was when i drove home. i had to actually unhook the battery to shut it off.

after doing alot of research about this i find this is not an uncommon problem. i have found alot of people having the same problem.

What version of the software are you running? I recommend upgrading to the latest 2.043 (don't ask about the numbering scheme - apparently DC cannot count upwards from 9...)! Go here for download:http://mofv.com/MyGIG/WithNav/RER_2.043.zip

and go here for download/install instructions:http://www.mofv.com/mygig/DLZipBurnGuide.htm

Enjoy!
__________________
AKA HaggisHunter



JK 4DR 4WD 6sp black
amr42 is offline   Quote Quick Reply
Old 04-28-2010, 09:24 PM   #4
Jeeper
 
Join Date: Mar 2010
Location: MD
Posts: 261
funny thing... that is the version i had installed before i went to the dealer.. now i have something else installed that actually changed the entire layout of the mygig radio. it also sounds 100% different, like the sound quality is alot clearer but the rear speakers hardly sound like they are even on and i cant get the bass to go up with out seeming like the front speakers are crackling. the sub is pretty much useless right now and barely puts out any sound/bass. i will look up the version they installed and post it up tomarrow.

they said that the software they put on was a chrysler software and nobody else had it out yet. wich i think is BS, but i told they i would see how it worked out and we would go from there.
guygettnby is offline   Quote Quick Reply
Old 05-01-2010, 01:46 PM   #5
Jeeper
 
Join Date: Mar 2010
Location: MD
Posts: 261
the software they put on the mygig in my jeep is 1.022 so if im not mistaken shouldnt the newer version be 2.043?

oh yea and BTW the radio crashed again this afternoon. i called the dealer and they said for me to bring it in again so they could diagnose the problem.
guygettnby is offline   Quote Quick Reply
Old 05-03-2010, 06:18 PM   #6
Jeeper
 
Join Date: Mar 2007
Posts: 16
Quote:
Originally Posted by guygettnby View Post
the software they put on the mygig in my jeep is 1.022 so if im not mistaken shouldnt the newer version be 2.043?

oh yea and BTW the radio crashed again this afternoon. i called the dealer and they said for me to bring it in again so they could diagnose the problem.
Yes, youa re correct v2.043 is the latest SW for RER MyGIG.

Your sound problems may be related to a TSB for a re-program for the amplifier. I have heard otehrs report of similar experiences. Your dealer may have applied the wrong TSB to fix your MyGIG issue...
__________________
AKA HaggisHunter



JK 4DR 4WD 6sp black
amr42 is offline   Quote Quick Reply
Old 05-04-2010, 07:52 AM   #7
Jeeper
 
Join Date: Mar 2010
Location: MD
Posts: 261
Quote:
Originally Posted by amr42 View Post
Yes, youa re correct v2.043 is the latest SW for RER MyGIG.

Your sound problems may be related to a TSB for a re-program for the amplifier. I have heard otehrs report of similar experiences. Your dealer may have applied the wrong TSB to fix your MyGIG issue...
i have heard of this issue on other forums aswell. i have to take the jeep back in still for them to try and decide if they are going to replace the radio or not wich is what i heard they need to do in order to fix the problem. some have said this is caused by a corrupt hard drive. i was going to reinstall the new software but i didnt want to mess with anything and the dealer blame this on me.

guygettnby is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing aftermarket Radio in TJ write up TheTJRod Communications and Electronics 157 09-05-2014 11:27 PM
I passed! amy Communications and Electronics 38 09-19-2011 03:04 PM
New Radio Unit...Now AC Doesn't work? HELP! Rawb77 Communications and Electronics 9 03-02-2010 08:42 AM
Stock Radio ???s nicolas-eric TJ Tech Forum 1 05-22-2009 06:04 PM
Plug and Play Sirius Satellite Radio scotiez Communications and Electronics 5 02-08-2008 10:16 PM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 06:56 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC