NavTV with Aftermarket Stereo System - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-24-2013, 10:30 AM   #1
Jeeper
 
dcstein's Avatar
 
Join Date: Jul 2012
Posts: 185
Angry NavTV with Aftermarket Stereo System

I bought a NavTV (allgig and av harness) unit directly from navtv. I had this, along with a new system (amp, lc7i, and speakers) installed professionally this weekend. After several hours of trying, the installers couldn't get the the system to work properly. They said with the NavTv installed, one of the audio channels on the system was barely audible. They thought it may have been the LC7i or the Amp, but after replacing those and the problem remained, they realized it was the NavTV. They disconnected that and the sound worked as intended. So my question, anyone have a similar issue? Any idea what could cause this or fix it? I'd like to get the NavTv installed so I can use the backup camera and other features. I'll be calling NavTv shortly too and will post if they offer a soluion. Any help is appreciated!

dcstein is offline   Quote
Old 06-24-2013, 02:36 PM   #2
Jeeper
 
Join Date: Oct 2012
Posts: 68
Quote:
Originally Posted by dcstein View Post
I bought a NavTV (allgig and av harness) unit directly from navtv. I had this, along with a new system (amp, lc7i, and speakers) installed professionally this weekend. After several hours of trying, the installers couldn't get the the system to work properly. They said with the NavTv installed, one of the audio channels on the system was barely audible. They thought it may have been the LC7i or the Amp, but after replacing those and the problem remained, they realized it was the NavTV. They disconnected that and the sound worked as intended. So my question, anyone have a similar issue? Any idea what could cause this or fix it? I'd like to get the NavTv installed so I can use the backup camera and other features. I'll be calling NavTv shortly too and will post if they offer a soluion. Any help is appreciated!
I've read about this issue on a different forum multiple times, that's why I went and purchased NavTool interface

wrangler4eva is offline   Quote
Old 06-25-2013, 08:14 AM   #3
Jeeper
 
dcstein's Avatar
 
Join Date: Jul 2012
Posts: 185
Quote:
Originally Posted by wrangler4eva View Post
I've read about this issue on a different forum multiple times, that's why I went and purchased NavTool interface
Any specific forum threads you can point me to? I've been searching and can't find any threads specific to audio issues.
dcstein is offline   Quote
Old 06-25-2013, 10:21 AM   #4
Jeeper
 
Join Date: Oct 2012
Posts: 68
Quote:
Originally Posted by dcstein View Post
Any specific forum threads you can point me to? I've been searching and can't find any threads specific to audio issues.
Not sure I was searching in Google and came across
wrangler4eva is offline   Quote
Old 08-06-2013, 09:39 AM   #5
Jeeper
 
dcstein's Avatar
 
Join Date: Jul 2012
Posts: 185
I know this is an old thread, but I figured I'd post my resolution. I worked with the NavTV guys, they are awesome btw, and they ended up writing some new code for Jeeps with a manual transmission. They sent the code to me and I updated it via the included USB wire. Very easy and it worked. Now the device works as advertised and is great. Can't emphasize enough how good the customer service was.
dcstein is offline   Quote
Old 08-09-2013, 05:21 PM   #6
Jeeper
 
Join Date: Aug 2013
Posts: 22
^ yes nav tv is a great company. Shame i didnt see this when you needed an answer. Most of the Nav TV pieces are coded to different trims. When I put NAV TV pieces in at the shop, most time I have to reflash the NAV TV module to the correct trim, which in turn solves the issue. The NAV TV piece is the best on the market.

honda400ex81 is offline   Quote
Reply

Tags
navtv amp camera jl

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:48 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC