Need Some Help - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-28-2012, 10:12 PM   #1
Jeeper
 
JOCJK's Avatar
 
Join Date: Jun 2012
Location: The Mountains
Posts: 800
Need Some Help

Installing the leveling kit and ran into a problem. It appears the bolt on the new sway bar link is bigger than the stock ones. I can't get it through, it goes in about 3/4's of the way and jams up. Its almost like the threads are thicker half way down the bolt. Am I crazy? Two of us tried with no success to get it on, tried with some finesse tried with some force and nothing. If I can't get the new one on can I put the stock ones for the time being? Anyone else have this problem? Is it possible i got the wrong part? Maddening.
Attached Thumbnails
Click image for larger version

Name:	IMG_0203.jpg
Views:	21
Size:	221.1 KB
ID:	136348  

JOCJK is online now   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:16 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC