One year of ownership - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-14-2014, 12:10 AM   #1
Jeeper
 
rnuover13's Avatar
 
Join Date: Jul 2013
Posts: 115
One year of ownership

And not one issue with my 2013 JKUR. Guess I'm one of the lucky few.

rnuover13 is offline   Quote Quick Reply
Old 01-14-2014, 01:02 AM   #2
Jeeper
 
Andydeelight's Avatar
 
Join Date: Apr 2013
Location: LA 2 NAPA
Posts: 16
Awesome. The only thing I've had was a baby leak in my soft top that is fine now.

Andydeelight is offline   Quote Quick Reply
Old 01-14-2014, 06:57 AM   #3
The Bad Guy

WF Supporting Member
 
daggo66's Avatar
 
Join Date: May 2009
Location: NJ exile living in Baltimore
Posts: 22,060
Actually you are part of the silent majority. No one bitches that everything is normal.
__________________
Tom

"I've got two things in this world, my balls and my word and I don't break them for no one."
daggo66 is online now   Quote Quick Reply
Old 01-14-2014, 07:43 AM   #4
Jeeper
 
Join Date: Jun 2012
Location: Central TX
Posts: 330
Just over 1 year and 20,000 miles on my '13 JKU Sahara. No problems!
backdoc is offline   Quote Quick Reply
Old 01-14-2014, 08:05 AM   #5
Supporting Member

WF Supporting Member
 
kurtz265's Avatar
 
Join Date: Mar 2012
Location: Ridgefield, CT
Posts: 685
same- 2012 JKUR, 20,000 miles, no issues.
kurtz265 is offline   Quote Quick Reply
Old 01-14-2014, 08:18 AM   #6
Jeeper
 
Join Date: May 2011
Posts: 2,214
Quote:
Originally Posted by backdoc View Post
Just over 1 year and 20,000 miles on my '13 JKU Sahara. No problems!

Good to know.
demarpaint is offline   Quote Quick Reply
Old 01-14-2014, 08:45 AM   #7
Jeeper
 
Old Dogger's Avatar
 
Join Date: May 2012
Location: Phoenix, Rattlesnake Country
Posts: 3,084
10 months and 6,000 miles on my 2013 JKR, with only a radiator cap replaced.
It runs and performs great, with no other problems.........
Old Dogger is offline   Quote Quick Reply
Old 01-14-2014, 08:59 AM   #8
Build Thread Queen

WF Supporting Member
::WF Moderator::
 
StarBrite's Avatar
 
Join Date: Jun 2013
Location: Austin, Texas
Posts: 6,421
14 months, 22,000+ miles and no mechanical problems with our 2013.

We did have an issue with paint on the hinges, but that was repaired under warranty and haven't had any recurrence.
__________________
2014 JKU FE - 'Celticon' - Hydro Blue Pearl - Auto - 3.73 - Premium Soft Top - TeraFlex 2.5" Lift w/Rancho 9000xl Shocks - 15" MBTKO/33" DuraTracs - ACE Rock Sliders/Cargo Basket - Rampage Recovery Bumper
My build thread: StarBrite's Celticon
StarBrite is offline   Quote Quick Reply
Old 01-14-2014, 09:03 AM   #9
Jeeper
 
Jdpatt12's Avatar
 
Join Date: Nov 2012
Location: Illinois
Posts: 216
Just over 14mos on my jku sport and 0 issues. I've been waiting about 2 mos to get it in dealer for the transmission line recall. I'm trying not to let it bug me but my dealer is going very slow on them due to jeep not sending the parts needed. And I have a little over 14,000 miles on it.
Jdpatt12 is online now   Quote Quick Reply
Old 01-14-2014, 09:09 AM   #10
Build Thread Queen

WF Supporting Member
::WF Moderator::
 
StarBrite's Avatar
 
Join Date: Jun 2013
Location: Austin, Texas
Posts: 6,421
Ooops! Forgot about the recall. Had that fixed yesterday.

Jdpatt, for what it's worth my dealership said Chrysler solved the supply issue and has enough parts for the recall now. I was on a list and going by the dealership's timeline it wouldn't have been done until July. They called last week and said Chrysler sent all the parts in one shipment. Maybe check with your dealership and ask if they've checked on parts recently.
__________________
2014 JKU FE - 'Celticon' - Hydro Blue Pearl - Auto - 3.73 - Premium Soft Top - TeraFlex 2.5" Lift w/Rancho 9000xl Shocks - 15" MBTKO/33" DuraTracs - ACE Rock Sliders/Cargo Basket - Rampage Recovery Bumper
My build thread: StarBrite's Celticon
StarBrite is offline   Quote Quick Reply
Old 01-14-2014, 09:23 AM   #11
Jeeper
 
AverageJK's Avatar
 
Join Date: Oct 2012
Location: Phoenix
Posts: 1,140
Images: 1
I've had my 2013 for a year now too. Only issue I had is the auto down feature broke for the drivers window switch.
__________________
2013 Moab
"Insert mod list here."
My Average JK Build Thread
My Jeep Profile
AverageJK is online now   Quote Quick Reply
Old 01-14-2014, 09:27 AM   #12
Jeeper
 
Join Date: Jul 2013
Location: South Florida
Posts: 237
13 Sport with with 9,000 miles and 6 months, I've replaced the oil sensor, clutch switch, and rear differential fluid, but I still love it and would rather get the gremlins discovered/fixed while still under warranty than years down the road. I love my JEEP.
ssteacher95 is offline   Quote Quick Reply
Old 01-14-2014, 10:26 AM   #13
Supporting Member

WF Supporting Member
 
Knuckles65's Avatar
 
Join Date: Mar 2013
Location: Orlando, FL
Posts: 1,205
8 months and 8K miles here and only one minor problem with a bad door gasket (It was leaking very slightly onto the drivers side floor.) and a clogged/dripping rear washer sprayer.

__________________
2013 Commando Green JK Rubicon
-------------------------------------------------
Remember - sometimes, the advice you get on the Internet is worth exactly what you paid for it!
Knuckles65 is offline   Quote Quick Reply
Old 01-14-2014, 11:18 AM   #14
Jeeper
 
Join Date: Sep 2013
Posts: 81
6000 miles of smiles over 4 months. Loving it (specially now that I swapped out the factory speakers )
Ricanbandit is offline   Quote Quick Reply
Old 01-14-2014, 11:29 AM   #15
Jeeper
 
JeepDirtyGirl's Avatar
 
Join Date: Jul 2011
Location: NY
Posts: 182
2011 JK Sport S with 21,000 miles on the odo and no problems here either. Only quirk is when it POURS outside, I end up with approximately a quarter sized spot of water on the front passenger side footwell. Definitely not going to complain about that. With my luck, I would take it in to be fixed and come back with it leaking like a sieve on the next bit of a sprinkle. I have even taken it through the touchless car wash, and she does just fine. I drive quickly through the blast of air to dry it though since she has a soft top.
__________________
Happy Jeepin'!!
JeepDirtyGirl is offline   Quote Quick Reply
Old 01-14-2014, 11:50 AM   #16
Jeeper
 
Jdpatt12's Avatar
 
Join Date: Nov 2012
Location: Illinois
Posts: 216
Quote:
Originally Posted by StarBrite View Post
Ooops! Forgot about the recall. Had that fixed yesterday. Jdpatt, for what it's worth my dealership said Chrysler solved the supply issue and has enough parts for the recall now. I was on a list and going by the dealership's timeline it wouldn't have been done until July. They called last week and said Chrysler sent all the parts in one shipment. Maybe check with your dealership and ask if they've checked on parts recently.
I went to the dealer this past Friday. 2 months ago I was #4 now I'm # 3 on the list. They said they would call when the part was in.
Jdpatt12 is online now   Quote Quick Reply
Old 01-14-2014, 12:13 PM   #17
Jeeper
 
thejdj's Avatar
 
Join Date: Oct 2010
Location: San Diego, CA
Posts: 122
5K miles in 7 months. Water pump was replaced under warranty and the trans line replaced. No other issues. Love it.
__________________
2013 JK Sport S in Billet. AT, HT, 3.73, 430N, Truck-Lite's, AEV CHMSL, Rubi Rails, Tint. 9K
<sold> Inferno Red 2005 WK 5.7L Limited QDII
<sold> Flame Red 2001 TJ Sport
<sold> Taupe Frost 2000 WJ Laredo 4.7 QD
<sold, bought back, sold again> Flame Red 1997 TJ Sport
thejdj is offline   Quote Quick Reply
Old 01-14-2014, 01:11 PM   #18
Jeeper
 
spinlock's Avatar
 
Join Date: Sep 2013
Location: 37.9° N, 121.7° W
Posts: 2,614
Zero defects here on either of my 2 JKs!

But if I really put some effort into it I can probably find something to complain about.
spinlock is offline   Quote Quick Reply
Old 01-14-2014, 01:56 PM   #19
Supporting Member

WF Supporting Member
 
Join Date: Jan 2013
Posts: 26
2013 JKS here - one year old an zero problems.
bobver is offline   Quote Quick Reply
Old 01-14-2014, 04:35 PM   #20
Jeeper
 
Join Date: Feb 2013
Posts: 200
Problems? None.
Annoyances? 3 rock dings in the wind shield, and a back seat that bounces around when you fold it down.
Likes? Still staying above 18 MPG (between 18 and 21 depending on how much freeway driving I do)
12 months 20K so far
jimbot is offline   Quote Quick Reply
Old 01-14-2014, 04:43 PM   #21
Jeeper
 
Join Date: Nov 2012
Location: In The Hot South West AZ
Posts: 996
My 2013 Rubicon is 14 months old, with about 9000 miles on it.
One trip to the Dealer for a coolant issue, other than that, it has been trouble free!
Miser is offline   Quote Quick Reply
Old 01-14-2014, 04:44 PM   #22
Jeeper
 
RCMurray's Avatar
 
Join Date: Jan 2014
Location: Hanover, MD
Posts: 76
2 1/2 weeks and 500 miles here…no problems yet
RCMurray is offline   Quote Quick Reply
Old 01-14-2014, 05:06 PM   #23
Jeeper
 
Join Date: May 2010
Location: NW WA
Posts: 868
Just rolled 9,000 miles. No problems here.
TrueNorth is offline   Quote Quick Reply
Old 01-14-2014, 06:48 PM   #24
Jeeper
 
Join Date: Apr 2013
Location: Burbank, CA
Posts: 320
Quote:
Originally Posted by daggo66 View Post
Actually you are part of the silent majority. No one bitches that everything is normal.
I 100% agree with you.
__________________
THE DESERT FILES

FIND MY BLOG IN MY PROFILE

http://www.wranglerforum.com/members...wk-152359.html
socalwk is offline   Quote Quick Reply
Old 01-14-2014, 10:20 PM   #25
Jeeper
 
bostongmw's Avatar
 
Join Date: Nov 2012
Posts: 79
14 months and 27,000 miles. Just fuel, oil and three windshields ... And we don't go off road. Windshield is a rock magnet.
bostongmw is offline   Quote Quick Reply
Old 01-14-2014, 10:44 PM   #26
Jeeper
 
baddandy's Avatar
 
Join Date: Jul 2007
Location: Spanaway, WA
Posts: 175
Images: 1
1 year old today. Xfer case cable hose mod to stop the dash rumble is it so far at 15,000 miles. I have a click sound in the left door panel over bumps probably caused by having to slam the door with the hardtop.
__________________
2001 Jeep TJ Sport Rubiclone, SOLD
2013 JK 2 Door Sport Rubiclone 6 speed, RC 3.5" Series II, JKS front TB, TF rear TB brkt, 315/70/17 GY Duratracs, 17x8 ProComp 7005s, Rubi 44s
baddandy is offline   Quote Quick Reply
Old 01-14-2014, 11:45 PM   #27
Jeeper
 
RoadiJeff's Avatar
 
Join Date: Dec 2012
Location: St. Louis, MO
Posts: 2,053
Quote:
Originally Posted by rnuover13 View Post
And not one issue with my 2013 JKUR. Guess I'm one of the lucky few.
Same here on our 2013 JK. One year, 7,000 miles and all smiles.

We did take it in earlier today so they could inspect this transmission line recall for the 2013s to see if ours needed it. Apparently it does and the parts are on order.
RoadiJeff is offline   Quote Quick Reply
Old 01-15-2014, 05:16 AM   #28
Jeeper
 
Breitling's Avatar
 
Join Date: Jun 2013
Posts: 283
8k miles on 2013 JKU, no problems besides usual freedom panels leak fixed by 303 solution.
Breitling is offline   Quote Quick Reply
Old 01-15-2014, 05:30 AM   #29
Jeeper
 
MBeshada's Avatar
 
Join Date: Jun 2012
Posts: 108
Almost a year and turned 15,000 miles as I rolled into the driveway from work yesterday. Zero issues.
MBeshada is offline   Quote Quick Reply
Old 01-15-2014, 07:33 AM   #30
NO MALLCRAWLER NO MORE!

WF Supporting Member
 
mommymallcrawler's Avatar
 
Join Date: Sep 2013
Location: Scottsdale, Arizona
Posts: 1,935
Quote:
Originally Posted by TrueNorth View Post
Just rolled 9,000 miles. No problems here.
When I read this quickly at first I thought it said "I just rolled IT at 9,000". Was going to congratulate you lo!

My Jeep is still a baby. Will be 4 months on the 29th and sitting at 3300 lol. On our off road last weekend our leader told me "Your Jeep is just like a baby. Give it a hard spank into 4LO and make it crawl!" All I have done so far is an oil change.

__________________
Newbies Mandatory First Jeep Mod...
Get it naked, get it dirty and play with it!
mommymallcrawler is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:38 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC