problem with speedo and tach - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-24-2011, 05:03 PM   #1
Newb
 
Join Date: Jan 2011
Posts: 5
problem with speedo and tach

Hi, I'm a newbie; and so far, I'm really impressed with this forum. I have a 2000 Wrangler with the six cylinder, and my tach and speedo repeatedly go off and on almost as if they're trading times to work. If I didn't need them, it's actually pretty entertaining. I thought maybe a bad voltage regulator; but when I took the cluster apart, it's all chips and everything is part of the circuit board. The local dealer tells me that sometimes the voltage regulator is in the power distribution box (?) and sometimes it's still not replaceable. Has anyone experienced this problem before? If so, please help.

riven2649 is offline   Quote
Old 01-24-2011, 05:10 PM   #2
Jeeper

WF Supporting Member
 
firehawk_1989's Avatar
 
Join Date: May 2010
Location: Davenport, IA
Posts: 4,241
Welcome riven! glad to hear you like the forum.

Just wanted to let you know that you posted this in the JK (2007-present) Forum. You will get better responses if you post in the TJ forum, from the TJ owners. You can ask a Mod to move the thread for you, or if they see this they might do it.

Anyway, welcome!

firehawk_1989 is offline   Quote
Old 01-25-2011, 04:14 PM   #3
Newb
 
Join Date: Jan 2011
Posts: 5
Reply to firehawk

Thank you very much for your welcome and your info. I really appreciate it.

Gary
riven2649 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent engine bucking problem 98TJsport TJ Tech Forum 0 11-08-2010 03:42 PM
No Speedo, No Tach, and nobus in odometer fonecop1 TJ Tech Forum 0 08-04-2010 06:46 AM
Electrical problem PEPPERHEAD TJ Tech Forum 4 09-15-2009 10:57 AM
Super 44 and new speedo gear juspimpin TJ Tech Forum 4 05-26-2008 10:34 AM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:30 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC