Radio and electric windows sometimes don't work. Help. - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-24-2014, 05:04 PM   #1
Jeeper
 
ColoRubicon's Avatar
 
Join Date: Nov 2012
Location: Colorado
Posts: 206
Radio and electric windows sometimes don't work. Help.

Since I have had my 2013 JKUR I have had this problem on and off. I start the Jeep and the radio is on, (730N), it is showing info, but there is no sound, no blue tooth, no connection at all. Sometimes when this happens my front windows will not roll down and at at times it is the back windows as well. Talked to the dealership and they said to "jiggle the key, there is something with the alternators in some Jeeps" (Um okay) This doesn't help. The first couple times this happened I put the Jeep in park, turned it off and restarted it and it worked fine (like it needed to be rebooted)....however this has happened about 10 times and it is taking more and more times of turning the Jeep off and back on before it works.
I also bought the LED interior lights suggested on the forum, when I put the LED lights in the dome light, if the passenger one is replaced with LED then the map lights come on (flickering slightly) and stay on until the bulb is removed. Not sure if there is serious electrical issues...I have an appointment at the dealership on Weds. however I was just wondering if anyone else is having this issue?

__________________
Linda
Jeeps are Cool!
2013 JKUR Deep Cherry Red/Saddle Leather/4.10gears/730N/3.5" AEV lift/ 315x70x17, Wrangler Duratracs/RockHard front bumper, Off Road Only Hop-Stopper hood Latch
http://www.quadratec.com/products/13103_1020.htm
ColoRubicon is offline   Quote
Old 01-24-2014, 05:09 PM   #2
Jeeper
 
CarloDiMarco's Avatar
 
Join Date: Jul 2012
Location: Northeast
Posts: 41
If you remote start your Jeep I know a lot of stuff doesn't work until you insert the key and turn her on. Do you have remote start? Wonder if it is somehow related.

Did problem start after you put in the led lights?

CarloDiMarco is offline   Quote
Old 01-25-2014, 01:09 PM   #3
Jeeper
 
ColoRubicon's Avatar
 
Join Date: Nov 2012
Location: Colorado
Posts: 206
I do have remote start however this has never happened when I use remote start, it only happens when I hop in, start the jeep.....there is no sound what so ever, I have gone as far (many times) as to put it in park, take the key out and open the door to reset the whole system but it doesn't always do the trick and lately it is taking longer and longer to get the sound to come back on. Yesterday when this happened, I tried restarting it several times at stop signs and stop lights (I must look like an idiot if someone is paying attention), I made it to my destination and took the key out, waited a few minutes and then it worked fine. Seriously this drives me nuts

The problem has been happening forever, long before the lights, however I mentioned the lights because something is going on there as well, changing the bulbs should not make the map lights come on and stay on....really wondering if there is a bigger issue and hoping they will figure it out. I LOVE my Jeep and don't want to have to deal with electrical issues and I really don't want to trade it in.
__________________
Linda
Jeeps are Cool!
2013 JKUR Deep Cherry Red/Saddle Leather/4.10gears/730N/3.5" AEV lift/ 315x70x17, Wrangler Duratracs/RockHard front bumper, Off Road Only Hop-Stopper hood Latch
http://www.quadratec.com/products/13103_1020.htm
ColoRubicon is offline   Quote
Old 01-25-2014, 02:16 PM   #4
Jeeper
 
Raziel's Avatar
 
Join Date: Aug 2011
Posts: 781
An electrical diagram will help to see if the radio& Windows are connected some how. Loose battery connection could cause issues, check that out. Could be poor connection some where.
__________________
2011 Jeep Wrangler Unlimited, M/T


Home, Home Is Where The Heart Is. That Is What They Say. It's Sorrow Is As Sweet To Me As Red Wine...
Raziel is offline   Quote
Old 02-12-2014, 06:21 PM   #5
Newb
 
Join Date: May 2013
Location: Ft. Worth TX
Posts: 4
I just ran into this same issue. Jeep delivered yesterday, just 100 miles, '14 JKUR. I'm no newbie to Jeeps, have owned a TJ and CJ, just new to one with more electronics. Got in this afternoon, sun finally came out decided to roll down windows - fronts did not work, but rear did. I have remote start but didn't use it. Put in park, turned off and restarted. Windows work.

Question to OP- did you get any further info from the dealer? Plan on stopping by this weekend to get things checked, didn't make sense.
Admiral is offline   Quote
Old 02-12-2014, 10:34 PM   #6
Jeeper
 
ColoRubicon's Avatar
 
Join Date: Nov 2012
Location: Colorado
Posts: 206
Admiral, I took my 13 JKUR back to the dealer two weeks ago today, they updated the 730N and said this was what was causing the radio not to work. So far I have only had my phone not connect once, which could have been an issue with the phone. We will see. As for the windows, the dealer said the window switch panel is bad and ordered a new one....I haven't heard back from them, I plan on calling tomorrow to see if the part has arrived. I also asked them to order the dome light to see if this will fix the other issue I had when I replaced my interior lights with LED ones. (The map lights come on and flicker, won't go off unless i put the regular bulb back in.)
Let me know if you have a similar situation, I am curious to see what the say.

__________________
Linda
Jeeps are Cool!
2013 JKUR Deep Cherry Red/Saddle Leather/4.10gears/730N/3.5" AEV lift/ 315x70x17, Wrangler Duratracs/RockHard front bumper, Off Road Only Hop-Stopper hood Latch
http://www.quadratec.com/products/13103_1020.htm
ColoRubicon is offline   Quote
Reply

Tags
electrical , radio , windows

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:11 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC