RPM's don't drop - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-15-2011, 04:00 PM   #1
Jeeper
 
adrenaline's Avatar
 
Join Date: Aug 2010
Location: Arizona
Posts: 158
RPM's don't drop

I have a 2010 JK. It has really low miles on it.
5sp manual pretty stock, except it has new springs and shocks of of a Rubicon and stock wheels and tires off of a rubi. The tires are BF G muds.

The issue if it is

When I push the Jeep a little I mean hold the gear to 5K rpms the rpms stay there when I take my foot off of the gas and push the clutch. They stay there for a good 2 seconds. It actually stays up there longer the higher in the rpm range I am in. It is seriously driving me crazy. I have gone to the dealer and drove other 2010, and they all seem to do the same thing. It is probably not an issue, but it is aggravating to the point where I really don't like to drive the Jeep anymore.

My question is. Can I buy a scanner, and change it so the RPM's drop quicker when releasing the gas pedal? Of if not is this something that the dealer can change? What if I got a new ECU out of an 09?

Somebody help!!

adrenaline is offline   Quote
Old 06-15-2011, 04:20 PM   #2
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 6,420
I wish I could help you further, but my 10 Rubi doesn't do that at all. In fact it feels the same to me as my YJ with mechanical linkage. As soon as I let off the gas the rpm's drop. I've heard of this problem before so you're not alone. I can't believe that's it normal, especially because mine doesn't do it. I have a 6spd. Maybe that makes a difference. I don't know.

kik is online now   Quote
Old 06-15-2011, 04:26 PM   #3
Jeeper
 
adrenaline's Avatar
 
Join Date: Aug 2010
Location: Arizona
Posts: 158
Quote:
Originally Posted by kik View Post
I wish I could help you further, but my 10 Rubi doesn't do that at all. In fact it feels the same to me as my YJ with mechanical linkage. As soon as I let off the gas the rpm's drop. I've heard of this problem before so you're not alone. I can't believe that's it normal, especially because mine doesn't do it. I have a 6spd. Maybe that makes a difference. I don't know.
Well that is good to hear at least it does seem to be a problem. I will go talk to the dealer, but I haven't found one here yet that I like. The problem is you talk to the service writer and they don't understand so you go on a road test with them and they say oh that is normal and send you on your way. Like I say I have driven others on the lot and they do the exact same thing.

Thanks for letting me know yours is different now I have something to pursue.
adrenaline is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
High rpm's at cold start. HELP! 1FUNYJ YJ Tech Forum 0 02-28-2011 02:19 PM
High RPM's? surfskate21 General Jeep Discussion 12 11-29-2010 01:30 PM
RPM's drop at start gth-wrangler97 TJ Tech Forum 5 04-06-2010 08:32 PM
Transfer case drop removal? chiro2736 TJ Tech Forum 34 07-15-2008 09:16 PM
T-case drop removal GrnTJ TJ Tech Forum 5 10-01-2007 05:30 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:13 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC