Sirius reception problems - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-17-2009, 11:58 AM   #1
Jeeper
 
Join Date: Oct 2008
Posts: 26
BadAndy is on a distinguished road
Sirius reception problems

A few days ago I started having problems with my Sirius reception in my 07 X. Have had it for over a year with no issues at all.

The factory radio now defaults to FM when I turn it on and when I hit the "sat" button it switches to sirius breifly, with no sound, and then flips back to FM after 15-30 seconds.

Is this a reception issue (i.e. antenna problem) or is it something with the tuner itself. Nothing has happened to the jeep so I don;t know how the antenna would have gotten damaged in any way but I am going to take a look at it today anyway.

Also, where exactly is the Sirius antenna mounted? I know it's on the roll bar on the driver's side I think. Anyone having similar issues?
BadAndy is offline   Quote
Old 07-17-2009, 01:28 PM   #2
The Bad Guy

WF Supporting Member
 
daggo66's Avatar
 
Join Date: May 2009
Location: NJ exile living in Baltimore
Posts: 23,105
daggo66 is on a distinguished road
Quote:
Originally Posted by BadAndy View Post
A few days ago I started having problems with my Sirius reception in my 07 X. Have had it for over a year with no issues at all.

The factory radio now defaults to FM when I turn it on and when I hit the "sat" button it switches to sirius breifly, with no sound, and then flips back to FM after 15-30 seconds.

Is this a reception issue (i.e. antenna problem) or is it something with the tuner itself. Nothing has happened to the jeep so I don;t know how the antenna would have gotten damaged in any way but I am going to take a look at it today anyway.

Also, where exactly is the Sirius antenna mounted? I know it's on the roll bar on the driver's side I think. Anyone having similar issues?
Have you checked on the status of your account?

__________________
Tom

"I've got two things in this world, my balls and my word and I don't break them for no one."
daggo66 is offline   Quote
Old 07-17-2009, 04:32 PM   #3
Jeeper
 
Badfish's Avatar
 
Join Date: Sep 2008
Location: the oc
Posts: 366
Badfish is on a distinguished road
that would be my geuss too its free for the first year then you have to call in and set up an account and pay for it.
__________________
2008 Wrangler X. K and N drop in filter and BFG Mud Terrains.
Badfish is offline   Quote
Old 07-17-2009, 05:00 PM   #4
Jeeper

WF Supporting Member
 
N39-W120's Avatar
 
Join Date: Feb 2009
Location: South Eastern VA
Posts: 2,020
N39-W120 is on a distinguished road
Send a message via AIM to N39-W120 Send a message via Skype™ to N39-W120
What they said
__________________
Daily Driver 2010 Ford Fusion
Weekend Toy: 2008 Rubicon...
Expensive Toy: 1983 Cadillac Coupe DeVille

It's not the size of the dog in the fight, but the size of the fight in the dog!
N39-W120 is offline   Quote
Old 07-18-2009, 10:13 AM   #5
Jeeper
 
Join Date: Oct 2008
Posts: 26
BadAndy is on a distinguished road
Yeah the account is fine, took care of that right after I bought the jeep. I can't even get on the radio to hear the "free" preview channel which all sat radios default to if there is no account set up.
BadAndy is offline   Quote
Old 07-18-2009, 02:54 PM   #6
Jeeper
 
Badfish's Avatar
 
Join Date: Sep 2008
Location: the oc
Posts: 366
Badfish is on a distinguished road
if you have an account call them they are your best bet at this point or maby the dealership. sounds like a hardware problem to me but i dont know for sure
__________________
2008 Wrangler X. K and N drop in filter and BFG Mud Terrains.
Badfish is offline   Quote
Old 07-18-2009, 05:52 PM   #7
Jeeper
 
Join Date: Oct 2008
Posts: 26
BadAndy is on a distinguished road
Found the problem, was an antenna issue as I thought.

Don't know how it happened but the factory connector was broken, nothing a little electrical tape couldn't fix.
BadAndy is offline   Quote
Old 07-18-2009, 08:13 PM   #8
Jeeper

WF Supporting Member
 
N39-W120's Avatar
 
Join Date: Feb 2009
Location: South Eastern VA
Posts: 2,020
N39-W120 is on a distinguished road
Send a message via AIM to N39-W120 Send a message via Skype™ to N39-W120
Quote:
Originally Posted by BadAndy View Post
Found the problem, was an antenna issue as I thought.

Don't know how it happened but the factory connector was broken, nothing a little electrical tape couldn't fix.
Electrical tape? We only use duct tape here....
__________________
Daily Driver 2010 Ford Fusion
Weekend Toy: 2008 Rubicon...
Expensive Toy: 1983 Cadillac Coupe DeVille

It's not the size of the dog in the fight, but the size of the fight in the dog!
N39-W120 is offline   Quote
Old 11-18-2009, 09:33 PM   #9
Newb
 
Join Date: Nov 2009
Posts: 1
mbharrington is on a distinguished road
did you find where the antenna goes?

mbharrington is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to fix all vacume problems and how to locate the problems. Captaincoop1220 YJ Tech Forum 50 02-23-2013 01:19 PM
Fuel injector cleaner caused major problems. NEED HELP!! dwilliams59 YJ Tech Forum 2 03-14-2008 11:52 PM
Radio Problems Walkeraviator Communications and Electronics 17 07-27-2007 06:40 PM



Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 06:49 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC
« Back

Enter your email address:

Delivered by FeedBurner