Snapped my e-brake. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-08-2011, 03:08 AM   #1
Jeeper
 
HowardJ's Avatar
 
Join Date: Oct 2010
Location: Attica, IN
Posts: 100
Snapped my e-brake.

Lovely.

Parked the Jeep, pulled the e-brake up and POP. no tension. whatsoever.
I've spent the last 3 hours trying to figure out the problem (took the driver seat out, console out, e-brake mechanism apart.. can't figure it out. I do see a broken metal er.. thingamabob? right under the lever

I googled it and saw quite a few jeepers who have had this problem - most said it is the coil but I'm not so sure.
Haven't looked underneath for loose brake cables yet.. will do that in the day light.

Anybody else have this problem?

HowardJ is offline   Quote Quick Reply
Old 10-08-2011, 09:59 AM   #2
Jeeper
 
tjt94's Avatar
 
Join Date: Aug 2011
Location: El Centro, CA
Posts: 438
The console will come out without taking out the driver's seat. Those seat bolts are a real pain huh? The console isn't much better but with the e-brake broken it would be much easier.

Replace your broken thingamabob and you should be good to go.

tjt94 is offline   Quote Quick Reply
Old 10-08-2011, 05:40 PM   #3
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 34,289
Quote:
Originally Posted by HowardJ
Lovely.

Parked the Jeep, pulled the e-brake up and POP. no tension. whatsoever.
I've spent the last 3 hours trying to figure out the problem (took the driver seat out, console out, e-brake mechanism apart.. can't figure it out. I do see a broken metal er.. thingamabob? right under the lever

I googled it and saw quite a few jeepers who have had this problem - most said it is the coil but I'm not so sure.
Haven't looked underneath for loose brake cables yet.. will do that in the day light.

Anybody else have this problem?
I had/have the same problem. It would "pop" and not hold the jeep. I was still under warranty and brought it in.

I was told the PO probably did not use the
ebrake so it need adjusting ??
Whatever they did it seemed to work.

Now-- every once in a while it will still make that popping sound, I have to pull up pretty hard for it to work. I have a manual so just keep it in gear.

Researched it briefly and seems the ebrake is somewhat complicated in this thing, also-- others have had issues too.
__________________
2007 Rubicon/Rock Krawler triple rate 2.5" coils/RK rear TB w/ a teraflex raised bracket/Rancho 9000 31/32XL shocks/Synergy flipped draglink,ball joints,tie rod /Hankook MT 315-75-16 on Level 8 ZX's/Rancho geo brackets/Ruff stuff uppers/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings/Rancho cat back exhaust.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is online now   Quote Quick Reply
Old 10-08-2011, 06:16 PM   #4
Jeeper
 
aelwero's Avatar
 
Join Date: Jul 2010
Location: Fort Bliss TX
Posts: 1,670
Images: 1
Quote:
Originally Posted by kjeeper10 View Post
I have to pull up pretty hard for it to work.
thats probably not a lever issue, that's probably a 4 wheel disc brake issue... disc brakes don't work mechanically, so they put a tiny little set of brakes shoes inside the small center section of the disc rotor. I've had 4 vehicles with this type of E-brake (and if you call the company, they will be very adamant that it is a parking brake, not an emergency brake, and was never meant to stop a vehicle in motion in an emergency...) and if you hit it while in motion, or if you leave it on and drive a block or two, the shoes pretty much get destroyed.

I'd recommend not using the thing unless it's a situation where you really need it, because using it all the time runs the risk of driving across the parking lot with it on that one time, and that's all it takes for it to start losing effectiveness
__________________
'71 DJ-5 (that isn't a typo)
'10 JKU Sport RHD

RHD... it's a jeep thing
aelwero is offline   Quote Quick Reply
Old 10-08-2011, 06:41 PM   #5
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 34,289
Quote:
Originally Posted by aelwero

thats probably not a lever issue, that's probably a 4 wheel disc brake issue... disc brakes don't work mechanically, so they put a tiny little set of brakes shoes inside the small center section of the disc rotor. I've had 4 vehicles with this type of E-brake (and if you call the company, they will be very adamant that it is a parking brake, not an emergency brake, and was never meant to stop a vehicle in motion in an emergency...) and if you hit it while in motion, or if you leave it on and drive a block or two, the shoes pretty much get destroyed.

I'd recommend not using the thing unless it's a situation where you really need it, because using it all the time runs the risk of driving across the parking lot with it on that one time, and that's all it takes for it to start losing effectiveness
Already done it

Thanks.

Now that I think about it, who actually uses it as an "emergency" brake?

Some call it an e-brake and some a parking brake. Assuming they are the same.

I call it a e-brake but use it only for parking
__________________
2007 Rubicon/Rock Krawler triple rate 2.5" coils/RK rear TB w/ a teraflex raised bracket/Rancho 9000 31/32XL shocks/Synergy flipped draglink,ball joints,tie rod /Hankook MT 315-75-16 on Level 8 ZX's/Rancho geo brackets/Ruff stuff uppers/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings/Rancho cat back exhaust.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is online now   Quote Quick Reply
Old 10-08-2011, 06:50 PM   #6
The wicked fat man!!!

WF Supporting Member
 
HillbillyJeeper's Avatar
 
Join Date: Jun 2011
Location: Nun yo gyatdamn biniz!
Posts: 1,043
My 07 did the same thing. Aint even tried to fix it yet. I might do that tomorrow.
__________________
OUTHOUSE OFFROAD CLUB!!! We Do Shit!!


That was Purdy as hell right there!!!!

Uh.... dad... Uncle Jessie is crazy! Sooo cool though!
HillbillyJeeper is offline   Quote Quick Reply
Old 10-08-2011, 06:57 PM   #7
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 34,289
Quote:
Originally Posted by HillbillyJeeper
My 07 did the same thing. Aint even tried to fix it yet. I might do that tomorrow.
Here is my receipt thingy.

Clean and adjust rear break shoes ??
Attached Thumbnails
Click image for larger version

Name:	image-2367156860.jpg
Views:	38
Size:	87.5 KB
ID:	71420  
__________________
2007 Rubicon/Rock Krawler triple rate 2.5" coils/RK rear TB w/ a teraflex raised bracket/Rancho 9000 31/32XL shocks/Synergy flipped draglink,ball joints,tie rod /Hankook MT 315-75-16 on Level 8 ZX's/Rancho geo brackets/Ruff stuff uppers/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings/Rancho cat back exhaust.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is online now   Quote Quick Reply
Old 10-08-2011, 08:45 PM   #8
Jeeper
 
HowardJ's Avatar
 
Join Date: Oct 2010
Location: Attica, IN
Posts: 100
I broke a metal piece that attaches to the lever. Have to order/get a new one through my Jeep stealership Monday. -.-
I've been told it a little over $40 and I can do it myself.
So right now I'm driving without an e-brake or a center console.
I also broke my shift boot so now the rubber is just flopping everywhere when I shift. -.-

kjeeper- I call it e-brake.. but I only use it for parking too.
HowardJ is offline   Quote Quick Reply
Old 10-09-2011, 08:16 PM   #9
Newb
 
Oil Eater JK's Avatar
 
Join Date: Oct 2011
Location: Orangeville Ontario
Posts: 6
Images: 2
I had the same problem and fixed it myself with out removing the console completely. It was a pain in the butt doing it that way. It didn't take too long and I got it done. I ordered the replacement handle/coil part and swapped it. NOTE!!! remember to hook up the brake sensor cable! In my case the DVD wouldn't work because the brake never registered as on. May not be an issue if you don't have My Gyg. Anyways, since then I've had the brake adjusted twice and it's back to the same uselessness as it was before I snapped the first one. Apparently this is a common issue. Sucks for hooking up the trailer on a hill!
Oil Eater JK is offline   Quote Quick Reply
Old 10-11-2011, 03:03 AM   #10
Jeeper
 
Join Date: Sep 2011
Location: Orlando
Posts: 82
Quote:
Originally Posted by kjeeper10 View Post
Here is my receipt thingy.

Clean and adjust rear break shoes ??
My guess is they picked up a few more bucks of warranty work that way.

When my auto transmission shredded itself in my Trailblazer SS it was supposed to be a three day job max and that included getting the parts they needed.

On the third day I called and asked if it was ready. The tech told me 'no', that they accidentally broke the o2 sensor in half while working on the tranny and, of course, none were in stock so it would be the next day.

Next day pick up the truck. Under customer complaints on the work order there was listed "Truck will not go forward while in gear" and also, "Customer complains that truck runs rough". I told them about the truck not being able to move but I didn't say anything about a rough running engine.

Of course "Truck will not go forward while in gear" was the kaput tranny that they had to rebuild under warranty but the "Customer complains that truck runs rough" was ALSO covered under warranty as a "bad O2 sensor". The one that they snapped in half while working on the tranny.
Yozho is offline   Quote Quick Reply
Old 10-11-2011, 05:51 AM   #11
MallCrawler

WF Supporting Member
::WF Moderator::
 
kjeeper10's Avatar
 
Join Date: Feb 2011
Location: Connecticut
Posts: 34,289
Quote:
Originally Posted by Yozho
My guess is they picked up a few more bucks of warranty work that way.

When my auto transmission shredded itself in my Trailblazer SS it was supposed to be a three day job max and that included getting the parts they needed.

On the third day I called and asked if it was ready. The tech told me 'no', that they accidentally broke the o2 sensor in half while working on the tranny and, of course, none were in stock so it would be the next day.

Next day pick up the truck. Under customer complaints on the work order there was listed "Truck will not go forward while in gear" and also, "Customer complains that truck runs rough". I told them about the truck not being able to move but I didn't say anything about a rough running engine.

Of course "Truck will not go forward while in gear" was the kaput tranny that they had to rebuild under warranty but the "Customer complains that truck runs rough" was ALSO covered under warranty as a "bad O2 sensor". The one that they snapped in half while working on the tranny.
Nice
__________________
2007 Rubicon/Rock Krawler triple rate 2.5" coils/RK rear TB w/ a teraflex raised bracket/Rancho 9000 31/32XL shocks/Synergy flipped draglink,ball joints,tie rod /Hankook MT 315-75-16 on Level 8 ZX's/Rancho geo brackets/Ruff stuff uppers/Fox ATS stabilizer/Adams front DS/Artec front armor w/ Currie upper bushings/Rancho cat back exhaust.

Lifting your JK? Read this!!



Click HERE to become a WranglerForum Supporting Member!
kjeeper10 is online now   Quote Quick Reply
Old 10-11-2011, 08:33 AM   #12
Jeeper
 
JeeperJake's Avatar
 
Join Date: Jul 2010
Posts: 2,804
"e-brake"="virtual reality brake" as opposed to 'real emergency brake'.....the stop-and-hold designs of olden times.

Don't understand why they do it this way now....can't be just the disc pad design.

__________________
get in--buckle up--hang on
"soothing agricultural implement/personal servant/Walter Mitty multidimensional access utility device conveniently travels on pavement when necessary and often keeps me warm/cool/dry/soothed as needed."
JeeperJake is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake line fitting failure Alaska TJ TJ General Discussion Forum 3 10-03-2011 10:42 PM
Brake Lights Not Working InvertChaos TJ General Discussion Forum 3 08-28-2011 06:15 PM
first time on the beach 08fun JK General Discussion Forum 33 08-03-2011 11:06 AM
Drum to Disc Brake Conversion for Dana 35 or Chrysler 8.25 AOR Vendor Spotlight! Great Deals for Members. 1 06-27-2011 08:49 AM
Ford 8.8 Brake Lines Question burton160w TJ General Discussion Forum 4 05-16-2011 10:17 AM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 02:43 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC