Speaker Static - Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today



Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-09-2012, 08:41 PM   #1
Jeeper
 
Join Date: Jun 2012
Location: Toronto
Posts: 39
psywash is on a distinguished road
Speaker Static

Hey Everyone,

I'm getting weird static coming from my speakers. This only happens when I use the auxiliary or CD, radio is fine. It usually triggers if I increase the volume over half or so. It's also more noticeable when the song is a little more bass heavy.

I've tried adjusting the bass and it doesn't help. It seems to be coming from the right side, but when I play with the balance adjustment, left/right, it stops being static. This only happens when I have it centred (L/R). Playing around with Back/Front doesn't seem to make a difference.

I've brought it into the dealer and they replaced the Passenger side speaker. Then when I drove it off the lot, it started again.

Its a 2012 JKUR. Is this happening to anyone else?

Thanks
P.
psywash is offline   Quote
Old 09-09-2012, 10:09 PM   #2
Jeeper
 
wrh3's Avatar
 
Join Date: Jul 2012
Location: Loganville, GA
Posts: 391
wrh3 is on a distinguished road
It happens in ours as well, not constantly but sporadically.

__________________
Bill - 2012 Rubicon (Hers), 2013 Rubicon 10A (SOLD), 2002 Wrangler Sport (Sons)

billswebspace.com
wrh3 is offline   Quote
Old 09-25-2012, 08:27 PM   #3
Jeeper
 
Join Date: Jun 2012
Location: Toronto
Posts: 39
psywash is on a distinguished road
Still happening.

Anyone know if it has something to do with the Ground or power coming in?
I'm taking it in for service in a few more clicks, and wanted to get it sorted out. I'm just not sure the dealer knows what it is based on my last visit.
psywash is offline   Quote
Old 09-25-2012, 08:29 PM   #4
Jeeper
 
thinkxingu's Avatar
 
Join Date: Jul 2012
Location: NH
Posts: 1,035
thinkxingu is on a distinguished road
Happens in my '10 as well. Sounds scratchy, like moving a busted cable around.

S
__________________
"I have a great ambition to die of exhaustion rather than boredom."
thinkxingu is offline   Quote
Old 09-25-2012, 10:28 PM   #5
Jeeper
 
Metonymy's Avatar
 
Join Date: May 2012
Posts: 511
Metonymy is on a distinguished road
And none of you have taken it to a dealership to get them to check it out?

Ya'll are nuts!
Metonymy is offline   Quote
Old 09-26-2012, 04:06 AM   #6
Jeeper
 
thinkxingu's Avatar
 
Join Date: Jul 2012
Location: NH
Posts: 1,035
thinkxingu is on a distinguished road
I haven't because I've only had the Jeep for three months and have only noticed it two or three times- I know it'd be a diagnostic PITA.

S
__________________
"I have a great ambition to die of exhaustion rather than boredom."
thinkxingu is offline   Quote
Old 09-26-2012, 08:53 AM   #7
Jeeper
 
Join Date: Jun 2012
Location: Toronto
Posts: 39
psywash is on a distinguished road
Quote:
Originally Posted by Metonymy View Post
And none of you have taken it to a dealership to get them to check it out?

Ya'll are nuts!
I did take mine in.
They said it was the speaker, so they replaced it.

It's still happening.
I'm taking it in again next week, but I doubt they know how to diagnose the problem properly.
psywash is offline   Quote
Old 09-26-2012, 08:59 AM   #8
Jeeper
 
johnpmcelroy's Avatar
 
Join Date: Jun 2012
Location: Bellingham, Washington
Posts: 670
johnpmcelroy is on a distinguished road
Sounds like the whole radio CD player needs to be changed
johnpmcelroy is offline   Quote
Old 09-26-2012, 09:03 AM   #9
Jeeper
 
johnpmcelroy's Avatar
 
Join Date: Jun 2012
Location: Bellingham, Washington
Posts: 670
johnpmcelroy is on a distinguished road
Do you know the difference between static and something might be loose by the speaker. And what speaker setup do you have. 4.1, 5.1 or 6.1. Do you have the tweeters on the dash. What. How bout some more clues.
johnpmcelroy is offline   Quote
Old 09-26-2012, 09:17 AM   #10
Jeeper
 
johnpmcelroy's Avatar
 
Join Date: Jun 2012
Location: Bellingham, Washington
Posts: 670
johnpmcelroy is on a distinguished road
If you can get access to the speaker wires, run some wiring from left to right and right to left and see if the problem moves left. That would mean your Radio/CD player is bad if it did move left. If not, start looking for loose wiring on the Radio and to the speakers.
johnpmcelroy is offline   Quote
Old 09-26-2012, 09:19 AM   #11
Jeeper
 
Binx's Avatar
 
Join Date: Aug 2012
Location: western mass
Posts: 535
Binx is on a distinguished road
Sounds like the head unit is bad. Popping, muffled sound would be blown speaker, tweeter would sound high pitched and crackley. If your plugging in to aux with a 3.5mm cable or Usb from a source its probably the cable moving or bad cable. Move the cable around with that source selected and see if you get the same sound. Does it stop when its all the way to one side, L or R?
Binx is offline   Quote
Old 09-26-2012, 09:24 AM   #12
Jeeper
 
johnpmcelroy's Avatar
 
Join Date: Jun 2012
Location: Bellingham, Washington
Posts: 670
johnpmcelroy is on a distinguished road
And do a load test on the charging system, alternators will slowly die with no advanced notice. Also, with the car running, turn everything on, lights, wipers, radio, everything, turn radio on half way, and observe your head lights and see if they are pulsating or flashing. And another question, are you at idle or driving when you hear the static. And what are the RPM's
johnpmcelroy is offline   Quote
Old 09-26-2012, 09:26 AM   #13
Jeeper
 
johnpmcelroy's Avatar
 
Join Date: Jun 2012
Location: Bellingham, Washington
Posts: 670
johnpmcelroy is on a distinguished road
Quote:
Originally Posted by Binx View Post
Sounds like the head unit is bad. Popping, muffled sound would be blown speaker, tweeter would sound high pitched and crackley. If your plugging in to aux with a 3.5mm cable or Usb from a source its probably the cable moving or bad cable. Move the cable around with that source selected and see if you get the same sound. Does it stop when its all the way to one side, L or R?
Good Pointer.
johnpmcelroy is offline   Quote
Old 02-11-2013, 02:22 PM   #14
Jeeper
 
Join Date: Jun 2012
Location: Toronto
Posts: 39
psywash is on a distinguished road
Quote:
Originally Posted by johnpmcelroy View Post
Do you know the difference between static and something might be loose by the speaker. And what speaker setup do you have. 4.1, 5.1 or 6.1. Do you have the tweeters on the dash. What. How bout some more clues.
Hey,

It is consistent static, on songs with Base and when it is at 60%+ volume.
I believe I have 6.1 (2 by the front, 2 tweeters, 2 on the roof, and a sub). It does it with everything: AUX, CD, and Radio. I've replaced the speaker already, and I've replaced the entire Radio.

The dealer tried to blame my 'style' of music. Really!!!??

I want to take to an Audio shop, and flip the bill to Chrylser. We all know they won't pay for it.

Any thoughts? I'll try the Left/Right test later tonight.

Thanks!
psywash is offline   Quote
Old 02-12-2013, 02:27 PM   #15
Jeeper
 
Join Date: Jun 2012
Location: Toronto
Posts: 39
psywash is on a distinguished road
Quote:
Originally Posted by Binx View Post
Sounds like the head unit is bad. Popping, muffled sound would be blown speaker, tweeter would sound high pitched and crackley. If your plugging in to aux with a 3.5mm cable or Usb from a source its probably the cable moving or bad cable. Move the cable around with that source selected and see if you get the same sound. Does it stop when its all the way to one side, L or R?
Hey Binx,

I just tried the L and R test. When it's all the way on one side, either Right or Left and full blast, there is NO STATIC. It only happens when I have it centered.

What's the deal?

I want to call out the dealership, so they can fix my system.

Thanks!
psywash is offline   Quote
Old 02-14-2013, 01:53 PM   #16
Jeeper
 
Join Date: Jun 2012
Location: Toronto
Posts: 39
psywash is on a distinguished road
Any audio/speaker experts out there?
psywash is offline   Quote
Old 04-23-2016, 01:17 AM   #17
Newb
 
Join Date: Jan 2015
Location: Jacksonville, FL
Posts: 13
Nellaekim is on a distinguished road
This is happening on my 2000 TJ . I think it's a ground. Just have to find it. Not worth 120 hr for some yahoo to mis diagnosis the issue. Disconnect and clean all grounds. Come on now. Work it.. Dealers suck!

Nellaekim is offline   Quote
Reply

Tags
audio , radio , speaker , static

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 04:34 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC