SPOD Problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-15-2013, 10:42 AM   #1
Race Car Dave

WF Supporting Member
 
NFRs2000NYC's Avatar
 
Join Date: Nov 2011
Location: NYC
Posts: 6,639
SPOD Problem

Hey guys, I have a weird issue with my SPOD unit. For some reason, after my Moab trip, something happened, and now switch #2 and switch #4 activate each other. If I turn on switch #2 (roof lightbar) it turns on the lightbar but it also turns on switch #4 (front locker). Now I don't yet have a front locker, so its just the switch thats turning on, but the reverse is true as well. If I turn on switch #4 (front locker), it will also turn on switch #2 and my lightbar will turn on. I have emailed the guys at SPOD but never heard back from them. Anyone have any idea what can be going on? Is there something wrong with the board itself? Any help would be greatly appreciated as I am at a loss.

NFRs2000NYC is offline   Quote Quick Reply
Old 06-15-2013, 10:50 AM   #2
Jeeper
 
mountainneer's Avatar
 
Join Date: Nov 2012
Location: Valencia, CA
Posts: 445
I think the sPod crew was going to the Big Bear Forest Fest out here in California this weekend. The shop is probably closed. I would try to call them on Monday morning. They are usually very helpful...

mountainneer is offline   Quote Quick Reply
Old 06-15-2013, 10:52 AM   #3
Jeeper
 
gregaf3's Avatar
 
Join Date: Apr 2011
Posts: 200
Sounds like the two circuits are shorted together.
gregaf3 is offline   Quote Quick Reply
Old 06-15-2013, 11:17 AM   #4
Race Car Dave

WF Supporting Member
 
NFRs2000NYC's Avatar
 
Join Date: Nov 2011
Location: NYC
Posts: 6,639
Quote:
Originally Posted by gregaf3 View Post
Sounds like the two circuits are shorted together.
Thats what I figured as well, but I can't tell where the problem is.
NFRs2000NYC is offline   Quote Quick Reply
Old 06-15-2013, 11:18 AM   #5
Race Car Dave

WF Supporting Member
 
NFRs2000NYC's Avatar
 
Join Date: Nov 2011
Location: NYC
Posts: 6,639
Quote:
Originally Posted by mountainneer View Post
I think the sPod crew was going to the Big Bear Forest Fest out here in California this weekend. The shop is probably closed. I would try to call them on Monday morning. They are usually very helpful...
I emailed them over 3 weeks ago.
NFRs2000NYC is offline   Quote Quick Reply
Old 06-15-2013, 06:18 PM   #6
Jeeper
 
mountainneer's Avatar
 
Join Date: Nov 2012
Location: Valencia, CA
Posts: 445
Quote:
Originally Posted by NFRs2000NYC View Post
I emailed them over 3 weeks ago.
Thats not good...I would call them directly Monday morning.
mountainneer is offline   Quote Quick Reply
Old 06-15-2013, 07:22 PM   #7
Race Car Dave

WF Supporting Member
 
NFRs2000NYC's Avatar
 
Join Date: Nov 2011
Location: NYC
Posts: 6,639
Well, I emailed again, and he got back to me instantly. The first 3 calls were dropped because he is at Big Bear wheelin, but he found some high ground and we talked for a while. Im going to take the switch panel apart on Monday and see if there are any problems over there, and go from there. Bar none, awesome customer service. I guess my original email got lost in the haystack.
NFRs2000NYC is offline   Quote Quick Reply
Old 06-15-2013, 09:05 PM   #8
Jeeper
 
mountainneer's Avatar
 
Join Date: Nov 2012
Location: Valencia, CA
Posts: 445
That's good. Glad they got back to ya....Big Bear Forest Fest is a huge event.
mountainneer is offline   Quote Quick Reply
Old 06-15-2013, 10:44 PM   #9
Jeeper
 
mountainneer's Avatar
 
Join Date: Nov 2012
Location: Valencia, CA
Posts: 445
I was supposed to be wheeling at the Big Bear Forest Fest also, but I had some other commitments come up..Glad things worked out with sPod..
mountainneer is offline   Quote Quick Reply
Old 06-15-2013, 10:45 PM   #10
Race Car Dave

WF Supporting Member
 
NFRs2000NYC's Avatar
 
Join Date: Nov 2011
Location: NYC
Posts: 6,639
Quote:
Originally Posted by mountainneer View Post
I was supposed to be wheeling at the Big Bear Forest Fest also, but I had some other commitments come up..Glad things worked out with sPod..
Yup, gonna get to the bottom of it ASAP. Really a great product.
NFRs2000NYC is offline   Quote Quick Reply
Old 06-15-2013, 11:10 PM   #11
Jeeper
 
Join Date: Sep 2011
Posts: 314
Keep us posted, no issues with my SPOD yet...love the dang thing to death haha. Hope it works out for you
__________________
2012 JKU Rubicon
Silver | 4.10 Gears | Hard Top | Connectivity | Remote Start

-Faulty driver side head replaced at 23,000 miles
-New AB head possibly faulty and being replaced at 29,000 miles
Rubicon_Jim is offline   Quote Quick Reply
Old 06-15-2013, 11:21 PM   #12
Jeeper
 
TrueBlueJK's Avatar
 
Join Date: Oct 2012
Location: New York
Posts: 523
Even though I only have one switched hooked up on mine it works great so far, good luck I'm sure it'll be an easy fix!

TrueBlueJK is online now   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:50 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC