Sway Bar Link Grease Leak? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-05-2013, 12:41 PM   #1
Jeeper
 
Hack12's Avatar
 
Join Date: Apr 2012
Location: Rhode Island
Posts: 353
Images: 19
Sway Bar Link Grease Leak?

Just checked out my sway bar links and found about a marble sized ball of grease on the bottom connection of each. I've checked them many times before and never noticed this excess grease buildup. I haven't disconnected or wheeled them recently. Just wondering what the deal is and how it would happen to both sides at the same time??

Hack12 is offline   Quote
Old 04-05-2013, 01:30 PM   #2
Jeeper
 
Hack12's Avatar
 
Join Date: Apr 2012
Location: Rhode Island
Posts: 353
Images: 19
Here are a couple shots after I wiped the grease off.
#1 is where the buildup collected.
#2 seems to be where it may be originating from.

Attachment 232013
Attachment 232015

Hack12 is offline   Quote
Old 04-05-2013, 03:48 PM   #3
Jeeper
 
Hack12's Avatar
 
Join Date: Apr 2012
Location: Rhode Island
Posts: 353
Images: 19
Anyone have any insight for me?
Hack12 is offline   Quote
Old 04-05-2013, 04:07 PM   #4
Jeeper
 
JerryJeepster's Avatar
 
Join Date: Sep 2012
Location: Lakewood Ranch
Posts: 1,394
My RK links and the factory links don't have grease fittings.
JerryJeepster is offline   Quote
Old 04-05-2013, 04:11 PM   #5
Supporting Member

WF Supporting Member
 
cmaggi2's Avatar
 
Join Date: Oct 2012
Location: Prairieville, LA
Posts: 1,503
Quote:
Originally Posted by Hack12 View Post
Just checked out my sway bar links and found about a marble sized ball of grease on the bottom connection of each. I've checked them many times before and never noticed this excess grease buildup. I haven't disconnected or wheeled them recently. Just wondering what the deal is and how it would happen to both sides at the same time??
I always have grease (not marble-sized) coming from my TF sway bar links. I didn't know this was an issue since factory links don't even have grease zerks.
cmaggi2 is offline   Quote
Old 04-05-2013, 04:19 PM   #6
Jeeper
 
Hack12's Avatar
 
Join Date: Apr 2012
Location: Rhode Island
Posts: 353
Images: 19
Quote:
Originally Posted by cmaggi2 View Post

I always have grease (not marble-sized) coming from my TF sway bar links. I didn't know this was an issue since factory links don't even have grease zerks.
Yeah, this is the first time I've seen it on my TF links. I've had them for over a year.
Hack12 is offline   Quote
Old 04-05-2013, 06:11 PM   #7
Supporting Member

WF Supporting Member
 
cmaggi2's Avatar
 
Join Date: Oct 2012
Location: Prairieville, LA
Posts: 1,503
I thought I just greased them too much. I don't really know how much to put in. I figured too much is better than not enough.

cmaggi2 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:50 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC