Teraflex Leveling kit done + Rubi Springs/Shocks - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-30-2011, 03:08 PM   #1
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Teraflex Leveling kit done + Rubi Springs/Shocks

Installed all this on the weekend. Love the way the Jeep looks now.

Was fairly easy to install, took roughly 5 hours total time. Was not in a rush as this was first time doing this. Damn mosquitos did not help either..lol.

Only issue I have now is the front drivers side sway bar link is touching the coil.
I have read that a few ppl have had this issue as well. I triple checked everything and all looks good, so I have no idea.

Might have to get a mechanic to look at this.

Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 03:12 PM   #2
ESP
Jeeper
 
ESP's Avatar
 
Join Date: Jun 2010
Location: NC
Posts: 11,512
pics?

ESP is offline   Quote Quick Reply
Old 05-30-2011, 03:29 PM   #3
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Pics of before and after Teraflex Leveling kit, with Rubicon Shocks/Springs added.
Attached Thumbnails
Click image for larger version

Name:	Stock 2011 Sport.jpg
Views:	269
Size:	227.8 KB
ID:	51593   Click image for larger version

Name:	Teraflex lvl kit plus rubi springshocks.jpg
Views:	269
Size:	229.4 KB
ID:	51594  

Click image for larger version

Name:	Stock 2011 Sport rear.jpg
Views:	253
Size:	224.9 KB
ID:	51595   Click image for larger version

Name:	Teraflex lvl kit plus rubi springs shocks rear.jpg
Views:	275
Size:	228.2 KB
ID:	51596  

Click image for larger version

Name:	Driver sway link rub.jpg
Views:	312
Size:	224.2 KB
ID:	51597  
Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 03:45 PM   #4
Jeeper
 
repoman100's Avatar
 
Join Date: May 2010
Location: Montreal, Canada
Posts: 526
What size duratracs are those ?
__________________
JK- Fun ride, always, all the time.
repoman100 is offline   Quote Quick Reply
Old 05-30-2011, 03:51 PM   #5
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Quote:
Originally Posted by repoman100 View Post
What size duratracs are those ?
265/70/17....which I think are 32's.
Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 03:55 PM   #6
Jeeper
 
repoman100's Avatar
 
Join Date: May 2010
Location: Montreal, Canada
Posts: 526
I have the same setup (TF leveling kit and rubi shocks and coils) with 33s KM2s, was thinking of getting 33s duratracs next winter to replace my 265/70/17 winter tires that I have now. I tought the 32s would look small with the lift but it doesn't look so bad in your pics !
__________________
JK- Fun ride, always, all the time.
repoman100 is offline   Quote Quick Reply
Old 05-30-2011, 04:00 PM   #7
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Yah, not too bad. Will eventually get bigger tires but this will do for now.

Did you have any rubbing with the sway bar links on the drivers side..as seen in my pics?
Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 04:05 PM   #8
Jeeper
 
repoman100's Avatar
 
Join Date: May 2010
Location: Montreal, Canada
Posts: 526
for the link touching your coil, I find that weird as I did not have this issue, are you sure you installed it the right side, I know some people have installed it in reverse to prevent rubbing on the tire
__________________
JK- Fun ride, always, all the time.
repoman100 is offline   Quote Quick Reply
Old 05-30-2011, 04:29 PM   #9
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
So you think to try reversing the springs in the front? They both looked the same.
Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 04:30 PM   #10
Jeeper
 
repoman100's Avatar
 
Join Date: May 2010
Location: Montreal, Canada
Posts: 526
not the springs ! the sway bar links
__________________
JK- Fun ride, always, all the time.
repoman100 is offline   Quote Quick Reply
Old 05-30-2011, 04:45 PM   #11
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Yah I looked at that...the sway bar itself is close to the spring.

Actually, the spring looks bowed to the front of the vehicle..you can see it in the picture a few post back...hmmm.
Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 04:53 PM   #12
Jeeper
 
repoman100's Avatar
 
Join Date: May 2010
Location: Montreal, Canada
Posts: 526
Are you positive that your coils are seated properly ?
__________________
JK- Fun ride, always, all the time.
repoman100 is offline   Quote Quick Reply
Old 05-30-2011, 04:54 PM   #13
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Yep, bottoms line up with the notch.
Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 05:03 PM   #14
Jeeper
 
repoman100's Avatar
 
Join Date: May 2010
Location: Montreal, Canada
Posts: 526
I will try to get pictures of my swaybar links later
__________________
JK- Fun ride, always, all the time.
repoman100 is offline   Quote Quick Reply
Old 05-30-2011, 05:18 PM   #15
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
That would be great...thanks!
Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 05:46 PM   #16
Jeeper
 
JIMBOX's Avatar
 
Join Date: Nov 2009
Posts: 9,914
I'm just an innocent bysitter, but it looks to me like you don't have the stock "isloator" installed and thats what center's the spring around the "bumpstop" column, which looks like the spring is drifted to far forward--because of that-

Now either the Teraflex leveling kit, says to discard the "isolators" or--you've installed somrthing "UPSIDE DOWN"-

Carry on guy-

Ciao

JIMBO
__________________
"ya gotta have class"
JIMBOX is offline   Quote Quick Reply
Old 05-30-2011, 05:54 PM   #17
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Quote:
Originally Posted by JIMBOX View Post
I'm just an innocent bysitter, but it looks to me like you don't have the stock "isloator" installed and thats what center's the spring around the "bumpstop" column, which looks like the spring is drifted to far forward--because of that-

Now either the Teraflex leveling kit, says to discard the "isolators" or--you've installed somrthing "UPSIDE DOWN"-

Carry on guy-

Ciao

JIMBO
Hey Jimbox....the isolator is def there. I even made sure the 2in pucks were installed correctly.
Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 06:01 PM   #18
Jeeper
 
JIMBOX's Avatar
 
Join Date: Nov 2009
Posts: 9,914
OK, then try to explain the "situation" of the sway bar/coil spring/shock picture !!


Quote:
Originally Posted by Gilly93 View Post
Hey Jimbox....the isolator is def there. I even made sure the 2in pucks were installed correctly.
Is the wheel off are you Hijacked/ jackstand on frame--WHAT ??

JIMBO
__________________
"ya gotta have class"
JIMBOX is offline   Quote Quick Reply
Old 05-30-2011, 06:07 PM   #19
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Quote:
Originally Posted by JIMBOX View Post
OK, then try to explain the "situation" of the sway bar/coil spring/shock picture !!




Is the wheel off are you Hijacked/ jackstand on frame--WHAT ??

JIMBO
Pic was taken with full load on wheels. Did everything as per instructions from Teraflex regarding installation. Only thing I added was new springs and shocks into the mix off a Rubicon.
Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 06:18 PM   #20
MTH
Jeeper
 
MTH's Avatar
 
Join Date: Oct 2010
Location: North Carolina
Posts: 8,553
Sway bar link too short?
__________________
Mike
2010 JKU "Mountain" Edition
TeraFlex 2.5" Coil Lift : Old Man Emu Nitrocharger Shocks : 33x12.5R15 Goodyear DuraTracs : 15x8 Black Rock 909s : Other Stuff . . .
MTH is offline   Quote Quick Reply
Old 05-30-2011, 06:19 PM   #21
Jeeper
 
JIMBOX's Avatar
 
Join Date: Nov 2009
Posts: 9,914
Allright, the appearance is-


Quote:
Originally Posted by Gilly93 View Post
Pic was taken with full load on wheels. Did everything as per instructions from Teraflex regarding installation. Only thing I added was new springs and shocks into the mix off a Rubicon.
The swaybar is at too much "down angle" and the coil spring is bowed, by either shocks mounted are too short, or shock extensions are mounted wrong or LCAs are to short (impossible) or, I don't know what, but the coils should be perfectly STRAIGHT UP AND DOWN---UNDER NORMAL LOAD !!

The sway bar should be as close to LEVEL as you can getit, sometimes takes extended links/w lift !!

If you don't have an adjustable trackbar-that shouldn't affect the coils "foreaft"-

JIMBO
__________________
"ya gotta have class"
JIMBOX is offline   Quote Quick Reply
Old 05-30-2011, 06:26 PM   #22
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Quote:
Originally Posted by JIMBOX View Post
Allright, the appearance is-




The swaybar is at too much "down angle" and the coil spring is bowed, by either shocks mounted are too short, or shock extensions are mounted wrong or LCAs are to short (impossible) or, I don't know what, but the coils should be perfectly STRAIGHT UP AND DOWN---UNDER NORMAL LOAD !!

The sway bar should be as close to LEVEL as you can getit, sometimes takes extended links/w lift !!

If you don't have an adjustable trackbar-that shouldn't affect the coils "foreaft"-

JIMBO
Is it possible that the front axle may have shifted? Or my control arms are binded up? Ah dunno.

The passenger side coil is perfect..straight up and down. 1" clearance between coil and sway link. To me...I think something (axle) shifted.

Thanks for your help Jimbo.
Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 06:39 PM   #23
Jeeper
 
JIMBOX's Avatar
 
Join Date: Nov 2009
Posts: 9,914
Damn, 1" is perfect, thats what my '08 Rubi clearance is on the front springs-


Quote:
Originally Posted by Gilly93 View Post
Is it possible that the front axle may have shifted? Or my control arms are binded up? Ah dunno.

The passenger side coil is perfect..straight up and down. 1" clearance between coil and sway link. To me...I think something (axle) shifted.

Thanks for your help Jimbo.
I don't see how you could have a bent LCA, unless it was just damaged, but you'd know that !!

Check the top assy of the good coil and then look at the "bent" one and see if something may have "Shifted"--

Give you jeep a beer-ah hell, you have a beer-ah hell I'll have a beer--

JIMBO
__________________
"ya gotta have class"
JIMBOX is offline   Quote Quick Reply
Old 05-30-2011, 08:38 PM   #24
Jeeper
 
repoman100's Avatar
 
Join Date: May 2010
Location: Montreal, Canada
Posts: 526
Here is what mine looks like, your coil bows too much ...
Attached Thumbnails
Click image for larger version

Name:	image-1922315553.jpg
Views:	113
Size:	78.0 KB
ID:	51652  
__________________
JK- Fun ride, always, all the time.
repoman100 is offline   Quote Quick Reply
Old 05-30-2011, 08:55 PM   #25
Jeeper
 
Join Date: May 2011
Location: Middle Georgia
Posts: 82
I dont think the spring is seated properly.

Raise it back up, lossen everything, make sure the spring is seated, then tighten it just enough to hold it in place and lower it back down. Torque everything to spec once all 4 wheels are on the ground.

What number springs did you remove and what number Rubi springs did you install?

Looks good, Ive got a set of 18/59s sitting in the garage with all 4 Rubi shocks as well.
BMCGC is offline   Quote Quick Reply
Old 05-30-2011, 10:11 PM   #26
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Quote:
Originally Posted by BMCGC View Post
I dont think the spring is seated properly.

Raise it back up, lossen everything, make sure the spring is seated, then tighten it just enough to hold it in place and lower it back down. Torque everything to spec once all 4 wheels are on the ground.

What number springs did you remove and what number Rubi springs did you install?

Looks good, Ive got a set of 18/59s sitting in the garage with all 4 Rubi shocks as well.
I had 14/55 springs and upgraded to 17/58's, rubicon shocks as well.
The drive is definitely different.
Gilly93 is offline   Quote Quick Reply
Old 05-30-2011, 10:12 PM   #27
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Quote:
Originally Posted by repoman100 View Post
Here is what mine looks like, your coil bows too much ...
Is that not the passenger side? Can you take a pic of the drivers side?

Cheers.
Gilly93 is offline   Quote Quick Reply
Old 05-31-2011, 09:56 AM   #28
Jeeper
 
repoman100's Avatar
 
Join Date: May 2010
Location: Montreal, Canada
Posts: 526
Quote:
Originally Posted by Gilly93 View Post
Is that not the passenger side? Can you take a pic of the drivers side?

Cheers.

Have you figured this out ?

I'll take one later if you still need to see.
__________________
JK- Fun ride, always, all the time.
repoman100 is offline   Quote Quick Reply
Old 05-31-2011, 10:00 AM   #29
Jeeper
 
Gilly93's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Ontario, Canada
Posts: 92
Nope...no idea. Bringing it to a mechanic tomorrow. Really weird man.
Gilly93 is offline   Quote Quick Reply
Old 05-31-2011, 10:24 AM   #30
Jeeper
 
Clutch127's Avatar
 
Join Date: Sep 2010
Location: Raleigh, NC
Posts: 427
How much did all the parts cost?

__________________
Keep on rockin in the Jeep world!
Clutch127 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
lj teraflex tt non rubi jrussblues WF New Member Check In 4 04-13-2011 10:41 PM
Just ordered Teraflex leveling kit... 33s? repoman100 JK General Discussion Forum 17 02-15-2011 09:40 PM
Teraflex leveling kit dcrna JK General Discussion Forum 10 12-20-2010 05:33 PM
CA: Teraflex 1" Leveling kit (2007-2010) plac Classifieds Archive 5 05-02-2010 10:45 PM
Stock Rubi springs/shocks on Tj? KellyK TJ General Discussion Forum 3 10-27-2008 11:00 AM



Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:07 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC