Ticking and Power Loss - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-30-2013, 03:21 PM   #1
Jeeper
 
Join Date: Mar 2012
Posts: 30
Ticking and Power Loss

Took the Jeep in because of the ticking sound and a perceived loss of power. They called back late in the day and verified that 2 of the valves on the drivers side had collapsed and would need to be replaced. They went ahead and decided to order and replace all the valves for me. They said the head on mine is OK based upon the stamped code on the head, so that did not need to be replaced. They ordered the parts out of NY and will have me fixed and back in the Jeep by late next week. In the mean time they put me in a new Grand Cherokee as a loaner (very nice rig). Although a little frustrating having to deal with a problem on a newer vehicle, I will say that the service department at my local dealer has done an outstanding job of taking care of me and my Jeep. Hopefully the mechanic working on it is as good as the service manager.
Just thought I would share my story regarding the infamous head/valve issue.
Attached Thumbnails
Click image for larger version

Name:	20130525_120445.jpg
Views:	39
Size:	223.4 KB
ID:	255614  

Crazybvb is offline   Quote Quick Reply
Old 05-30-2013, 04:04 PM   #2
Jeeper
 
Blastek's Avatar
 
Join Date: Mar 2012
Location: Portland, OR
Posts: 2,343
Weren't the Artics produced before the latest AC head was even released (mid-july 2012)? Unless you had a head replaced, you need more than just the valves to fix this issue. The valve seats in the original head are the problem.

__________________
2012 Deep Cherry Red JKU Sport S - Tickastar, 6 speed, 3.73, Dual Tops
Blastek is offline   Quote Quick Reply
Old 05-30-2013, 07:06 PM   #3
Jeeper
 
Join Date: Mar 2012
Posts: 30
Quote:
Originally Posted by Blastek View Post
Weren't the Artics produced before the latest AC head was even released (mid-july 2012)? Unless you had a head replaced, you need more than just the valves to fix this issue. The valve seats in the original head are the problem.
I don't know the answer to that question regarding the production timeliness. I was told the valves were the only issue per the dealership service dept. They did tell me the head didn't fall into the defective lot that was produced.
In your opinion what else could have caused the valves to fail if the head isn't an issue? I am not overly knowledgeable mechanically regarding vehicles, so any info would be very helpful.....Thanks!!!
Crazybvb is offline   Quote Quick Reply
Old 05-30-2013, 07:18 PM   #4
Jeeper
 
Blastek's Avatar
 
Join Date: Mar 2012
Location: Portland, OR
Posts: 2,343
Well, the dealer has to be wrong. Any 2012 model year wrangler has either an AA or AB head. The original AA head ran until mid June. I think the Arctic package was discontinued in early 2012, so I'm pretty sure you have the AA head. You can check on the inside of your driver's door. There is a tech tip from Chrysler that identifies any head built before mid-late July (can't remember the exact date) is not the latest revision. The latest revision supposedly has improved materials for the valve guides/seats and cooling that prevents the issue.

There is a chance that you had a failure on the passenger side head. This is much more rare and we don't know the build dates for revisions on that side. Given that you had ticking, I'd say it's more likely you have an issue with the driver's side head.

I haven't heard of collapsed valves? Maybe collapsed lifters? Anyway, let the dealer do its thing and see if it works out.

good luck!
__________________
2012 Deep Cherry Red JKU Sport S - Tickastar, 6 speed, 3.73, Dual Tops
Blastek is offline   Quote Quick Reply
Old 05-30-2013, 07:39 PM   #5
Jeeper
 
Join Date: Mar 2012
Posts: 30
Quote:
Originally Posted by Blastek View Post
Well, the dealer has to be wrong. Any 2012 model year wrangler has either an AA or AB head. The original AA head ran until mid June. I think the Arctic package was discontinued in early 2012, so I'm pretty sure you have the AA head. You can check on the inside of your driver's door. There is a tech tip from Chrysler that identifies any head built before mid-late July (can't remember the exact date) is not the latest revision. The latest revision supposedly has improved materials for the valve guides/seats and cooling that prevents the issue.

There is a chance that you had a failure on the passenger side head. This is much more rare and we don't know the build dates for revisions on that side. Given that you had ticking, I'd say it's more likely you have an issue with the driver's side head.

I haven't heard of collapsed valves? Maybe collapsed lifters? Anyway, let the dealer do its thing and see if it works out.

good luck!
Do you think their fix of just doing the valves is a band-aid application to just get by for awhile?
Crazybvb is offline   Quote Quick Reply
Old 05-30-2013, 10:42 PM   #6
Jeeper
 
Blastek's Avatar
 
Join Date: Mar 2012
Location: Portland, OR
Posts: 2,343
I would give them the benefit of the doubt. I don't know the circumstances, so the dealer may be doing right. You'll know immediately if their fix did not work by the ticking sound of the motor. If it's fixed, it won't tick.

Edit: It does suck that they're removing your cylinder head and not replacing it.
__________________
2012 Deep Cherry Red JKU Sport S - Tickastar, 6 speed, 3.73, Dual Tops
Blastek is offline   Quote Quick Reply
Old 06-05-2013, 02:34 PM   #7
Jeeper
 
Join Date: Mar 2012
Posts: 30
Update: They installed the new valves but heard the ticking etc. still. They called me and said since they think it is still a problem they were going to go ahead and just replace the head once and for all even though Chryslers internal memo is telling them that is not necessary.

Crazybvb is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 03:56 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC