traction control light coming on - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-26-2013, 09:58 PM   #1
Jeeper
 
Join Date: Aug 2007
Location: Surgoinsville TN
Posts: 225
traction control light coming on

I have a 2013 Wrangler unlimited Rubicon 6sp on 3 separate occasions my traction control light came on and the jeep felt like it was rear differential was locking. Anyone else have a similar experience? I can't replicate it either. It was just at random times.

blackbelt is offline   Quote Quick Reply
Old 01-26-2013, 10:02 PM   #2
Supporting Member

WF Supporting Member
 
lee indy's Avatar
 
Join Date: May 2009
Location: Middle Georgia
Posts: 5,265
Lifted?

__________________



LeeIndy's Build Thread
lee indy is offline   Quote Quick Reply
Old 01-26-2013, 10:05 PM   #3
Jeeper
 
Dusthol's Avatar
 
Join Date: Jan 2012
Location: Williston nd
Posts: 1,010
It sensed loss of traction. Mine does it on the ice if I give to much throttle
Dusthol is offline   Quote Quick Reply
Old 01-26-2013, 10:11 PM   #4
Jeeper
 
Join Date: Aug 2007
Location: Surgoinsville TN
Posts: 225
Not lifted and I was on dry pavement not going fast at all(no way i could have lost traction). It just felt like it was locked in the rear. It was only for a few seconds each time and then would let go.
blackbelt is offline   Quote Quick Reply
Old 01-26-2013, 10:14 PM   #5
Jeeper
 
COStrider's Avatar
 
Join Date: Sep 2012
Posts: 1,759
Quote:
Originally Posted by blackbelt
I have a 2013 Wrangler unlimited Rubicon 6sp on 3 separate occasions my traction control light came on and the jeep felt like it was rear differential was locking. Anyone else have a similar experience? I can't replicate it either. It was just at random times.
My 2012 did this stock from time to time. Usually it was over very bumpy areas, in patches of sand, or small wet sections of road. Sometimes the light would stay on for some time after.

Just thought I'd let you know it might be normal to a certain extent.
__________________
We do not take risks to escape life, but to keep life from escaping us.-Unknown
COStrider is offline   Quote Quick Reply
Old 01-26-2013, 10:19 PM   #6
Jeeper
 
Join Date: Aug 2007
Location: Surgoinsville TN
Posts: 225
The light coming on didnt really bother me to much. What the real issue is, is the way the rear felt like it locked up. I guess I could have hit a bump and it thought it lost traction and locked up?
blackbelt is offline   Quote Quick Reply
Old 01-27-2013, 09:41 AM   #7
Jeeper
 
bbtj's Avatar
 
Join Date: Jul 2010
Location: Kansas City, Mo
Posts: 1,527
It could also be a bad wheel sensor, which happened on my 2010. Since yours is a 2013 and, I assume, still under warranty, take it in and let the dealer sort it out.
bbtj is offline   Quote Quick Reply
Old 01-27-2013, 10:10 AM   #8
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 4,747
Images: 1
Quote:
Originally Posted by blackbelt View Post
The light coming on didnt really bother me to much. What the real issue is, is the way the rear felt like it locked up. I guess I could have hit a bump and it thought it lost traction and locked up?
This could be it. Did it occur either on the same or similar section of road? Monitor it and if continues with no real explanation bring it in. Keep in mind that the dealer will have to be able to "replicate" it which could turn into a headache itself.
kik is offline   Quote Quick Reply
Old 01-27-2013, 11:23 AM   #9
Supporting Member

WF Supporting Member
 
lee indy's Avatar
 
Join Date: May 2009
Location: Middle Georgia
Posts: 5,265
Quote:
Originally Posted by blackbelt View Post
Not lifted and I was on dry pavement not going fast at all(no way i could have lost traction). It just felt like it was locked in the rear. It was only for a few seconds each time and then would let go.
there goes my theory of steering wheel needing to be centered.
__________________



LeeIndy's Build Thread
lee indy is offline   Quote Quick Reply
Old 01-27-2013, 11:58 AM   #10
Jeeper
 
nmdriver's Avatar
 
Join Date: Aug 2009
Location: Grants, NM
Posts: 224
Mine was coming on so I replaced all 4 sensors and it did not fix it. I got it aligned and it did. It was only off a tad but apparently enough. Is your steering wheel perfefectly centered?
nmdriver is offline   Quote Quick Reply
Old 01-27-2013, 01:24 PM   #11
Jeeper
 
chrisfp88's Avatar
 
Join Date: Jun 2012
Posts: 1,309
Also were you on a section of road with a lot of pitch, i think that would be the correct term, i.e. a road that empties into a large storm gully in the middle? The locking you feel is most likely the vehicle thinking it is in a slide and sending power and brakes where needed to try and right itself. Mine always does it on a section of road like that.
chrisfp88 is offline   Quote Quick Reply
Old 04-03-2014, 11:52 AM   #12
Newb
 
Join Date: Apr 2014
Posts: 2
Very Similar Problem Very Dangerous

I'm going through the same issue with my 2013 Rubicon.
From time to time the traction control goes berserk and it feel like all of the power is transferred to the passenger side wheels resulting in the Jeep pulling hard to the left. It's almost cause 2 collisions.

As usual the dealership is like tits on a bull.

I'm starting the lemon law fight with them now.
MattCSC is offline   Quote Quick Reply
Old 04-03-2014, 12:30 PM   #13
Jeeper
 
rustynail11's Avatar
 
Join Date: Apr 2013
Location: Mansfield (DFW area), TX
Posts: 243
I have a 2013 Sport Unlimited and mine has done the same thing at random times under very normal driving conditions. I may go 2 weeks without it happening then it will happen 2 or 3 times in a very short time span. In addition now when it does it all the other warning lights on my dash light up.

Taking it to the dealer to get looked at week after next when I go out of town.
rustynail11 is offline   Quote Quick Reply
Old 04-08-2014, 08:22 AM   #14
Newb
 
Join Date: Sep 2011
Location: Outback Australia (for now)
Posts: 2
I have a 2012 and mine did that shortly after I purchased it. The dealership checked it out and found two bad sensors (can't remember which ones). They replaced them and I haven't had any issues since.
ErickM is offline   Quote Quick Reply
Old 04-09-2014, 08:45 AM   #15
Newb
 
Join Date: Apr 2014
Posts: 2
Bad Sensors

It would be a big help if you could tell me which ones.

Supposedly Chrysler engineers are putting it through tests going on a week now with no luck. I love the jeep but live in a city with lots of pedestrians. I do not want to run anyone over if this thing acts up again.
MattCSC is offline   Quote Quick Reply
Old 04-09-2014, 08:53 AM   #16
Supporting Member

WF Supporting Member
 
14Sport's Avatar
 
Join Date: Dec 2013
Posts: 851
Quote:
Originally Posted by lee indy View Post
there goes my theory of steering wheel needing to be centered.
Not really. Hitting a pothole or loose bolts can cause the steering to uncenter if something bent or moved.

OP, is your steering wheel centered?
14Sport is offline   Quote Quick Reply
Old 04-09-2014, 11:31 AM   #17
Jeeper
 
insylem's Avatar
 
Join Date: Apr 2013
Location: Enterprise, Alabama.
Posts: 992
Images: 3
Quote:
Originally Posted by blackbelt View Post
I have a 2013 Wrangler unlimited Rubicon 6sp on 3 separate occasions my traction control light came on and the jeep felt like it was rear differential was locking. Anyone else have a similar experience? I can't replicate it either. It was just at random times.
I've experenced that before when driving in 2Hi on muddy / sandy roads.
__________________
2013 Wrangler Unlimited Rubicon 10th Anniversary
insylem is offline   Quote Quick Reply
Old 05-27-2014, 05:09 PM   #18
Jeeper
 
Join Date: Jan 2013
Location: California
Posts: 135
I was coming home yesterday from the fishing/camping up in the high Sierras...suddenly the chime sounded...I was like WTF...?! Then about 10 miles (paved mountain road in Yosemite) it did it again...No lights on dashboard or nothing....I kep driving another 5 miles or so when it happened again. This time the traction control, brake and air bag lights flashed and only traction control stayed lit. In about 15 miles I stopped turned engine off and started again...drove home remaining 76 miles without a troubles...
I did not experienced any changes in driving or handling while the lights and chime did their thing...it was very weird... and my GF freaked out that we loose brakes or engine will die while on the mountain roads...

I have 2013 Sport lifted. Never had any issues before...If it does it again I will take it to dealer and have them check it out.
TheIronWolf is offline   Quote Quick Reply
Old 06-20-2014, 08:49 AM   #19
Newb
 
Join Date: Jan 2013
Location: Central La
Posts: 1
I'm having these same issues on flat concrete in Louisiana, in my 2011 Sahara. It's only when it starts, for the first two minutes or so, but when i pull onto the street it bogs down and slows to a crawl. ABS light comes on too. Naturally dealership has no open apptments until July.

Mung is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 05:18 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC