Two issues on Brand new Rubi - Page 2 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-28-2012, 05:01 AM   #31
Supporting Member

5-Year WF Supporting Member
 
danrb's Avatar
 
Join Date: Nov 2012
Location: VA
Posts: 1,164
Squeaks? I never noticed any until it was mentioned in this thread. Now I can't stop hearing them. No more piece and quiet in my ride.

Seriously, take it out on the trail, you'll either get over it or have a nervous breakdown.

__________________
2013 JKUR. Rock Krawler 3.5 X-Factor, RK Draglink flip, Nitto Trail Grappler 35x12.5x17, ACE Rock Sliders, Poison Spyder Brawler MID Front Bumper with Brawler Bar, ENGO E10000S Electric Winch, ACE Engineering JK Pro Series Rear Bumper with Tire Carrier, JW Speaker 8700, Dually Fog lights and sPOD
danrb is online now   Quote
Reply

Tags
alignment , seats

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 01:42 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC