uconnect self install harness question - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-13-2010, 07:52 PM   #1
Newb
 
Jpinetti's Avatar
 
Join Date: Oct 2010
Location: Harborcreek, Pa
Posts: 10
uconnect self install harness question

Hi all, new 2010 JK unlimited owner. I need a little help so i don't look like an idiot when i show up at the dealer tomorrow to have my uconnect setup with StarScan. I've searched everywhere and can't find any really detailed info on this install. The instructions that came with the kit are useless. So I ordered the kit for the REQ radio. I got the radio out and routed the harness and mic. I installed the uconnect unit on the backside of the removable panel under the glove box (for easy access when the ipod connector comes in). I unplugged the large factory connector from the back of the radio and hooked that into the uconnect harness. Do I abandon the factory small connector on the back of the radio and plug in the one from the uconnect harness or just not hook up the small plug off the uconnect harness? Also, am i correct in thinking the ipod adapter cable will plug into the uconnect unit?

Jpinetti is offline   Quote Quick Reply
Old 10-13-2010, 09:20 PM   #2
Jeeper
 
Join Date: Aug 2010
Posts: 16
I was going to install a uconnect and had this link saved:

http://public.mvlan.net/content/Jeep...20Uconnect.pdf

quite98 is offline   Quote Quick Reply
Old 10-13-2010, 09:51 PM   #3
Newb
 
Jpinetti's Avatar
 
Join Date: Oct 2010
Location: Harborcreek, Pa
Posts: 10
Thanks! That is by far the best representation of the install I've seen yet. It didn't mention what to do with the small connector (not bigger power/data) that was already plugged in from the factory. It did say plug all three of the uconnect harness plugs in though. I'm still confused cause nothing seems to happen with this small one unplugged. Radio still works. Is this for the subwoofer? I cranked it up and didn't notice a difference in sound. I guess I'll try just taping it off for now. I just don't want the dealer giving me a hard time cause I installed it wrong and they couldn't flash the connect module or something.
Jpinetti is offline   Quote Quick Reply
Old 10-14-2010, 06:49 AM   #4
Newb
 
Jpinetti's Avatar
 
Join Date: Oct 2010
Location: Harborcreek, Pa
Posts: 10
Also what about the DVD plug. What's that for and how do u watch DVDs. Will a monitor plug into aux jack?
Jpinetti is offline   Quote Quick Reply
Old 10-14-2010, 07:02 AM   #5
Jeeper
 
Join Date: Jul 2010
Location: South Texas
Posts: 94
There is a You Tube video that shows how to install...(mainly how to remove all of the panels to get access to the radio. The harness fits to the left of the radio in the open space when you're putting the radio into place.
STxWrangler is offline   Quote Quick Reply
Old 10-14-2010, 05:57 PM   #6
Newb
 
Jpinetti's Avatar
 
Join Date: Oct 2010
Location: Harborcreek, Pa
Posts: 10
So my ipod cable came in today. Awesome service from Mopar! Got it within 36 hours of order! Anyway, no starscan yet but somehow i expected this to work at least. No dice. Does this require the starscan too? Also, how do you access it once it's hooked up? Aux button?
Jpinetti is offline   Quote Quick Reply
Old 03-14-2011, 10:47 AM   #7
Jeeper
 
fanofnd's Avatar
 
Join Date: Mar 2011
Location: Maryland
Posts: 153
I know this is an old thread but did you ever get an answer on this? I have the same issue and can't seem to get a definitive answer.
fanofnd is offline   Quote Quick Reply
Old 03-14-2011, 01:42 PM   #8
Supporting Member

WF Supporting Member
 
RB-10rubicon's Avatar
 
Join Date: Sep 2010
Location: Princeton area in new jersey
Posts: 1,258
I have the mygig uconnect and got the ipod cable for christmas i pluged it into the back of radio ran wire to glove box and pluged it in no problems .not sure what radio you have but im thinking it has to do with aux button this is the cable i got
RB-10rubicon is offline   Quote Quick Reply
Old 03-14-2011, 01:57 PM   #9
Jeeper
 
fanofnd's Avatar
 
Join Date: Mar 2011
Location: Maryland
Posts: 153
Thanks for the help but I have a RES radio. The confusion is what to do with the nine pin connector which I believe is for the speakers. The harness is fairly self explanatory with the exception of the nine pin plug. I will try to explain as clear (as mud) as I can. When removing the radio there is a male 22 pin and a male 9 pin. The uconnect harness has a female 22, a male 22 and a male 9. The 22 pin connections are self explanatory. The problem with the 9 is that 1 of them ends up not getting used. Does the 9 from the vehicle get abandoned or does the 9 from the harness end up not being used? THANKS!
fanofnd is offline   Quote Quick Reply
Old 03-14-2011, 02:13 PM   #10
Supporting Member

WF Supporting Member
 
RB-10rubicon's Avatar
 
Join Date: Sep 2010
Location: Princeton area in new jersey
Posts: 1,258
I think that the nine pin is for the steering wheel controls for the 11's i would leave the nine pin coming from the ipod harness out .just hook it up and try it before putting dash back together hopefully it will work for you .side note try every possible connection before reinstalling
RB-10rubicon is offline   Quote Quick Reply
Old 03-14-2011, 02:21 PM   #11
Jeeper
 
fanofnd's Avatar
 
Join Date: Mar 2011
Location: Maryland
Posts: 153
Sorry, I forgot to mention it is a 2010. Haven't gone to the dealer yet to get the Uconnect phone enabled but radio, sirius and ipod cable all worked hooked both ways. I can only assume it has something to do with the bluetooth function but as previously stated I haven't been to the dealer yet. My fear is getting there to have the uconnect phone enabled and having it connected wrong.
fanofnd is offline   Quote Quick Reply
Old 03-14-2011, 03:38 PM   #12
Supporting Member

WF Supporting Member
 
RB-10rubicon's Avatar
 
Join Date: Sep 2010
Location: Princeton area in new jersey
Posts: 1,258
Ok i was looking online did you buy the mic for the uconnect that might be were the mic goes
RB-10rubicon is offline   Quote Quick Reply
Old 03-14-2011, 05:03 PM   #13
Jeeper
 
fanofnd's Avatar
 
Join Date: Mar 2011
Location: Maryland
Posts: 153
I bought and installed the complete kit. The non nav radios require a module and wiring harness to be installed unlike the nav radios.
fanofnd is offline   Quote Quick Reply
Old 03-14-2011, 05:40 PM   #14
Supporting Member

WF Supporting Member
 
RB-10rubicon's Avatar
 
Join Date: Sep 2010
Location: Princeton area in new jersey
Posts: 1,258
I wish i could be more helpful mabey someone will chime in with more knowledgment on this good luck im sure youll get it to work
RB-10rubicon is offline   Quote Quick Reply
Old 03-14-2011, 07:11 PM   #15
Jeeper
 
fanofnd's Avatar
 
Join Date: Mar 2011
Location: Maryland
Posts: 153
I appreciate your help.
fanofnd is offline   Quote Quick Reply
Old 06-23-2011, 05:56 AM   #16
Newb
 
Join Date: Jun 2011
Posts: 1
Did you ever find out anything about which connector to use
trk 28 is offline   Quote Quick Reply
Old 08-08-2011, 08:40 PM   #17
Newb
 
Join Date: Aug 2011
Posts: 1
I have finally gotten all my parts for my 2011 Avenger/Uconnect/iPod. I took stereo out of dash and I also have the little 9? pin from the car that's not being used after you follow installation instructions. I'm not sure what it's for. I plugged uconnect in (without starscan) and everything that should work, worked. Steering controls worked fine, stereo worked fine (it did not pick up my ipod or phone because it's not starscanned)
I'm not sure what that 9-pin is for. I purchased a Lockpick MyGig mic and am wondering if it will work with the uconnect.
I'm also wondering if I can get it starscanned and then install it at home because I will need to mess with it to see if Lockpick MyGig mic will work. I don't want to install everything and then find out it's not working.
How is yours working? Did you find out what 9pin is for?
BADTOLZ is offline   Quote Quick Reply
Old 08-09-2011, 09:10 AM   #18
Jeeper
 
Join Date: Apr 2011
Posts: 1,694
On the 2010 wranglers they had the Uconnect harness somewhat prewired inn the IP harness, but the module would have to go in the factory location (behind the HVAC controls) instead of under the glove box. Tape back the small connector and plug the new one from the new harness into the radio. Also I hope that you mounted the mic on the driver "A" pillar instead of on the knee bolster like the reference link that was posted. having the mic down below will give terrible results for speech commands as well as people listening to you.



Quote:
Originally Posted by Jpinetti View Post
Hi all, new 2010 JK unlimited owner. I need a little help so i don't look like an idiot when i show up at the dealer tomorrow to have my uconnect setup with StarScan. I've searched everywhere and can't find any really detailed info on this install. The instructions that came with the kit are useless. So I ordered the kit for the REQ radio. I got the radio out and routed the harness and mic. I installed the uconnect unit on the backside of the removable panel under the glove box (for easy access when the ipod connector comes in). I unplugged the large factory connector from the back of the radio and hooked that into the uconnect harness. Do I abandon the factory small connector on the back of the radio and plug in the one from the uconnect harness or just not hook up the small plug off the uconnect harness? Also, am i correct in thinking the ipod adapter cable will plug into the uconnect unit?

xsdbs is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
5.7L PCM to YJ wiring harness, need help. cowboy724 YJ Tech Forum 10 04-20-2011 02:21 PM
12/92 Wrangler Dash Harness HELP tytrophen YJ General Discussion Forum 1 03-23-2010 12:35 PM
'98 harness on a '97? kdukes4 TJ Tech Forum 0 12-15-2009 11:17 PM
*help s.o.s* install question??????? jeepmiller09 JK Tech Forum 12 05-08-2009 05:25 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 10:50 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC