Water pump squeal - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-26-2013, 08:27 AM   #1
Jeeper
 
Join Date: Dec 2012
Posts: 30
Water pump squeal

Yesterday my 2013 JKU started to squeal. First, it would only happen for a few seconds every 10 seconds. Within a few minutes it would not stop. I looked at the belts and noted that it was coming from low on the motor. Took it to the dealership this morning.

I was told that there is a service bulletin on the water pump for just this issue. They have ordered a replacement, but it could be weeks on backorder. Sounds to me like they are planning for a lot of replacements.

In the meantime I was told that there is no issue with failure.

Dingus is offline   Quote Quick Reply
Old 03-26-2013, 10:47 AM   #2
Jeeper
 
cobraj59's Avatar
 
Join Date: Mar 2013
Location: West of Boston
Posts: 64
Thanks Dingus, how many miles on your jku. Did they give a hint on what percentage will have this problem or should we all be listening for the squeal!

cobraj59 is offline   Quote Quick Reply
Old 03-26-2013, 11:33 AM   #3
Jeeper
 
Join Date: Dec 2012
Posts: 30
I have only 5900. When I took it in, the service coordinator immediately acknowledged a known issue with the squealing water pump. He said the new pumps are on backorder and that he has no ETA for its arrival. Sounds like it is a recent issue that they have yet to receive the upgraded water pumps to resolve. I could not find a posted TSB.
Dingus is offline   Quote Quick Reply
Old 03-26-2013, 11:59 AM   #4
Jeeper
 
Join Date: Jan 2010
Location: Las Cruces, NM
Posts: 2,291
Lets just hope is doesn't start squirting water or the engine overheating while you wait.....
__________________
2013 WRANGLER SPORT 2 DR., V-6 ,AUTO,HARD TOP
(Sold)1994 Jeep Wrangler 2.5L, Bestop top
/w steel half door and slider windows
5 speed, 2.5" lift, 31" tires,rack lights
Garyk is offline   Quote Quick Reply
Old 03-26-2013, 12:06 PM   #5
Jeeper
 
Join Date: Dec 2012
Posts: 30
At least I am on record at the dealership
Dingus is offline   Quote Quick Reply
Old 03-26-2013, 03:54 PM   #6
Jeeper
 
Ponderosa's Avatar
 
Join Date: Jan 2013
Location: Arizona Desert
Posts: 177
My squeeked from day one. I have a little over 1000 miles now. Haven't taken it to the dealer because I know they can't fix it.
__________________
2013 Deep Cherry Red JKU Sahara
Ponderosa is offline   Quote Quick Reply
Old 03-26-2013, 05:18 PM   #7
Jeeper
 
Join Date: Dec 2012
Posts: 30
Ponderosa, I didn't even ask about the pump replacement. The Service Tech brought it to my attention. You may want to ask.
Dingus is offline   Quote Quick Reply
Old 03-27-2013, 12:18 AM   #8
Jeeper
 
Tweak's Avatar
 
Join Date: Jan 2013
Location: Keller, TX
Posts: 2,395
Quote:
Originally Posted by Ponderosa View Post
My squeeked from day one. I have a little over 1000 miles now. Haven't taken it to the dealer because I know they can't fix it.
mine started around 2000, it comes and goes. I keep a good eye on my temp gauge though!
Tweak is offline   Quote Quick Reply
Old 03-27-2013, 12:30 AM   #9
Jeeper
 
Join Date: Jan 2013
Posts: 30
My 2013 has an intermittent squeek aswell that the dealer says is the water pump. I am also on the list waiting for a replacment at 1589 miles...
Jvarricchio4 is offline   Quote Quick Reply
Old 03-27-2013, 06:52 AM   #10
Jeeper
 
Join Date: Dec 2012
Posts: 30
How long have you been waiting? I was told it could be weeks.
Dingus is offline   Quote Quick Reply
Old 03-27-2013, 10:45 AM   #11
Jeeper
 
Join Date: Jan 2013
Posts: 30
Ive been waiting two weeks now. I also has an issue with my clutch that they said they would do at the same time, but if I knew it was going to take this long I just would have had them do it in the begining. I might stop in their today and ask about it.
Jvarricchio4 is offline   Quote Quick Reply
Old 03-27-2013, 02:26 PM   #12
Jeeper
 
Join Date: Dec 2012
Posts: 30
I was told to cool my heals for the pump. Sounds like they are expecting weeks of backlog. Also, I was told there is an update for UConnect for the Iphone5. I need to get that done too.
Dingus is offline   Quote Quick Reply
Old 03-27-2013, 04:47 PM   #13
Jeeper
 
Join Date: Jan 2013
Posts: 30
I just got the call today that my pump is in. I set up an appointment for Tuesday to drop it off. I hope they dont have it long, as the tranny has to come out.
Jvarricchio4 is offline   Quote Quick Reply
Old 04-20-2013, 12:19 PM   #14
Jeeper
 
Join Date: Sep 2012
Location: Payson,AZ
Posts: 240
Why does the tranny have to come out?

HRR1 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Featured Product

All times are GMT -5. The time now is 10:19 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC