Windshield Threads gone. How do i fix? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-30-2013, 11:33 PM   #1
Jeeper
 
Idriveoverstuff's Avatar
 
Join Date: Feb 2013
Posts: 288
Windshield Threads gone. How do i fix?

The threads that the windshield brackets bolt to are trashed. It's a 09 JKRU. What do I do? I can't mount rack, light bar, anything. I'm stumped and can't find info. It's a daily driver so I don't want to take it apart until I have a plan.
Help!

Idriveoverstuff is offline   Quote
Old 03-31-2013, 01:19 AM   #2
Jeeper
 
traitor08's Avatar
 
Join Date: Aug 2012
Posts: 483
Drill and retap. No problem.

__________________
13 JK Dozer - 6sp and 3.73's. Riding on 35" Nitto Trail Grapplers, 17" MB V-Drive wheels. 2.5" Rock Krawler max travel lift and Fox Racing shocks.

Proud member of NRA
Life supporter of 2nd Amendment
Blame the person not the tool
traitor08 is offline   Quote
Old 03-31-2013, 08:24 PM   #3
Jeeper
 
Idriveoverstuff's Avatar
 
Join Date: Feb 2013
Posts: 288
That sounds easier. I was told to take a little hole saw and open the inside up and go from there. You happen to have an web sites or videos for referene
Idriveoverstuff is offline   Quote
Old 03-31-2013, 09:20 PM   #4
Jeeper
 
AZikas86's Avatar
 
Join Date: Mar 2013
Posts: 139
I installed my led light bar bracket under my corner windshield light mounts, and when i started tightening i grabbed a few threads then it popped, I ended up going to a fastenal and getting a longer bolt to grab more threads and tightened it, and it worked.
AZikas86 is offline   Quote
Old 04-01-2013, 04:11 AM   #5
Jeeper
 
Idriveoverstuff's Avatar
 
Join Date: Feb 2013
Posts: 288
Quote:
Originally Posted by AZikas86
I installed my led light bar bracket under my corner windshield light mounts, and when i started tightening i grabbed a few threads then it popped, I ended up going to a fastenal and getting a longer bolt to grab more threads and tightened it, and it worked.
I did that too. Still not working.
Idriveoverstuff is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 11:53 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC