06 TJ shifter issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-15-2013, 08:16 PM   #1
Jeeper
 
slayer74's Avatar
 
Join Date: Sep 2012
Location: 1 mile from the middle of nowhere, North Carolina
Posts: 79
06 TJ shifter issue

Me and the kids were messing around out in the woods with the top down and hit a pretty good size bump. (Ok, a good sized tree that had fallen down and I didn't see it in the brush. .)
Now the shifter (6 speed manual) has kind of canted over to the left side. I can shift the Jeep and it runs but it sure doesn't feel right. I'm worried about breaking something if I drive it like this. 1st and 2nd move the whole lower console when I shift into those gears.
Anyone got any thoughts on this one?

slayer74 is offline   Quote Quick Reply
Old 04-15-2013, 10:11 PM   #2
Jeeper
 
Join Date: Jun 2012
Posts: 41
The first thing I'd check is the transmission mount between the transmission and the skid plate. That's the only thing I know of that will affect the postion of the shift lever.

dmoriarty is offline   Quote Quick Reply
Old 04-15-2013, 11:09 PM   #3
Jeeper
 
idiot magnet's Avatar
 
Join Date: Oct 2009
Location: Noblesville, IN
Posts: 547
Could be a broken motor mount as well. Your 4 wheel drive linkage could be messed up and pushed your shifter over. you could have part of the tree stuck under there.
Check everything you can underneath it.
idiot magnet is offline   Quote Quick Reply
Old 04-16-2013, 08:56 AM   #4
Jeeper
 
slayer74's Avatar
 
Join Date: Sep 2012
Location: 1 mile from the middle of nowhere, North Carolina
Posts: 79
Thanks for the input guys. I don't think its the linkage since I can put it in 4WL and 4WH. I'll take a look at the transmission mount again and let y'all know how it goes.
slayer74 is offline   Quote Quick Reply
Old 04-16-2013, 09:10 AM   #5
Jeeper
 
idiot magnet's Avatar
 
Join Date: Oct 2009
Location: Noblesville, IN
Posts: 547
Check your skid plate to see if it's bent. I bent mine so badly that it knocked my linkage for my 4wd shifter off and turned the transmission slightly. We had to remove it and beat the crap out of it to get it straight again. Yes they bend.
idiot magnet is offline   Quote Quick Reply
Old 04-16-2013, 09:23 AM   #6
Jeeper
 
slayer74's Avatar
 
Join Date: Sep 2012
Location: 1 mile from the middle of nowhere, North Carolina
Posts: 79
I'd sure like to know just how you did that! Sounds like you may drive as fearlessly as I do.
The skid plate isn't bent on mine. But, there is a good possibility something is crammed up in between the skid plate and the transmission housing.
slayer74 is offline   Quote Quick Reply
Old 04-16-2013, 10:58 AM   #7
Jeeper
 
idiot magnet's Avatar
 
Join Date: Oct 2009
Location: Noblesville, IN
Posts: 547
Slamming down on rocks with a stock skid is not advisable. Had to crawl under it to shift it since the linkage came unhooked. No one in our group brought a sledge hammer so we had to use logs intended for the camp fire to beat it back straight. They did that while I was under the Jeep fixing all of the messed up linkage. The new flat skid is in production and I hope to have it on soon.
idiot magnet is offline   Quote Quick Reply
Old 04-16-2013, 10:23 PM   #8
Jeeper
 
slayer74's Avatar
 
Join Date: Sep 2012
Location: 1 mile from the middle of nowhere, North Carolina
Posts: 79
I know it may sound stupid but that sounds fun. In looking everything over a little closer today, it is the transmission mount. Fixing it Thursday night.
slayer74 is offline   Quote Quick Reply
Old 04-16-2013, 10:34 PM   #9
Jeeper
 
idiot magnet's Avatar
 
Join Date: Oct 2009
Location: Noblesville, IN
Posts: 547
I hope it goes smoothly and it's a pretty easy fix. It's helpful to have a friend when installing the skid plate along with a good floor jack.
idiot magnet is offline   Quote Quick Reply
Old 04-16-2013, 10:51 PM   #10
Jeeper
 
slayer74's Avatar
 
Join Date: Sep 2012
Location: 1 mile from the middle of nowhere, North Carolina
Posts: 79
Got both of those things lined up. Looks pretty straight forward compared to other things we've worked on so I think it'll go pretty smooth. I'll let you know though.
slayer74 is offline   Quote Quick Reply
Old 04-18-2013, 07:32 PM   #11
Jeeper
 
slayer74's Avatar
 
Join Date: Sep 2012
Location: 1 mile from the middle of nowhere, North Carolina
Posts: 79
Guess its bad on me that I was guessing transmission mount before I looked over everything. Turns out it is a broken engine bracket. Sheared the bolts right off too. Wow is this gonna suck.
slayer74 is offline   Quote Quick Reply
Old 04-18-2013, 09:23 PM   #12
Jeeper
 
idiot magnet's Avatar
 
Join Date: Oct 2009
Location: Noblesville, IN
Posts: 547
Hopefully you have part of the bolt sticking out or it's not going to be easy getting a drill in there to get those out. Passenger side I hope which is easier to get at.
Good luck.
This has me thinking to buy some aftermarket engine mounts.
idiot magnet is offline   Quote Quick Reply
Old 04-18-2013, 09:38 PM   #13
Jeeper
 
slayer74's Avatar
 
Join Date: Sep 2012
Location: 1 mile from the middle of nowhere, North Carolina
Posts: 79
Thanks. But, Its the driver side. Looks like the bolts didn't shear off clean. So I'll back them out well enough. Still gonna suck lol
slayer74 is offline   Quote Quick Reply
Old 04-28-2013, 11:48 AM   #14
Jeeper
 
slayer74's Avatar
 
Join Date: Sep 2012
Location: 1 mile from the middle of nowhere, North Carolina
Posts: 79
Well, to wrap up this issue, as it turns out it had to have been the motor mount failing that caused the engine bracket to snap those bolts. Last week we replaced the transmission mount, driver side motor mount, engine bracket bolts. The shifter is back where it belongs and that problem appears to be solved aside from one bolt we could not get out of the block. Shifts a little smoother too but that could all be in my head.

Next step on this is to buy the Brown Dog engine brackets and motor mounts and never worry with this particular problem again.

One new development though, and this wasn't around before the break, I have a major vibration at 35 - 45 MPH that doesn't happen more than 20% of the time. Bad though. Gonna look at the track bar bushing and ball joints next.

Again, thanks for all the advice guys. It did help me out a lot.

slayer74 is offline   Quote Quick Reply
Reply

Tags
shifter

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:25 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC