1997, 4 cyl, couple questions - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-22-2011, 02:21 PM   #1
Jeeper
 
Join Date: Nov 2010
Posts: 18
1997, 4 cyl, couple questions

Had an o2 sensor code, replaced the sensor above the cat, code came back after 30 miles. Also noticed about 65 MPH that the temp gauge ran high by my standards (about 210) and the oil pressure was, if I recall, somewhere between 55-60 (high?). Doing a bit of searching on the site, finding some useful information here and there, any thoughts about any or all of these things? Thanks in advance

biohzd is offline   Quote Quick Reply
Old 11-22-2011, 05:16 PM   #2
Jeeper
 
Join Date: Aug 2011
Posts: 21
Your temp and oil psi are consistent to what my 2.5 does and from what I remember seeing in a couple you tube videos too.

As for the O2 sensor I heard the ones from the chain parts stores are not high quality and/or not highly compatible for jeeps. I got my last sensor outta a totaled jeep so that's not from my own experience, rather just word of mouth.

Hope that helps.

czkarl is offline   Quote Quick Reply
Old 11-23-2011, 06:41 AM   #3
Jeeper
 
arcountryboy's Avatar
 
Join Date: Apr 2011
Location: England, AR
Posts: 849
Temp and oil are just fine, might have a faulty O2 censor. Chain parts stores are not know for the quality of their parts.
__________________
Arkansas Crawlers
BlueRibbon Coalition


arcountryboy is offline   Quote Quick Reply
Old 11-23-2011, 09:10 AM   #4
Jeeper
 
Gkbassn4's Avatar
 
Join Date: Aug 2011
Location: Louisiana
Posts: 182
Same thing just happened to me in my 97' SE 4 banger. Changed the o2 sensor and about 30-40 miles the same code came back. It didnt read as an o2 problem as it did previously (even though it was the same code) but came back as: "loose fuel cap, evap canister, loose connection, and something with the fuel. I called a local shop and they said basically my jeep is just polluting the air and/or getting bad fuel economy. So, i dont know what to do ha
Gkbassn4 is offline   Quote Quick Reply
Old 11-23-2011, 09:40 AM   #5
Jeeper
 
Join Date: Nov 2010
Posts: 18
I'm surprised that the temp is ok, seemed high by what I know but it is what it is..... The o2 sensor was an ngk guy, oem or so I was told. May have to think about replacing it again after I take a look for some exhaust leaks perhaps.
biohzd is offline   Quote Quick Reply
Old 11-23-2011, 09:57 AM   #6
Jeeper
 
arcountryboy's Avatar
 
Join Date: Apr 2011
Location: England, AR
Posts: 849
Quote:
Originally Posted by biohzd View Post
I'm surprised that the temp is ok, seemed high by what I know but it is what it is..... The o2 sensor was an ngk guy, oem or so I was told. May have to think about replacing it again after I take a look for some exhaust leaks perhaps.

Jeeps run around 210*, give or take a few degree's. It worries a lot of people that are coming from something that normally runs 180* or so.
__________________
Arkansas Crawlers
BlueRibbon Coalition


arcountryboy is offline   Quote Quick Reply
Old 11-23-2011, 01:59 PM   #7
Jeeper
 
Join Date: Nov 2010
Posts: 18
Quote:
Originally Posted by arcountryboy View Post
Jeeps run around 210*, give or take a few degree's. It worries a lot of people that are coming from something that normally runs 180* or so.


Yep. That's me! ;-)

biohzd is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
YJ - Couple of questions about my hard top. clerks37 YJ Tech Forum 4 11-06-2010 07:15 AM
Couple of TJ questions InvertChaos TJ General Discussion Forum 22 10-15-2010 11:04 AM
Couple "add on" parts questions... Owen_TJ TJ General Discussion Forum 4 09-16-2010 12:42 PM
Couple questions about new JK :) Jamamp General Jeep Discussion 3 07-04-2010 09:08 AM
New Jeep, A couple of questions... tysalem JK General Discussion Forum 11 03-12-2010 09:20 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 05:21 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC