2.5L running ruff - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-08-2011, 01:51 PM   #1
Newb
 
Join Date: May 2011
Posts: 3
2.5L running ruff

hello all, I'm new to this forum and could sure use some help. problems on a 97 wrangler 2.5L.

I've replaced the o2 sensors, put in pulstar spark plugs (problems existed before the plug install and after), has fairly new plug wires, new dist cap and rotor, cleaned throttle body, and installed 4 new injectors. Also added a spectre aftermarket air filter to gain a little air flow.

150k miles on it.

it's giving a front o2 sensor code again, rough idle, (when idle and in gear it will drop in oil pressure until the "check gauges" light comes on). but the main issue is the rough idle. since the o2s sensor is new i'm thinking something else is causing it to glaze over and give bad readings. engine may also have a little exhaust manifold leak since i've noticed one of the exh manifold bolts is missing in the front. Car is hard to start, it always starts, just takes a little more cranking than it should, even if you turn the key and let it sit before engaging starter.

little black smoke at start up only. has an exhaust smell too. When I say rough idle, I mean it is running rough at idle, but it's also not right at higher rpms either. poor fueleconomy too.

where should I look now?

roomservice is offline   Quote Quick Reply
Old 05-08-2011, 04:33 PM   #2
Jeeper
 
Zip69_1999's Avatar
 
Join Date: Feb 2011
Location: Ocala, Fl
Posts: 55
Where did you purchase the O2 sensors? I've heard advance and discount aren't the best choices, kinda hit or miss!

__________________
1997 TJ SE
4 cyl
5 speed
Zip69_1999 is offline   Quote Quick Reply
Old 05-08-2011, 04:34 PM   #3
Jeeper
 
Zip69_1999's Avatar
 
Join Date: Feb 2011
Location: Ocala, Fl
Posts: 55
You might also consider doing a leak down test to see if your rings or valve seals are toast!
__________________
1997 TJ SE
4 cyl
5 speed
Zip69_1999 is offline   Quote Quick Reply
Old 05-08-2011, 04:57 PM   #4
Newb
 
Join Date: May 2011
Posts: 3
replaced the ox sensor before the cat again today just to see if this one was bad, ruined, or what ever. did not make a diff so I guess that means the ox sensor is not the prob.

zip, i may have bad valve(s), there is a ticking noise. So maybe a head job is in order.
roomservice is offline   Quote Quick Reply
Old 05-08-2011, 05:09 PM   #5
Jeeper
 
Zip69_1999's Avatar
 
Join Date: Feb 2011
Location: Ocala, Fl
Posts: 55
The ticking you hear may be from a leaking exhaust manifold! Easiest thing first to do : read the plugs, in the back of a Chilton manual you will see pics to read your plugs! Go from there!
__________________
1997 TJ SE
4 cyl
5 speed
Zip69_1999 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough running TJ - Electric or Fuel issue?? 666 TJ General Discussion Forum 4 07-01-2012 11:00 AM
2.5l with coolant coming out of spark plug holes Help.. Gkansa TJ General Discussion Forum 3 05-05-2011 08:32 AM
Getting every pony from 2.5L & 4.0L quicksand97 TJ General Discussion Forum 6 09-13-2010 09:03 AM
RBNM's Running Adventures RatherBNarizona Off-Topic 8 09-24-2009 01:25 PM
'94 YJ 2.5L Running Like Poo... Tony YJ Tech Forum 4 10-22-2008 12:13 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 09:24 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC