2002 tj wrangler A/C driving me crazy - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-06-2012, 05:25 PM   #1
Newb
 
Join Date: May 2012
Location: Florida
Posts: 6
2002 tj wrangler A/C driving me crazy

I have a 2002 TJ 4.0L L6. A local mechanic didn't have time to work on it the other day but he says the system is fully charged, the compressor just wouldn't kick on. When its been sitting and cooler out, it cuts on fine, blows cold. Once I get going, hot air again.

I already know I have a blend door problem, it always starts blowing from the defrost vents, then shifts to the regular vents. My question is, would this be the cause of the compressor not kicking on?

Thanks

shredd1981 is offline   Quote
Old 07-06-2012, 05:30 PM   #2
Jeeper
 
Join Date: Dec 2011
Location: Under my Jeep in beautiful upstate N.Y.
Posts: 3,264
The doors are seperate from the compressor.Id start with diag the compressor.Its really a simple system.

1jeeplvr is offline   Quote
Old 07-06-2012, 05:33 PM   #3
Jeeper
 
Notoriously_rob's Avatar
 
Join Date: Jun 2012
Posts: 686
Clogged vaccum line?
Notoriously_rob is offline   Quote
Old 07-06-2012, 05:40 PM   #4
Jeeper
 
Join Date: Dec 2011
Location: Under my Jeep in beautiful upstate N.Y.
Posts: 3,264
Add he is positive its full? I believe its 1.25lbs
1jeeplvr is offline   Quote
Old 07-06-2012, 05:43 PM   #5
Jeeper
 
desertrat04's Avatar
 
Join Date: Feb 2012
Posts: 70
I have a 2004 and my blend door went out on me. I have the motorized blend door and took it off and inspected it. I found out that I had a blown resistor. Stealership wanted $130 and I had the resistor replaced for a six pack of diet coke.
desertrat04 is offline   Quote
Old 07-06-2012, 06:59 PM   #6
Newb
 
Join Date: May 2012
Location: Florida
Posts: 6
Ha, nice. Thanks guys. Yeah I replaced the resistor already cuz I was having problems with the fan speeds, but now it just blows outta the defrost vents before switching. It could be a clogged line but I notice a lot of condensation on the accumulator dryer once the compressor stops working. Is this normal?
shredd1981 is offline   Quote
Old 07-06-2012, 07:02 PM   #7
Jeeper
 
Notoriously_rob's Avatar
 
Join Date: Jun 2012
Posts: 686
Switch unit?
Notoriously_rob is offline   Quote
Old 07-07-2012, 05:51 PM   #8
Newb
 
Join Date: May 2012
Location: Florida
Posts: 6
switch unit? I don't see any problems with the vacuum hoses. All I know is my A/C will only work for a little while at night or if it is cloudy. When it's hot outside (and it IS, I live in South Florida!) it will not work.
shredd1981 is offline   Quote
Old 07-07-2012, 05:53 PM   #9
Jeeper
 
Notoriously_rob's Avatar
 
Join Date: Jun 2012
Posts: 686
Ur switch unit (rurns everything on and off) could be going bad- i had to replace mine last week
Notoriously_rob is offline   Quote
Old 07-07-2012, 06:00 PM   #10
Newb
 
Join Date: May 2012
Location: Florida
Posts: 6
The actual in dash unit with the controls? Could be...I'll look into it. Thank you!
shredd1981 is offline   Quote
Old 07-08-2012, 05:15 AM   #11
Jeeper
 
Notoriously_rob's Avatar
 
Join Date: Jun 2012
Posts: 686
Yup- i found mine had been fried and actually melted to the wiring harness- changed it and now my a/c blows colder and fast like a dirty pirate hooker

Notoriously_rob is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Download our Mobile App

» Featured Product

All times are GMT -5. The time now is 09:28 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC