2003, 2.4 , rough running - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-25-2012, 10:39 AM   #1
Jeeper
 
Chris65GMC's Avatar
 
Join Date: Mar 2011
Location: Philadelphia
Posts: 103
2003, 2.4 , rough running

My jeep has had a small popping sound out of the exhaust when i cold start it, it also has a 'now and then' stumble /surge around 1500-3000rpm, the stumble is big enough where i can hear the engine rattle on a few occasions.

Any ideas? I'm thinking it could be as simple as bad gas, or we've been having weird weather in the NE, maybe the weather is tricking the cpu to lean out because it's 50 degrees, then it's running to lean the next morning when its 25 degrees? This started overnight, and has not been going on long.

Thanks for all help!
Chris

Chris65GMC is offline   Quote Quick Reply
Old 01-25-2012, 06:12 PM   #2
Jeeper
 
Join Date: Mar 2011
Posts: 241
I also have a 2.4L it's an 06
I first try and run the blue sta-bil through a full fresh tank. It breaks down the ethanol. Then I would get a can of mass air flow sensor cleaner. Remove your throttle body. And spray it all down and wipe all the crap out. Try those and also defiantly change your spark plugs while the throttle body is off. I recommend just basic champion plugs. And a new air filter wouldn't hurt either. Try those and let me know how that works!!

56cj5 is offline   Quote Quick Reply
Old 01-25-2012, 10:17 PM   #3
4 Little Squirrels

WF Supporting Member
 
ellman605's Avatar
 
Join Date: Oct 2010
Location: Lewisville, TX
Posts: 718
Potentially O2, I had a similar issue and O2s fixed it.
__________________
Elliott
'99 TJ Sport: 4.0L 12X,XXX Miles, 32RH Auto, 3.5" Suspension, 1.25"BL, SYE, D35 4.10 D30 Aussie Locked.

2013 CB500X: The toy
ellman605 is offline   Quote Quick Reply
Old 01-26-2012, 08:30 AM   #4
Jeeper
 
Chris65GMC's Avatar
 
Join Date: Mar 2011
Location: Philadelphia
Posts: 103
Quote:
Originally Posted by ellman605 View Post
Potentially O2, I had a similar issue and O2s fixed it.
Thanks for the info, I'll look into a few of these.

The ECU is not throwing any codes, and it only has 58K on it, but the 02 is worth considering.
Chris65GMC is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
98 Jeep Wrangler Running Rough shedrick YJ General Discussion Forum 7 07-20-2011 09:07 PM
Anybody running Rough Country's Wheel spacers? GEM1N1 JK General Discussion Forum 2 04-11-2010 10:12 PM
Rough running & horn sticking valkmc10 TJ Tech Forum 0 02-14-2010 07:12 PM
Blown Coils, Fuses and Running Rough, now Fixed sgblakley TJ General Discussion Forum 5 05-04-2009 07:57 PM
My Jeep is running rough! ccain Off-Topic 10 06-30-2008 04:00 PM



» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:01 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC