2005 Jeep Wrangler X Engine Surge - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-26-2011, 06:26 PM   #1
Newb
 
Join Date: Mar 2011
Location: massachusetts
Posts: 7
2005 Jeep Wrangler X Engine Surge

I have a 2005 Jeep Wrangler X six cylinder, just started to have some trouble with it today. The Vacuum line that controls the heater switch for defrot and heat fell off the conections near the manifold. re-connected it and now the engine surges when you come to a stop and in drive wants to lurch vechile forward. Put in park surge goes away. Disconnect vacuum line from drivers side engine (by manifold) goes away also. any clues to what is causing this? Could it be TPS?

G Power is offline   Quote Quick Reply
Old 03-26-2011, 07:11 PM   #2
Newb
 
Join Date: Dec 2010
Posts: 5
Did the hose line just fall off or did it more or less melt off? Also I would try just doing an easy battery disconnect and 'reboot' the system. Unless u have an OBD2 plug n' play system I don't know what else to tell you.

Mmonster is offline   Quote Quick Reply
Old 03-26-2011, 09:26 PM   #3
Jeeper
 
Join Date: Mar 2011
Posts: 57
idle

my 05 did the exact same thing. go to page 2 or 3 and look for thread ( idle fluctuation ) and you can get some info.
bob turnbow is offline   Quote Quick Reply
Old 03-27-2011, 06:46 AM   #4
Newb
 
Join Date: Mar 2011
Location: massachusetts
Posts: 7
the hose fell off its happened before.
G Power is offline   Quote Quick Reply
Old 03-27-2011, 06:48 AM   #5
Newb
 
Join Date: Mar 2011
Location: massachusetts
Posts: 7
Thanks for the info, going to clean TPS see if that helps.
G Power is offline   Quote Quick Reply
Old 03-27-2011, 06:52 AM   #6
Jeep Ninja

WF Supporting Member
 
scgeek12's Avatar
 
Join Date: Feb 2011
Location: Norfolk VA
Posts: 1,825
X2 for making sure you unplug the battery for a while after messing with the sensors as well, i was having similar problems to you and i changed my TPS but did not unplug the battery and wasted 2 more days troubleshooting a problem that was fixed already, just put another new tps in and rebooted it by unplugging the battery (i left it over night) and it runs / idles perfect now
scgeek12 is offline   Quote Quick Reply
Old 03-27-2011, 02:02 PM   #7
Newb
 
Join Date: Mar 2011
Location: massachusetts
Posts: 7
Changed TPS and cleaned throttle body. Runs well now. Disconecting electrical to reset computer now. Thanks for everyones reply.
G Power is offline   Quote Quick Reply
Old 03-27-2011, 02:04 PM   #8
Jeep Ninja

WF Supporting Member
 
scgeek12's Avatar
 
Join Date: Feb 2011
Location: Norfolk VA
Posts: 1,825
just another bit of info, i got a cheap duralast TPS from autozone and it lasted about 3 days lol, went to o'reillys and got a borg warner one and it has been fine since, just incase you went with a duralast and start having problems again, GL!

scgeek12 is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Jeep Jokes jeeptales Off-Topic 39 07-24-2013 01:14 AM
Runaway Off Topic Thread amerijeep Off-Topic 2723 01-30-2011 07:19 PM
Jeep Confidence Course at Offutt AFB during Air Show! wasomma General Jeep Discussion 0 08-26-2010 03:18 PM
1999 jeep wrangler 2.5 sport engine starter daxbike TJ Tech Forum 2 05-19-2010 12:37 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 11:45 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC