2005 TJ blows ignition switch fuse - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ General Discussion Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-14-2010, 08:29 AM   #1
Jeeper
 
TJMagoo's Avatar
 
Join Date: Oct 2010
Location: Lisbon, OH
Posts: 31
Send a message via AIM to TJMagoo
2005 TJ blows ignition switch fuse

Hi Guys,
I'm having a heck of a time trying to figure this problem out. I have a 2005 TJ that blows ignition switch fuses. It doesn't do it all the time. As soon as I put the key in and turn it, it blows it. Sometimes, I can go through multiple fuses before it doesn't blow one and fires up. Any idea where to start looking to diagnois this problem? I have an Edge trailjammer kit on there, should I unplug it? This is really irritating the crap out of me. I put a new ignition switch in, thinking that might be the problem, but it's blown 6 fuses since then.

Thanks in advance,
-Kelly

__________________
<a href=http://www.crawltocurecancer.com target=_blank>http://www.crawltocurecancer.com</a>
TJMagoo is offline   Quote Quick Reply
Old 10-14-2010, 09:35 AM   #2
AOR
Sponsoring Vendor

WF Supporting Member
 
AOR's Avatar
 
Join Date: Sep 2010
Location: Mount Aukum, CA - El Dorado County about 55 mins from the Rubicon Trail
Posts: 2,292
Check all cables from the battery to the starter and all the ground connections. Does it do this when turning to the cranking position or just turning it on? Oh yeah! it only takes 5 mins to remove the Edge from the loop. Do that as well. It couldn't hurt and you would eliminate that as a potential issue.

AOR is offline   Quote Quick Reply
Old 10-14-2010, 12:29 PM   #3
Jeeper
 
TJMagoo's Avatar
 
Join Date: Oct 2010
Location: Lisbon, OH
Posts: 31
Send a message via AIM to TJMagoo
It does it when I turn the key to crank it over.

Not a bad idea to remove the Edge from the loop.
__________________
<a href=http://www.crawltocurecancer.com target=_blank>http://www.crawltocurecancer.com</a>
TJMagoo is offline   Quote Quick Reply
Old 08-09-2011, 10:30 AM   #4
Jeeper
 
TJMagoo's Avatar
 
Join Date: Oct 2010
Location: Lisbon, OH
Posts: 31
Send a message via AIM to TJMagoo
It's been a while since I was on here but I wanted to update you guys on what I fiugred out to be the problem. I took AOR's suggestion and unplugged the Edge and haven't blown a fuse since.

Not sure what the problem is/was with the Edge. I contacted them and they never heard of this problem.
__________________
<a href=http://www.crawltocurecancer.com target=_blank>http://www.crawltocurecancer.com</a>
TJMagoo is offline   Quote Quick Reply
Old 08-09-2011, 03:04 PM   #5
AOR
Sponsoring Vendor

WF Supporting Member
 
AOR's Avatar
 
Join Date: Sep 2010
Location: Mount Aukum, CA - El Dorado County about 55 mins from the Rubicon Trail
Posts: 2,292
If it is still under warranty, have them replace it. If not, check for cracks in the wiring, connectors, dirt or metal in the connectors. Nice to hear you got the issue resolved.

Allen
__________________
Allen's Offroad - 530-620-1100
Email me at: sales@allensoffroad.com



Be careful what you wish for. It will come true!
Never miss a good chance to shut up! - Will Rogers
AOR is offline   Quote Quick Reply
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Jeep Wrangler Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Auxillary Lighting Install Writeup erickpl General Jeep FAQ/Stickies 15 09-20-2013 09:28 AM
Auxilary Lighting Writeup erickpl TJ Tech Forum 2 01-06-2011 07:50 PM
Starting troubles mother one YJ Tech Forum 10 09-07-2010 02:05 PM
WTF is with this ignition switch? bluegrass107 YJ Tech Forum 1 07-23-2010 08:30 AM
Clutch Override or Ignition Switch: Starting Issue Beowulf TJ Tech Forum 3 05-07-2009 01:19 PM


logo carid shop wrangler parts carid fender flares custom wheels store avs deflectors at carid
» Rates
Get low rates on auto insurance in Canada!

» Network Links
»Jeep Parts
» Featured Product

All times are GMT -5. The time now is 08:35 PM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC